Sign in to follow this  
Rick Brewster

paint.net 4.0 alpha build 5034

Recommended Posts

Pretty sure im not alone when i say i just wet myself a little. Installing it now, backed up the current version just incase things go pear shaped :D

Gonna post up my first PDN 4 image soon :D

Share this post


Link to post
Share on other sites

There have been discussions about accommodating users with older systems.  Nothing has been decided yet, but Rick hears what you're saying.  :-)

  • Upvote 2

Share this post


Link to post
Share on other sites

Pretty sure im not alone when i say i just wet myself a little. 

 

.. not only a little... 

 

Great job on the alpha. Haven't had any crashes jet... 

 

few thoughts though:

- As gege suggested the Rotation handles should really change.. was not very pleasant editing the following image.

​- Since the Magic wand tool automatically updates while adjusting the sensitivity, there should be a more precise input than just a slider..(for low tolerance it works just fine, but as soon you go over 50%, there is a slight lag spike and you already over adjusted it...)

maybe something like this?

image.png

 

 

Now to something different:

v4.0 marks a new era in the paint.net history... Of course the most important part is the software, but I think the time has come to renew not only the software, but also the logo and website, which if you ask me needs a overhaul very badly... And why not make a competition out of it? You would not have to bother with design stuff and could fully concentrate on the code and the community would do the rest. And if everything turns out bloody potato, don't take it. Nothing to lose there.

 

sorry for being all over the place.. I'm just so excited :D

Edited by Haeri

Share this post


Link to post
Share on other sites

There have been discussions about accommodating users with older systems.  Nothing has been decided yet, but Rick hears what you're saying.  :-)

 

I'm having a hard time convincing my wife I need to spend £xxx amount of pounds on a new system just for a hobby, when this one is working perfectly fine and quick.

 

If I get my own way it's going to cost me double bubble as a pay off tit4tat.  And I'm extremely tight so it could be goodbye from me

 

God forbid if I've got to use Creative Paint by MH :lol: :lol:  (joke)

  • Upvote 1

Share this post


Link to post
Share on other sites

I've found a bug:

 

I keep my taskbar on auto-hide and, when PDN 4 is maximized my taskbar will not show.

Oh, and I am not really liking the change of font for the titles. I'm not sure if there's a way to change this in-app but I prefer the pre-4 font(s).

 

Other than that, really liking it. Good job!

Share this post


Link to post
Share on other sites

I've only found one bug so far: drawing on an invisible layer causes 128x128px blocks to appear and you can see what you're drawing. It doesn't cause any trouble, but it is a bit odd.

Share this post


Link to post
Share on other sites

Rectangle select tells in the statusbar that Area is 0.

Ellipse select tells a value but it is different than in MeasureSelection plugin. But this may be because auf antialiased selection borders.

 

The order of tools in the toolstrip menu is a little bit strange:

  Rectangle Select, Move Selected Pixels, Lasso Select, Move Selection, Ellipse Select, Zoom, Magic Wand

Propose:

  Rectangle Select, Ellipse Select, Lasso Select, Magic Wand, Move Selected Pixels, Move Selection, Zoom

Share this post


Link to post
Share on other sites

I keep my taskbar on auto-hide and, when PDN 4 is maximized my taskbar will not show.

Oh, and I am not really liking the change of font for the titles. I'm not sure if there's a way to change this in-app but I prefer the pre-4 font(s).

 

 

I can reproduce the taskbar bug.

 

And, regarding font rendering, I'm trying to get used to it, but I still prefer it the 3.5 way too. Just out of curiosity, I took a screenshot of Edit menu in both versions and put them side-by-side. Sharpness in previous version is much better, IMO.

3lw.png

Share this post


Link to post
Share on other sites

I'm having a hard time convincing my wife I need to spend £xxx amount of pounds on a new system just for a hobby, when this one is working perfectly fine and quick.

 

If I get my own way it's going to cost me double bubble as a pay off tit4tat.  And I'm extremely tight so it could be goodbye from me

Windows 7 has been out for 4 years. Surely you can find a copy somewhere? I've seen a couple of listings online selling it for $50-100 USD (£30-65 GBP). Much cheaper than a new system, and the prerequisites for Vista and 7 are pretty similar. Plus, 7 is just about the best OS I've ever used.

Share this post


Link to post
Share on other sites

And, regarding font rendering, I'm trying to get used to it, but I still prefer it the 3.5 way too. Just out of curiosity, I took a screenshot of Edit menu in both versions and put them side-by-side. Sharpness in previous version is much better, IMO.

3lw.png

Have you calibrated your ClearType settings? (Control Panel > All Control Panel Items > Display > Adjust ClearType text)

Share this post


Link to post
Share on other sites

First, I want to thank Rick for his hard work in getting this out, and to everyone who may have helped him along (e.g. Ed Harvey).

 

Secondly, I've been having a bit of trouble with the magic wand after moving things. I made a video outlining the problem. Is this happening to anyone else?

http://youtu.be/Ht0zbabe5Hk

 

Also, deselecting with enter or ESC doesn't always work for me...

Edited by Daniels

Share this post


Link to post
Share on other sites

I can't watch the video, "This video is private."

 

If you can get me specific situations where ESC doesn't deselect, that'll help. The best format is a list of step-by-step instructions that starts with launching Paint.NET (a fresh clean slate in other words), although it's not 100% mandatory to format it that way of course.

Share this post


Link to post
Share on other sites

Fixed the video. The basic jist of it is: Open the program. Draw something on a new layer. Use rectangle select to select it, then move it with the move tool, and commit it to the canvas. When I try to select the field with the magic wand, it doesn't select the part where the selection used to be. It's like it's treating it as a different color.

 

With regards to the deselecting:

I launch the program, add a new layer, draw a filled rectangle. I then select it with the magic wand. When I hit enter once, it gets rid of the moveable sampling dot, but if I hit enter a second time, it does nothing. It only occurs with magic wand.

Share this post


Link to post
Share on other sites

Ahh yes. I already have a bug filed for that, although the circumstances are different. The new Magic Wand isn't treating alpha values correctly, and certainly not handling it as well as 3.5 does.

 

In this case, the two "regions" are actually different colors: transparent white (#00FFFFFF) versus transparent black (#00000000). In every sense they are supposed to be mathematically equivalent (any transparent color is equivalent to any other transparent color), the Magic Wand just isn't working correctly here :)

Share this post


Link to post
Share on other sites

The keyboard arrows (up / down / left / right) - don't work when trying to move a selection. Is this one of the known bugs that you are aware of ? 

Yes, I'm aware of this bug. I will absolutely be fixing it!

Share this post


Link to post
Share on other sites

 

- Dancing ants are too nervous. I mean, they move way too fast. This is specially proeminent on small and irregular selections, like those made with Magic Wand. I just compared them with that other big well known image editor and its ants are much more slower than ours :-)

 

 

For now, if this causes you trouble, you can go into settings and un-check "Animations" in the User Interface section.

Share this post


Link to post
Share on other sites

For now, if this causes you trouble, you can go into settings and un-check "Animations" in the User Interface section.

 

Well, it's not like it's causing big trouble. As I said, it's more like a small tweak to improve usability. And I think the other animations (such as when moving layers or reordering image thumbnails) are pretty neat. So, I'll stay with the nervous ants for now :)

Share this post


Link to post
Share on other sites

Have you calibrated your ClearType settings? (Control Panel > All Control Panel Items > Display > Adjust ClearType text)

Yes, I have. And, just to make it clear, both screenshots were taken on the same system, AFTER calibration. So, I assume it's not related to calibration.

 

Again, I don't take this as a big issue. We will end up getting used to it, I think. It's just that, when compared side by side, the old rendering looks better (for me, at least).

Edited by gege

Share this post


Link to post
Share on other sites

Muahah... I already decompiled the .resources and started updating my .resx... I'm unstoppable!

 

Well, I did it too. No more funny/nonsense phrases now :)

In fact, PT-BR it's almost completed. I'm just checking consistency of related strings (like Statusbar tips) and fine tuning the entire set of strings. 

Share this post


Link to post
Share on other sites

Mouse wheel scroll in the layer box!!!!!!!!!!!!!!!!!!!! Yesssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssssss.

 

Not even kidding, this alone would have been enough for me

 

 

EDIT------------- OH mane. Oh mane. Drag and drop layers. BESTEST Xmas EVER!

 

I just did the math. I probably avg. 15 minutes a day of "extra" time due to the damned layer box in v3. Over four years that is 13.38 DAYS. I was THIS close to switching to anohter editor SO many times. Glad I stuck with it. Good work, folks, you did your daddies proud...............   I SAY YA GOT PROUD PAPPIES........

 

 

EDIT  2------- Crashes while attempting to feather. Crashes on liquify

Edited by dmd7978

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this