Sign in to follow this  
Simon Brown

Custom Brushes Plugin 5.1.5

Recommended Posts

I got a problem!

I want to install more brushes to my Paint.NET, but the more I install the more lagg, either lags or stops responding!

Why is it doing this? I Want More Brushes! :cry:

Share this post


Link to post
Share on other sites
Don't seem to work for me...

They are not "animated", each time you use the brush it moves to the next frame.

I got a problem!

I want to install more brushes to my Paint.NET, but the more I install the more lagg, either lags or stops responding!

Why is it doing this? I Want More Brushes! :cry:

Check the size of your brushes, if they are larger than you normally use (file brush dimensions = brushsize^2), crop them.

Share this post


Link to post
Share on other sites

I am considering distributing a brush pack in the same place as the plugin. This may be an post-install brush installer or a seperate version of the plugin. Please notify me in this thread if you wish to give permission to have your brush included along with the brush itself. To be eligable the brush must be completly your own work.

Share this post


Link to post
Share on other sites

Random thought Simon.

You should make a plugin that makes abr's.

It could increase the interchangability between Photoshop and Paint.NET, Myrddin talked about when I suggested a PDN brush.

Share this post


Link to post
Share on other sites

Hi, sorry for the really late reply. I've downloaded and applied the updated CustomBrushes plugin; still no luck. Everytime I click "Draw with Custom Brush" Paint.NET crashes. I've attached my error log (as a zipped file, the forum won't let me upload as it is :?: ).

Another thing, the DLL I downloaded from here says it's version 4.6, yet the title of this topic says 4.8. Is the plugin attachment (on the first post) outdated?

pdncrash.zip

Share this post


Link to post
Share on other sites

cyclone look in your "C:\My Documents\Paint.NET User Files\Custom Brushes" folder. If the folder is empty put a PNG in there. Does that fix it?

Share this post


Link to post
Share on other sites
cyclone look in your "C:\My Documents\Paint.NET User Files\Custom Brushes" folder. If the folder is empty put a PNG in there. Does that fix it?

Hey, you're right! My folder was originally blank, but I just downloaded a custom brush (from that other thread) and moved it into the folder. Now the plugin works, and I can draw! Guess having no brushes in the folder seemed to confuse the plugin :P. Anyways, thanks again to brad.pike for the fix, and Simon Brown for the plugin! And I'll definitely keep an eye on this thread, to check for updates.

Share this post


Link to post
Share on other sites

Okay, I'm having an issue. I was looking for the "My Documents\Paint.NET User Files\Custom Brushes" and I can't find it. Maybe it's because I hit "Open" instead of "Save" when I downloaded it. But I need these brushes very badly. So please, can anyone help me out?

Share this post


Link to post
Share on other sites

is the .dll in the effects folder?

run the plugin once and then go to the user files folder and if it appears

actually run the plugin and press the shortcut in the window to open the brushes folder...

Share this post


Link to post
Share on other sites
Suggestion for Custom Brushes 5.0: Increase quality of preview bar brushes.

I could do that easily if I wanted to, but I reduced the quality to that extent to reduce the amount of memory the plugin occupies, this was my opinion of the lowest setting that allows people to still identify brushes. What would your opinion be of a brush preview panel that shows the selected brush in full quality?

Share this post


Link to post
Share on other sites

Instead of a large view of the brush, in the preview panel, is it possible to have a thumbnail grid like view of them, so only a little bit of quality of lost in the preview? Look at the attachment for further understanding, if you didn't understand the above sentence.

14658_8a47929329ec64c4b4bfe9d918519308

This is probably a bad idea, but i'll run it by you anyway. :P

Also, is there a point of having a second colour in the normal brush mode, as right clicking when brushing doesn't brush in that colour for me.. :?

Share this post


Link to post
Share on other sites
Instead of a large view of the brush, in the preview panel, is it possible to have a thumbnail grid like view of them, so only a little bit of quality of lost in the preview? Look at the attachment for further understanding, if you didn't understand the above sentence.

CB uses an owner-drawn listbox for that section, so this may even require writing a custom control to display them which would require too much work if it were based on the conventional listbox. I may consider, however, simply reducing the physical size of the thumbnails to reduce apparent pixelation.

Also, is there a point of having a second colour in the normal brush mode, as right clicking when brushing doesn't brush in that colour for me.. :?

The secondary colour is used in transitional mode, and it is not used on right-click as that command is already assigned to the spacing option and using the middle mouse button for this would be confusing to users used to the native Paint.NET shortcuts, and moving the spacing command to middle button would again be confusing to people used to right-clicking for this option.

Share this post


Link to post
Share on other sites

I have PDN v 3.35 with OS Windows XP and every time I try to use the custom brush plug-in, PDN crashes. It never did this with PDN v 3.31. I am sure this is a simple fix but I don't know how to do it. This is part of the crash log.

Exception details:

System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.

at System.Drawing.SafeNativeMethods.Gdip.GdipDrawImageRectI(HandleRef graphics, HandleRef image, Int32 x, Int32 y, Int32 width, Int32 height)

at System.Drawing.Graphics.DrawImage(Image image, Int32 x, Int32 y, Int32 width, Int32 height)

at System.Drawing.Bitmap..ctor(Image original, Int32 width, Int32 height)

at System.Drawing.Bitmap..ctor(Image original)

at CustomBrushes.CBDraw.IndexImageBrushes()

at CustomBrushes.CBDraw.CBDraw_Load(Object sender, EventArgs e)

at System.Windows.Forms.Form.OnLoad(EventArgs e)

at PaintDotNet.PdnBaseForm.OnLoad(EventArgs e)

at PaintDotNet.Effects.EffectConfigDialog.OnLoad(EventArgs e)

at System.Windows.Forms.Form.OnCreateControl()

at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

at System.Windows.Forms.Control.CreateControl()

at System.Windows.Forms.Control.WmShowWindow(Message& m)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ScrollableControl.WndProc(Message& m)

at System.Windows.Forms.ContainerControl.WndProc(Message& m)

at System.Windows.Forms.Form.WmShowWindow(Message& m)

at System.Windows.Forms.Form.WndProc(Message& m)

at PaintDotNet.PdnBaseForm.OurWndProc(Message& m)

at PaintDotNet.PdnBaseForm.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

If you need some other part of this crash log, please tell me where and I will send it to you.

Thanks for any help you can give me.

Share this post


Link to post
Share on other sites

it looks like you have a corrupt file either the effect or a brush. the correct place for troubleshooting plugin errors is the topic of the subject plugin... (is that grammatically correct?)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this