Sign in to follow this  
Ego Eram Reputo

Cannot select last visible plugin in stuffed menu.

Recommended Posts

Found this odd behavior today.

When a menu or sub menu is very full, I can't select the last shown plugin. Clicking on it does nothing. In the screenshot - I can't run Lightning.

yhsjjie-1813.png

I know I'm not a typical user - with many more plugins installed than I need. I'm currently doing some compatibility checks on all the plugins. That's why I have plenty of them installed.

This behavior is not limited to one menu. I've had it repro on different menus (Adjustments, Effects, Effect > Tools and Effect > Render) at different times. A slightly smaller monitor changes how much is visible in the menu, but the last item is still not able to be selected.

Seems to be limited to plugins, and not the built in effects. Scrolling the menu down changes which item is not selectable.

Application paint.net 4.0 (α 4.0.5105.6977)

Build Date Monday, 23 December 2013

Expiration Date Monday, 17 March 2014

Hardware accelerated rendering (GPU) True

Animations True

Language en-US

OS Windows 7 Service Pack 1 (6.1.7601.65536)

.NET Runtime 4.0.30319.18052

Physical Memory 4,095 MB

CPU Pentium® Dual-Core CPU E5400 @ 2.70GHz

Architecture x64 (64-bit)

Process Mode 64-bit

Speed ~2699 MHz

Cores / Threads 2

Features DEP, SSE, SSE2, SSE3, SSSE3, XSAVE

Video Card ATI Radeon HD 4350

Dedicated Video RAM 506 MB

Dedicated System RAM 0 MB

Shared System RAM 1,791 MB

Vendor ID 0x1002

Device ID 0x954F

Subsystem ID 0xE990174B

Revision 0

LUID 0x0000AF5F

Flags None

Share this post


Link to post
Share on other sites

I've found the same thing - at times but not always. It's working okay at the moment. Sometimes the menu flickers when you hover the cursor over a plugin

It's not something I ever noticed in 3.5

Share this post


Link to post
Share on other sites

I'm using 3.5.11 and have no problems using a plugin at the bottom of a list - or using the arrow to move to others lower down.

I probably have far too many plugins installed too - mostly versions of ones I'm working on - so my menus are also over full!

 

Hope that helps.

Share this post


Link to post
Share on other sites

I would expect that the ToolStrip renderer has been changed to allow the puzzle symbol for external plugins.

Plus the code to show the copyright info in the tooltip. Maybe there is a small issue.

Share this post


Link to post
Share on other sites

I can't get this behaviour to repeat following a restart. Some sort of transient strangeness.

If I come across it again I'll try and remember the lead up actions.

Share this post


Link to post
Share on other sites

It's back.  Straight from restart and rebooting doesn't resolve it.

 

The highlighting of the entry does work, but intermittently.  It alternates with the plugin tooltip.  A disconcerting pulsating effect :noes:

 

If I hit the entry at just the right time it will fire up the plugin.

Share this post


Link to post
Share on other sites

.  A disconcerting pulsating effect :noes:

 

 

 

That's what I meant.  Not the whole menu flickers

Share this post


Link to post
Share on other sites

The tooltip pops up under the cursor, so the cursor is no longer over the menu item, which makes the tooltip go away, which puts the cursor back on the menu item, which makes the tooltip appear under the cursor, so the cursor is no longer over the menu item, which makes the tooltip go away, which puts the cursor back on the menu item, which makes the tooltip appear under the cursor, so the cursor is no longer over the menu item, which makes the tooltip go away, which puts the cursor back on the menu item, which makes the tooltip appear under the cursor, so the cursor is no longer over the menu item, which makes the tooltip go away, which puts the cursor back on the menu item, which makes the tooltip appear under the cursor, so the cursor is no longer over the menu item, which makes the tooltip go away, which puts the cursor back on the menu item, which makes the tooltip appear under the cursor...

  • Upvote 2

Share this post


Link to post
Share on other sites

I've just made it happen on Tile Image and that's 3 up from the bottom. Weird thing experimenting just now. The last plugin before the lil arrow thing is Tiles Reflection XY but the tip for one of TR's was flashing if I hover the mouse below Tile Reflection but above the arrow (if that makes sense ?)

Personally I think the menu is a bit of a masochist and likes a firm hand as I've noticed that if you're softly softly it happen

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this