Jump to content

Documentation problem


Recommended Posts

Only thing that seems to "float" is the pop-up messages where the text is double underlined. Click on the little x to close or move the mouse away & it will go away after a short time.

Yep, not a screenshot so hard to know what you are seeing, Bean59.

THiGVp.png

Knowledge is no burden to carry.

 

April Jones, 2012

 
Link to comment
Share on other sites

Sorry for the reference to 'screenshot' when I meant link to the page in question. I took a screenshot but was not successful in including it in the post so as an alternative I added the link. I will make another attempt and also view the documentation in Firefox.

post-77008-129724735254_thumb.png

Edited by bean59
Link to comment
Share on other sites

Good, you got the screenshot working. I tried to get it to replicate the problem but BoltBait also asked what browser you are using. It could be a problem with the browser but BB & Pyro are the experts in that field. Sorry I couldn't help much. I am using Google Chrome & it works fine as noted by Pyro.

THiGVp.png

Knowledge is no burden to carry.

 

April Jones, 2012

 
Link to comment
Share on other sites

The problem is with IE7's rendering engine (which is essentially what IE8 Compatibility View is).

Looks like line 13 of style.css is the problem, where both the html document and the body node are set to 100% height. It's an unnecessary declaration to begin with, since both elements are automatically assumed to extend to the height of the content, and it's what's causing the unintended behavior. Percentage declarations set the element to the dimension of its parent, so what IE7 is doing is setting the body to 100% of html, and html to 100% of the window. Ultimately, this means footer gets absolutely positioned at the bottom of the viewspace based on the height of the window, covering over the text there.

I tested nixing line 13 in IE7, IE8, Firefox, and Chrome. The problem was fixed in IE7 with no ill effects in any of the other browsers/versions.

@Rick: I'd suggest your web guy remove that line.

@bean59: I'd suggest that you upgrade to IE8 if at all possible. If you have the IE Developer Toolbar you can go in and deactivate that line to fix it, but you'll have to re-do it every page load.

I am not a mechanism, I am part of the resistance;

I am an organism, an animal, a creature, I am a beast.

~ Becoming the Archetype

Link to comment
Share on other sites

  • 2 weeks later...

Like y'all said, this only happens in IE7. I tried the fix CMD suggested, but it made things look worse in newer browsers.

Since it works fine in IE8 and IE9, and since IE9 is almost RTM, I'm going to leave this alone. Upgrading to IE8/9 is free.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...