Jump to content

Hold Shift Key while dragging Corners stopped working


Recommended Posts

Hi

Here is what I have been doing for years on Paint and has just recently stopped working for me.

1. Select an object from an image with white background

2. Copy the selection

3. Paste the selection into a new image (size 1000 x 1000 pixels) (and into new layer)

4. Resize the object by holding shift key down and drag corners to resize object to keep aspect ratio the same - more often than not I am reducing the size of the object to fit into the new image

 

This last operation (4) does not work for me any more. Has this functionality been removed?

 

Thanks!

Link to comment
Share on other sites

Hi there and Welcome to the forum :).

 

I did exactly your steps above in PDN v4.0.12 and it's working fine for me.

 

I selected the image with the Rectangle Select Tool :RectangleSelectTool:

Went to Edit - Copy

Made a new layer and increased the canvas size

On new layer I went to Edit - Paste

With Shift moved the corners

 

arMc9fo.png

 

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

Maybe your keyboard is wearing out? Are you certain you're using the Move tool :MoveTool:

Link to comment
Share on other sites

RE: tools not working properly.

I created an image by opening a picture and copying and pasting part of the image into a new layer for each copy/paste to create a group from a single person. I merged them down into one layer after moving them around a bit. I applied the ink sketch effect and turned it up until the background (white) flipped over, and then dialed back to white.

After that nothing worked.  I could not apply any tool or effect, period. I tried it again with a totally new file, same steps, and same outcome, once merged down, the final layer was untouchable; select an area and when you release the tool disappears. Magic wand - nothing, a single point (16% hardness) A reboot fixed it.

That didn't help you much, but I feel a little better. good luck.

Link to comment
Share on other sites

On 10/26/2016 at 10:03 AM, Retiredslacker said:

RE: tools not working properly.

I created an image by opening a picture and copying and pasting part of the image into a new layer for each copy/paste to create a group from a single person. I merged them down into one layer after moving them around a bit. I applied the ink sketch effect and turned it up until the background (white) flipped over, and then dialed back to white.

After that nothing worked.  I could not apply any tool or effect, period. I tried it again with a totally new file, same steps, and same outcome, once merged down, the final layer was untouchable; select an area and when you release the tool disappears. Magic wand - nothing, a single point (16% hardness) A reboot fixed it.

That didn't help you much, but I feel a little better. good luck.

 

Gremlins - perhaps ;)

 

But - there are two possibilities that could have contributed to your situation.

 

1.  The tools you tried to use - i.e. Rectangle select, etc., may have been set to :  Subtract, or intersect, etc., and if not set back to 'Replace' the tools won't work.

 

2.  (a) When you tried to select with the magic wand, the 16% hardness was probably too low and it wouldn't select your color. 

     (b) The Rectangle Select was not back on Replace.

    

 

Or ............... Gremlins :D.

Edited by Pixey

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

  • 2 weeks later...

Just to be clear, I had the rectangle select on default - didn't know you could change it, thanks. 16% is too low to detect pixels? Interesting; I think it can be worse than that as just before coming here I could not get a 30% magic wand to select more than one pixel, in a field of grays - sweatpants actually...

Also I still get that weird effect when selecting all then move selected pixel tool, on a SINGLE layer image when I drag the right side left, the original layer shrinks but also remains AS IS underneath. I have pix of that now.

 

What I am led to conclude is that PAINT still has some algorithm issues, and after awhile it's just best to restart the program. When I works with hundreds of files at some point the errors begin and don't correct, so it is just easy to restart. I think it is still helpful to report these things so that maybe it points to how to improve the program. My dream is that one day it will support brushes ala PS... :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...