Jump to content

Line Jumps/Skips to Top of Window while Drawing


Recommended Posts

I'm getting this odd error when drawing lines with both the pen tool and the line tool. I've tried to replicate it in MSpaint and there's no error there, so I'm assuming it's not my tablet that's the problem. Can anyone shed light on this? Thanks!

 

Image attached.

 

ehqLqWL.png

 

post-136690-0-30566500-1403881467_thumb.

Link to post
Share on other sites

Okay. I have a fix for you. Edit: Go to Settings and uncheck "Fluid mouse input" https://forums.getpaint.net/topic/28852-line-jumpsskips-to-top-of-window-while-drawing/?do=findComment&comment=545624

 

 

Download and apply this .REG file (the attachment is a ZIP which contains a REG ... just double click on it). It will disable smooth mouse input via GetMouseMovePointsEx, which allows paint.net 4.0 to get mouse input at >60hz (more specifically, it enables getting mouse input at whatever rate the mouse feels like supplying it). It unfortunately has a bug in Windows 8 and 8.1. The bug causes exactly what you're seeing but only when mouse input is in the top-left quadrant of the monitor (notice how there are no jumps in the right or bottom halves of the screen?). It also happens in Remote Desktop so I automatically disable it in that case. However, apparently it happens in this case too ... I asked about VMWare because that's the other scenario I know of which causes this, but I wasn't able to figure out how to automatically detect it.

 

Before you do this though, can you answer a few questions for me:

 

1. Turning off Windows Ink ... is that a Windows setting or a Wacom Bamboo setting? Where would I find that setting? (maybe I can auto-detect this and then the .REG won't be necessary!)

 

2. What happens if you turn on Windows Ink? Does the problem go away? (you'll then get the "ripple delay lag issue," whatever that is, but I just need a quick test)

 

3. After you apply the .REG, do things work? (this is important ;) please let us know that it worked for you!)

 

Here's the contents of the .REG file:

Windows Registry Editor Version 5.00
 
[HKEY_CURRENT_USER\Software\Paint.NET]
"UI/EnableSmoothMouseInput"="False"
 
If this comes up more often then I'll probably add a checkbox in the Settings dialog for it. Edit: I did!

PDN4_DisableSmoothMouseInput.reg.zip

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to post
Share on other sites

Hey Rick, thanks so much for the quick replies! I really appreciate the feedback.

 

I tried what you said, it seems it doesn't matter if Windows Ink is on or not: Turning Windows Ink on or off is part of the "Set-up your Pen and Touch" control panel. Wacom's driver changelog states that they recently added the option to turn Windows Ink support off which solves a whole host of problems, including the dreaded mini-lag every time you set the pen down. But yeah, they're not related I don't think.

 

I did some more testing and you're absolutely right, it's isolated to the top left corner.

 

Aaaand... YES! That absolutely did fix it! Wonderful. No more weird line jumping. I very much appreciate it, Rick!

Link to post
Share on other sites
  • 9 months later...

As OP's answer isn't very clear about Windows Ink, here's a more in-depth explanation :
Windows Ink is a Microsoft feature that allows some tablet users (depending on the brand and model of the tablet) to write by hand in text boxes. It opens window similar to the on-screen keyboard, but that detects handwriting and converts it (badly) to text.
When Windows Ink is activated (which is the default behavior), movements smaller than about 3mm are not detected. This is very annoying, especially when drawing details.
Windows Ink appeared in Windows XP with the Tablet PC Settings, a set of default drivers for tablets. The only way to deactivate it was finding the service and disabling it.
In June 2013, Wacom released a driver update allowing users to deactivate Windows Ink in the configuration window.
And that's pretty much everything about Windows Ink.

Link to post
Share on other sites
  • 8 months later...
  • 1 month later...

Send your old one this way if you like :mrgreen:

Link to post
Share on other sites
  • 1 year later...

Rick made good on his idea to add this option into the Settings Dialog :Settings:

 

SettingsDialog.png

 

 

  • Like 2
Link to post
Share on other sites
  • 3 weeks later...

Hi, I am using the UGEE M708 graphics tablet and I am having the same issue, do you know if the solution provided will work for this tablet too? Thank You!

 

UPDATE: solved by turning off fluid mouse input. (left for others if they happen to have the same issue)

Edited by LinkInThePark
Link to post
Share on other sites
  • 3 months later...
  • 2 years later...

Hi Rick

 

I have this problem with my fujitsu Q738 tablet and my Wacom bamboo pen and my medical records software.  How do I get to the settings window where I can disable the fluid mouse input on windows 10?  Or is that settings page specific to the paint program?

 

David

Link to post
Share on other sites

I don't know anything about your medical records software. You'll have to talk to them about it. It has nothing to do with Paint.NET.

 

Also, this thread is 6 years old so I'm closing it.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...