Jump to content

CustomBrushesMini v2.2


Recommended Posts

I'm having problems w/CustomBrushesMini v1.9

History - Had Paint.net 3.36 , Orginal CustomBrushes.dll- worked good/great

Updated to 3.5 added CustomBrushesMini(unsure which version) worked fine.

Updates to 3.5.1 -added CustomBrushesMini v1.9 Now I'm getting this error

This plugin has encountered an error, and must be closed.

File: C:\Program Files\Paint.NET\Effects\CustomBrushesMini.dll

Effect Name: CustomBrushesMini.CustomBrushesMiniEffect

Full error message: System.MissingMethodException: Method not found: 'Void

SBCommon.ToolStripNumericUpDown.SetPresets(System.Decimal[])'.

at CustomBrushesMini.Controls.CBToolbar..ctor()

at CustomBrushesMini.CBDraw..ctor()

at CustomBrushesMini.CustomBrushesMiniEffect.CreateConfigDialog()

at PaintDotNet.Menus.EffectMenuBase.RunEffectImpl(Type effectType) in

D:\src\pdn\paintdotnet\src\PaintDotNet\Menus\EffectMenuBase.cs:line 708

Any help will be appreciated.

37025_c09bde4ab252ff8d85f04a4af6588b4a

A generation which ignores history has no past and no future.

Link to post
Share on other sites

Hello again,

1. Is the newest CBM backward compatiable to 3.36? PDN, thought I would get updated plugin pack(if not please tell me and ignore #2)

2. I get this error;

File: C:\Program Files\Paint.NET\Effects\CustomBrushesMini.dll

Effect Name: CustomBrushesMini.CustomBrushesMiniEffect

Full error message: System.MissingMethodException: Method not found: 'System.IServiceProvider PaintDotNet.Effects.Effect.get_Services()'.

at CustomBrushesMini.CustomBrushesMiniEffect.CreateConfigDialog()

at PaintDotNet.Menus.EffectMenuBase.RunEffect(Type effectType)

Thanks for you help,I have tried to "extract to" and put in to effecfs (twice)also I extraced to a seperate file and copy, paste in to effects to no avail, overwriting old each time. :cry:

Thanks again,

Kart

Kart Sig.

KART_PDN_SIG.png

Link to post
Share on other sites

I just downloaded the version 1.9 and extracted it to the effects folder as usual when downloading a plugin, but when I went to run it for a picture I'm working on, a window prompted me to restart Paint.NET ((I have the most up to date sub-version of 3.5 for PDN)) I clicked a button for error details and it gave me this:

File: C:\Program Files\Paint.NET\Effects\CustomBrushesMini.dll

Effect Name: CustomBrushesMini.CustomBrushesMiniEffect

Full error message: System.IO.FileNotFoundException: Could not load file or assembly 'SBCommon, Version=3.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

File name: 'SBCommon, Version=3.0.0.0, Culture=neutral, PublicKeyToken=null'

at CustomBrushesMini.Controls.CBToolbar..ctor()

at CustomBrushesMini.CBDraw..ctor()

at CustomBrushesMini.CustomBrushesMiniEffect.CreateConfigDialog()

at PaintDotNet.Menus.EffectMenuBase.RunEffectImpl(Type effectType) in D:\src\pdn\paintdotnet\src\PaintDotNet\Menus\EffectMenuBase.cs:line 708

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

I restarted Paint.NET several times and continue to get the same error message. What am I doing wrong?

Link to post
Share on other sites

It's working now, thanks.

Edit: It works for a little bit, but it still occasionally gives me errors. Restarting paint.NET seems to alleviate the errors so I can manage....

Edit again: despite adding the file you told me to, the plugin caused PDN to crash on me. I only hope it managed to save my work since it crashed in the middle of the "recomended restart" of PDN.

Link to post
Share on other sites

Hi!

Because I highly value using the CustomBrushesMini (frequently), reporting this problem.

In fact, I'm having the same problem as previously mentioned in this thread.

Was using CustomBrushesMini w/no problems in PDN 3.3.6.

Then...because of Checking For Updates, .NET framework & PDN updated to lastest.

So..now using PDN 3.5.1, went to use CustomBrushesMini & was notified newer avail.

So downloaded/extracted lastest zip bundle to PDN Effects folder.

Here are the version(s) of these 2 DLLs:

CustomBrushesMini.dll v1.9.0.0

SBCommon.dll v3.0.0.0

So, I can access & doodle within CustomBrushesMini screen, but after clicking OK, doodle(s) disappear upon returning to the main PDN screen - this behaviour never occurred in PDN 3.3.6

OS is XP Home SP3.

Let me know if I can supply additional info to assist in debugging.

Peace...John

Link to post
Share on other sites

Yes - this is quite the mystery.

Here's some more info that may help to debug.

Uninstalled PDN 3.5.1

Reinstalled PDN 3.3.6

Placed these dlls in the now empty Effects folder:

CustomBrushesMini.dll v1.7.1.0

SBCommon.dll v2.0.0.0

And...all was well once again - custom paintstroke made it's way back to main PDN screen.

Then....clicked on Check For Updates & allowed PDN to be once again updated to v3.5.1

Did not change/update any Effect dlls.

Problem occurred once again.

Also...I took note of this when the process was successful:

- draw custom paintstroke on Custom screen

- click OK to return to main PDN screen

- a little popup screen quickly appears/disappears on top of main PDN screen (status for a process-in-progress?)

- custom paintstroke appears on main PDN screen

When the process is failing, this little popup screen does not appear at all.

It goes straight from custom-to-main screen(s) without any intervening process.

Hopefully this info may help.

I'll remain at PDN 3.3.6 in order to use CustomBrushesMini.dll v1.7.1.0.

Thanks & Peace...John

Link to post
Share on other sites

howdy, i posted this on the draw with photohop brushes tutorial aswell to ensure that it gets answered,s orry if i piss anyone off :)

im having some didfficulties with this. i can upload the brushes easily, get them into paint.net etc, but it has some weird bugs.

if i put a brush on my canvas, undo it, then put the brush on again, and stuff up again and decide to undo it, it wont undo. so basically i can only undo it once =[

also, i cant delete brushes from the selection of brushes on the side when in paint.net. Is there a way to delete some of the brushes because some i dont want anymore?

please help me if u have a solution to these problems :)

Link to post
Share on other sites
if i put a brush on my canvas, undo it, then put the brush on again, and stuff up again and decide to undo it, it wont undo. so basically i can only undo it once =

Make sure you're using the latest version. Yes, I should really put the version number in the titlebar.

also, i cant delete brushes from the selection of brushes on the side when in paint.net. Is there a way to delete some of the brushes because some i dont want anymore?

Go to Documents\Paint.NET User Files\Custom Brushes and delete the brushes there, but not while CBM is running.

KaHuc.png
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...