Jump to content

Paint.Net Installer Crash


Recommended Posts

Previous thread I posted to bleepingcomputer.com when trying to resolve my microsoft.net framework issues that explains things in more detail: https://www.bleepingcomputer.com/forums/t/691667/issues-with-microsoft-net-framework/

Basically, my Installer finishes extracting the files, attempts to load the next segment for a few seconds and then crashes. (A classic "this program has stopped working error message appears) Before I did what's listed in the above post, the installer would just completely stop working after the extraction, and nothing would happen at all. All the other information that I'm too lazy to type out is in the above post.

 

Link to comment
Share on other sites

Hello @dagwimweaper and Welcome to the forum :)

 

I'm sorry but we can't go to another site to review your issue.  Please give us more information about your operating system and whether you are trying to install the Classic or Store version.

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

I'll copy and paste some of the info from the other site then, if that's okay. My operating system is Windows 8.1 and I'm trying to install the classic version.

 

  • Members
  • 47 posts
  • ONLINE
  •  
  • Local time:01:14 PM

Posted Yesterday, 01:53 PM

From Other Site:

Not sure if I should post this here, but I've posted issues here before and the support was excellent, so i thought I would try again. I posted this on the microsoft community forums as well but answers are scarce there and usually unhelpful.

So, I recently purchased a used laptop. (It should be noted that when I got this laptop the resellers had upgraded it to windows 10, which the computer couldn't properly handle, so I wiped the hard drive and installed a fresh version of Windows 8.1.) I noticed that many of my programs were having issues installing, most of them saying they require the latest version of Microsoft.NET Framework. So, I downloaded Microsoft Framework 4.7.2, and tried to install it. At first, the installation failed and had an error message. I don't remember what it said, unfortunately. Then it started saying it was already installed. I checked my windows features to see if this was true, and it didn't appear in the features, or in the place where you uninstall programs. However, I did have an older version of Microsoft Framework, I think 3.0, but I'm not sure. I thought maybe the failed installations had left residual files behind causing my computer to think it was already installed. So after that I tried deleting the Microsoft.Net folder like an idiot, which just made things worse. At that point I started googling fixes, and found a tool that completely removes all versions of Microsoft.Net Framework from your system. I ran it and removed everything, but the installer still says the framework is already installed, and I am still getting errors from programs saying they need the framework to run. This is the tool I used to cleanup: https://www.raymond.cc/blog/wp-content/plugins/download-monitor/download.php?id=2599

 

Edit: I ran a setup verifier tool for microsoft net (this one:https://www.raymond.cc/blog/wp-content/plugins/download-monitor/download.php?id=3006) and collected logs, and I also ran the official net repair tool and collected logs. The logs are attached. (I'll send the logs on here as well if you need them.)

 

 

So basically I worked through with the helper on the other website and I believe I fixed the microsoft framework by running an sfc scan thing, and then running another command to repair the corruption. After that the paint installer wasnt crashing immediately, but still wasn't working. (Read Above)

 

Sorry if this is hard to understand, there's a lot of information I had to write and I'm horrible at explaining things.:/

Link to comment
Share on other sites

Right, to start please try this tool to remove any left over things from previous installs:

 

https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

 

Then try to install afresh.  Good Luck.  Let us know what transpires :)

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

Okay, then we wait until someone else can help you.  It's just a guess, but it sounds like your computer is a tad messed up :)

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to comment
Share on other sites

2 hours ago, dagwimweaper said:

so I wiped the hard drive and installed a fresh version of Windows 8.1.

 

Have you installed all the Updates?

Link to comment
Share on other sites

A fresh copy is bound to have multiple updates awaiting it. Keep updating and rebooting until no new updates show up.

Link to comment
Share on other sites

Try installing the .NET Framework https://www.microsoft.com/en-us/download/details.aspx?id=56115

 

Once that is finished, try installing Paint.NET again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...