recursor

Sprite Animation Helper (v 0.94 updated October 28, 2016)

Recommended Posts

boudewijn    0

Is there a 64 bit version of this plugin. I installed the current version in my PDN effects folder but it does not show after starting PDN. There is no animation submenu under effects.

***

Added later, OOPS, I was too fast. I apologize. It shows as soon as I have an image open.

Edited by boudewijn

Share this post


Link to post
Share on other sites
Jorichi    1

Hello there!

 

I just must say that you've done an awesome job with this plug-in recursor. I really love it!

This is easily one of the most used function that I have in Paint.net now and it's really paying off lately.

It saves me buckets of time on checking how fluid the animations are of my sprites for my first game project: Becky

4d51a53ac9.gif

A link for those interested in this little project:

http://jorichi.tumblr.com/post/120936611137/quite-a-while-ago-ive-drawn-becky-for-the-first

 

She has a ton of moves and the spritesheet is getting kind of out of control at this point. XD

And because of that I stumbled upon an error. When sampling an area for animation previewing beyond the 3000 pixel mark it gives me an error.

The error tells me it's limited to within these values.

I was wondering if this is intentional or if this will be fixed. It's something I can easily work around by moving the sprites around a bit anyways.

 

My main reason for asking this is if you're still planning on working on this plug-in in terms of expanding and/or updating it (since the last update was almost a year ago).

For example I was hoping to see a multiple layer sampling feature (if that's even possible) in the Animation Helper or an option that alligned a new row to be sampled on the same X Offset if the amount of collumns have been exceeded.

I can understand if you no longer want to/can work on this, it's already great as it is!

  • Upvote 1

Share this post


Link to post
Share on other sites
recursor    3

Hi Jorichi,

 

That is a nicely drawn and animated character. I'm Glad you find the plugin useful. I just updated the plugin to address the x and y offset value limits of 3000. Now they can be set up to 10,000.When I originally did the plugin, you could only get data from the currently selected layer, but that might have changed.

I am currently busy with some other stuff but I will make a note to look into it. A Multi-Layer sampling feature would be really neat.

 

PS Sorry I didn't see this until now. I somehow was not following my own topic!

Edited by recursor

Share this post


Link to post
Share on other sites
Jorichi    1

Awesome! Thanks for the little update, it makes working on my sprite-sheet a whole lot easier ^.^

Also good luck with the other stuff you're working on!

Share this post


Link to post
Share on other sites
LucasMS    0

Just registered to say: "Thanks for this great plugin!"
I'm sure it will help me a lot on my sprite-stuff, just did the first tests and all went smoothly.
I was getting tired already of creating and always changing python / ruby scripts for my batch spritesheet work needs.
Now I'll be able to spend more time programming the actual game! :D

Edited by LucasMS

Share this post


Link to post
Share on other sites
bmkorkut    0

Hi, I guess I found a bug that occurs when you have a non-zero offset with multiple rows.

 

I have my frames ordered vertically; 15 rows, single column. The whole image is 256x256. When I got the following settings:

 

frame size: 64x16 

offset: 16x16

columns: 1

frames: 15

 

the first frame is shown on the preview, others are lost (going to wrong coordinates).

 

When I move my image to the left of the canvas and set the X offset to 0 accordingly, the frames are displayed correctly.

 

It looks like the offset value is only added to the first row.

 

Thank you for this useful plug-in!

ewwNMq6.gif

Share this post


Link to post
Share on other sites
recursor    3

That's not a bug but is the intended behaviour. However, I can see where the behaviour you are describing would be useful especially if the animation frames are in columns instead of rows. Give me a couple of days and I'll add a checkbox to apply xoffset to all rows. Thanks for the feedback. :)

Edited by recursor

Share this post


Link to post
Share on other sites
recursor    3

Is there a way to manipulate the speed of the animation with out making multiple frames?

The plugin supports changing the speed of the animation by adusting the FPS parameter, but no it doesn't support different timings for each frame.

Share this post


Link to post
Share on other sites
Dirakia    0

Hi, i got a small problem

The file i wanted to be done is not as expected:

.GIF instead of .BMP

only 1 frame got animated

Background isnt transparent

Heres everything recorded for further infos 

Share this post


Link to post
Share on other sites
recursor    3

Hi, i got a small problem

The file i wanted to be done is not as expected:

.GIF instead of .BMP

only 1 frame got animated

Background isnt transparent

Heres everything recorded for further infos 

 

Thanks for the video. I'll look into it,

Also, do you have any plans on open sourcing the plugin?

No plans for that.

I have my desktop scaling set to 150% and the effects dialog is not usable at all. Have a look at the screenshot:

2nrjwxv.jpg

 

Thanks. I'll look into possible solutions.

Share this post


Link to post
Share on other sites
midora    201

JFI: My display scaling is 250% and as wouter said the dialog is not usable.

You should know that Paint.NET tells the OS that the application is high dpi aware. So there is no auto-scaling active.

A lot of plugins which are not property-based do not support display scaling.

Share this post


Link to post
Share on other sites
recursor    3

Hi, i got a small problem

The file i wanted to be done is not as expected:

.GIF instead of .BMP

only 1 frame got animated

Background isnt transparent

Heres everything recorded for further infos 

Just had a chance to look at your video, and you are using an older version of the plugin. There is a newer version you should try that fixes some issues with exporting animated gifs.

Share this post


Link to post
Share on other sites
Dirakia    0

Just had a chance to look at your video, and you are using an older version of the plugin. There is a newer version you should try that fixes some issues with exporting animated gifs.

Thanks for the info ^^

But i still have a problem xD

I cant save it as a BMP. animated sprite :T

Share this post


Link to post
Share on other sites
corleoner    0

Any idea what my problem may be?

 

I've downloaded the dll into my effects directory.  I've restarted paint.net several times, still not seeing it in my menu.

 

 

post-147280-0-23179700-1463498230_thumb.

post-147280-0-59813800-1463498235_thumb.

Share this post


Link to post
Share on other sites
corleoner    0

[solved]

 

Updated paint to the newest version and it works now. 

 

Second question:  Is there a plug in (or another simple method), to break down a gif into frames which would be compatible in the format used by your plug in?  I think I found a couple that I'm experimenting with that may be ok, but wasn't sure if there was a newer one that you may have developed.

Edited by corleoner

Share this post


Link to post
Share on other sites
recursor    3

[solved]

 

Updated paint to the newest version and it works now. 

 

Second question:  Is there a plug in (or another simple method), to break down a gif into frames which would be compatible in the format used by your plug in?  I think I found a couple that I'm experimenting with that may be ok, but wasn't sure if there was a newer one that you may have developed.

I have not yet had the need to pull in an animated gif and edit its frames individually so I'm afraid I'm not much help there.

Edited by recursor

Share this post


Link to post
Share on other sites
kuenzign    1

Hey, I was trying to use this plugin to separate a picture into separate pictures and I believe that I can do that with this plugin.  My issue is that the maximum width and height of a cell is 1000px.  For this image, I need 735px x 1024px cells.  Could you please either remove the maximum or raise it to something larger?  It would be greatly appreciated.  :)

Share this post


Link to post
Share on other sites
Fruggy    0

I can't install the latest version of Paint.net so I have Paint.NET v3.36. Is there any way to get this to work with it? I have put it in the Effects folder and made sure the dll isn't locked, but it doesn't show up in the effects tab.

 

Thanks.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now