Jump to content

issue tiff saving and custom tags (double arr)


Recommended Posts

Hi

There is an issue saving custom tiff tags:  "double" array changes to "undefined"  (see "orig" tag attach to "saved").

Note: Double Arrays are saved  with field_passcount = TRUE, first param before data is fieldcount!    (e.g. libtiff: TIFFSetField(PTiff, MY_CUSTOM_DATA, 5, Data))

I can not say whether it happens also for a single double or other Array data types.

I added a tiff with custom tags so you can try out.

Best regards

Stefan

 

tiftags_orig.PNG

tiftag_saved.PNG

test.zip

Link to post
Share on other sites

 

On 7/11/2011 at 12:14 PM, Ego Eram Reputo said:

TIF support in paint.net is minimal and provided on a "Gee if it works - that's great" basis ( http://forums.getpaint.net/index.php?/topic/19468-lab-color-space/page__view__findpost__p__330287)

 

This means that there is unlikely to be a change in the way PDN handles TIF images. Especially since you're using custom tags.

 

Do you really, really, really need to use TIF?

Link to post
Share on other sites
  • 1 year later...

BTW this probably works a lot better in the latest version (currently 4.2.7). I've put in a whole bunch of metadata related work into the 4.2 series of updates.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...