Jump to content

Unable to complete installation of version 5.0.1 in Windows 11

Go to solution Solved by toe_head2001,

Recommended Posts



I am unable to complete the installation of version 5.0.1 in Windows 11. I am attaching a screenshot showing the installer's message.

This applies to all sorts of installation: offline exe/msi installer, online installer and auto updating from version 4.3.12 (by selecting the "Update when I exit" option). Also, this happens in several separate computers running Windows 11.






Link to comment
Share on other sites

  • Solution

Sounds like you have an existing paint.net installation that has become broken. Please use this utility to remove the broken installation:



Afterwards, you should be able to install paint.net anew.

(September 25th, 2023)  Sorry about any broken images in my posts. I am aware of the issue.

My Gallery  |  My Plugin Pack

Layman's Guide to CodeLab

Link to comment
Share on other sites

I have the same exact problem, and the Microsoft Remover Tool doesn't find paint.net in the removable list.
I Deleted every single file of Paint.net after I uninstalled with Everything to see if it would work but it doesn't.

What made me uninstall paint.net? It's kinda strange.
So everything was fine before I Updated Boltbait's Plugin to the latest version supported for Paint.net 5.0 and Over(I had paint.net version 5 with Boltbait's plugin Pack for version 4), After I updated the Plugin with the use of the .exe installer from Boltbait, I tried opening Paint.net and it started going downhill from there... It just wouldn't start.
I went to uninstall paint.net, deleted the rest of the files in temp and %temp% folder, and used Everything to delete the remaining folders Paint.net left, folders were: paintdotnet. I restarted my computer and tried installing paint.net through every installer and it just wouldn't work, on the msi installer the installer blocked itself and crashed(left with the tab open) and the other installers would be really really slow and then not function anymore. What I found interesting is that if I opened process hacker as admin and searched paint on the search box, it would find me 4-6 instances of paint.net all in an orange box meaning that they were blocked/shutting down?

Another really strange occuring is that if I tried to reinstall paint.net version 4 and over(before version 5) it would still give me the same problems! 
Seriously I do not know if I broke something in my Computer or that there is something stopping paint.net from installing itself, Please, I need Help.


OS: Windows 11 Pro 22H2 Build 22621.1194

CPU: AMD Ryzen 5 2500u

GPU:AMD Radeon RX Vega 8

Link to comment
Share on other sites

Try using Revo Uninstaller to remove any traces of PDN. Then try reinstalling the latest version.

Link to comment
Share on other sites

I did it already, by the way i found the problem, It was the Latest Windows 11 Release that glitched Paint.net, I went back to the version I had before and it worked, paint.net now opens and functions properly.

PS: I disabled GPU Acceleration cause it Lags at Startup and Editing, now it feels really really fast with it turned off and set to CPU Power.

Link to comment
Share on other sites

  • 2 weeks later...

Windows 10 x64 with all updates.

PaintNet 5.0 and 5.01 behaving strangely, I always uninstall, restart, install using Revo Installer Uninstaller, never had an issue...

PaintNet 5.0 was a puzzle I download the exe, installation window shows it has completed, yet no icon shortcut on desktop, I restart PC same I look in C Programmes, here in I find a PaintNet folder within is an EXE double click it installs again from start (as if never installed, but finally works... However, updating to 5.01 removed? Uninstalled? PainNet

now unable to install an old version, I attempted without using Revo, paint.net.4.3.11.install.anycpu.web nothing installed, goes through the motions, however nothing there or in C programmes.

I am proceeding with Admin pro_head2001 suggestion.

P.S an abnormal Cursor behaviour very difficult, jumps all over the place... suggesting OS corruption?

OS: Windows 11 Pro 22H2 Build 22621.1194

CPU: Intel i7 Quad HQ

SSD: NVMe 250 G
GPU: Nvidia  1070 8 G

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...