Jump to content

Install silently fails


Recommended Posts

On Windows 10, the installer is silently failing. I already have .Net 4.6.1 installed. I've gone through the install troubleshooting thread, but nothing there has made a difference. PDN was never previously installed on this computer (it's brand new).

 

Here're the contents of pdnSetupShim.log, which I'm not permitted to attach, for whatever reason:

--- paint.net SetupShim starting, lpCmdLine='/suppressReboot', nCmdShow=10
CoInitialize(NULL) returned 0
Checking OS requirement
    bIsWin7SP1 = true
    bResult = true
EnsureOSRequirement() returned 0
Called EnsureTrustedInstallerIsEnabledAsync()
Checking .NET requirement
    bIsNetfx46Installed = true
    bIsSupportedNetfxInstalled = true
    bIsNetfxInstallerPresent = true
PreInstallPrompt() returned true
InstallNetfx() returned 0
Launching paint.net installer. bRebootRequired=false
Done. nReturnVal=-1
Sleep(1000)
--- Exiting, nReturnVal=ffffffff


When I run the installer, it extracts the files it needs, then I see another window open for a fraction of a second and then it all immediately closes. I'm guessing this corresponds to the "Launching paint.net install" and "Done." lines.

 

While everything is being extracted, I can see lots of things being put into %temp%\PdnSetup, but as soon as the program exits it all gets cleaned up. There's no opportunity to pause between when the files are extracted and the program cleans it up and exits.

 

What else should I look at?

Link to comment
Share on other sites

Hello and welcome to the forum dcormier :D

Try running this diagnostic tool http://forums.getpaint.net/index.php?/topic/107908-1603-error-diagnostic-tool/ (just follow the instructions included in the thread).

Link to comment
Share on other sites

When I run that tool I get this:

 

post-147927-0-61034300-1467897911_thumb.

 

Here's the pdn.log, which I'm not permitted to attach:

=== Verbose logging started: 2016-07-07  9:24:18  Build type: SHIP UNICODE 5.00.10011.00  Calling process: C:\Windows\SysWOW64\msiexec.exe ===
MSI (c) (C8:90) [09:24:18:724]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg


MSI (c) (C8:90) [09:24:18:724]: Font created.  Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg


MSI (c) (C8:54) [09:24:18:735]: Resetting cached policy values
MSI (c) (C8:54) [09:24:18:736]: Machine policy value 'Debug' is 0
MSI (c) (C8:54) [09:24:18:736]: ******* RunEngine:
           ******* Product: PaintDotNetMsi\PaintDotNet_x64.msi
           ******* Action: 
           ******* CommandLine: **********
MSI (c) (C8:54) [09:24:18:736]: Note: 1: 2203 2: PaintDotNetMsi\PaintDotNet_x64.msi 3: -2147287037 
MSI (c) (C8:54) [09:24:18:737]: MainEngineThread is returning 3
=== Verbose logging stopped: 2016-07-07  9:24:18 ===

The PDN installer is in the same directory, with its original name (in case that matters).

 

I enabled MSI logging (set the installer logging registry value to voicewarmupx) and ran the installer normally, but no MSI log was created.

 

Link to comment
Share on other sites

That diag tool is lying to you. The msi package was never created; the setup aborted before it could happen.

I assumed there would never been any issues with creating the msi, so there isn't any verification at that step. It should say "Failed!" instead of "Done." I'll have to update the tool.

 

As a workaround, my advice would be to create an msi file on another computer, and then run that msi on the computer having the issue.

Link to comment
Share on other sites

I do see the MSIs being extraced into %temp%\PdnSetup when I run the installer. Process Monitor confirms that PaintDotNet_x64.msi and PaintDotNet_x86.msi are both written to that directory. Again, everything in %temp%\PdnSetup is deleted after the process exits and there's no opportunity to pause before that happens.

 

If I run the installer on another machine, copy the %temp%\PdnSetup directory over, then run PdnSetup\SetupFrontEnd.exe it does seem to work.

 

Should I go ahead with this, or are you (either of you) willing to do more investigation to find out why running the installer doesn't work? I'm leaning towards the latter, since at some point I'll want to do an upgrade and probably won't have another laptop on my desk.

Link to comment
Share on other sites

I had the same exact problem that you are having; where during the install process the file would unzip everything and then ask me if I wanted to install .NET and paint.net., but after it finished unzipping everything the program closed out and all the files that it had unzipped disappeared. I even had the temp folder it created open and watched as all the files disappeared after the install program had finished unzipping.

 

My name is what happened next. After a cool-off period and contemplating ways of breaking my laptop (I am running Windows 8.1) I decided to try a fresh approach.

 

First I cleared the event logs on my computer:

Step 1: Windows key + R

Step 2: typed: eventvwr.msc

Step 3: Once the Event Viewer launches, double-click and expand Windows Logs.

Step 4: Here Right-click on Application option and choose Clear Log.

Step 5. Perform the same operation and clear the Security, Setup, and System log.

 

Afterwards I ran Optimize/defrag on my laptop followed by rebooting the laptop.

 

I then went to Control Panel -> Programs and Features -> clicked Turn Windows features on or off -> Checked every box that had to do with .NET Framework

I let the Windows do it's thing before proceeding to the next phase.

 

I then used the help guide provided by this website: http://forums.getpaint.net/index.php?/topic/692-install-update-or-uninstall-trouble-read-this/

Went to Step 5

Clicked on the link provided in Step 5 B

Downloaded Netframework Repair Tool

Installed and ran Netframework Repair Tool

It found several issues which it corrected.

I then did another reboot of the laptop.

 

I then double checked Windows Update to see if there were any new updates available and downloaded them and did another reboot.

 

After the laptop rebooted I installed paint.net again and this time it started working. It linked me to the .NET website to download the updated .NET 4.6.1. After which I reinstalled paint.net and it completed the install process and now I can use it on my laptop.

 

Hopefully this helps you out.

Edited by LostMyMarbles
  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...