Jump to content

ctrl + mouswheel zoom skips 100%


Recommended Posts

Known bug, and mostly unfixable since everyone's scroll wheels send different information to the program. Mine, for instance, does not skip 100%. A few other people's hit 90% before skipping to 102%. Sorry.

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

Problem with that ctrl + shift + a hotkey is it brings up Trillian, and there is no setting to remove the hotkey in it's preferences. I'm confused as to why the tick count would make it impossible to fix this bug. Why couldn't you just check the new value against the old and if its less then 100% from above 100% set it to 100%. As someone who programs for a living, this shows either a design flaw or lazyness.

Link to comment
Share on other sites

Hey, I have an idea. How about if you don't tell Rick what's lazy or bad design until you program your own award-winning free graphics software, eh? If you're so 1337, fix Trillian so it won't pop up when you use this shortcut.

The point is, you don't know how easy or hard it would be. So don't make it sound like you do.

If your next post in this thread isn't an apology, it will be locked.

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

I do apologize, the developers are obviously not lazy. It's more likely just not a priority. I havn't gone over the source enough to comment on the design either.

However, and I ask this on a "I would really like this fixed" basis, wouldn't adding:

if (this.ScaleFactor > ScaleFactor.OneToOne && newSF < ScaleFactor.OneToOne)
{
   this.ScaleFactor = ScaleFactor.OneToOne;
   break;
}

to the "public virtual void ZoomIn(double factor)" function of the DocumentViewer class's do loop after the newSF declaration fix this problem?

Link to comment
Share on other sites

Yes please use tact when discussing these things. Key words to avoid are "easy" and "lazy".

I've got a bug filed on this already but I just haven't looked at it yet. I've sent myself a new reminder and will look at doing this for v3.5. I'm in the middle of a whole mess of important text and font related stuff though, so don't necessarily expect it in the next alpha update.

For now just press Ctrl+Shift+A or Ctrl+Alt+0. Both are shortcuts for setting the zoom level to 100% (the second does work even though it isn't listed in the View menu -- just use whichever one you're most comfortable with).

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...