Jump to content

Anti-aliased lines


Arc
 Share

Recommended Posts

I was wondering if the Devleopers could make thinner lines for the anti-aliasing for rounded rectangles. y'know just one pixel thickness without it being transparent/faint. I've got the latest version of PDN so I was wondering if it could be included in the next upgrade.

Link to comment
Share on other sites

It does seem that no matter where you start drawing, you can never get a 1 pixel width line.

RoundedRectangle.png

I believe that Rick is using GDI+ for drawing shapes, so this is more a problem with Windows than Paint.NET. So, don't hold your breath waiting for a fix.

If you need finer lines, you may want to mix a rounded rectangle and a normal rectangle yourself.

Click to play:
j.pngs.pngd.pnga.pngp.png
Download: BoltBait's Plugin Pack | CodeLab | and how about a Computer Dominos Game

Link to comment
Share on other sites

That is true but I'm a comicer. Iuse .Net for effects and speechbubbles. And I did attempt the methoed you just suggested,but whenever I add tails and use the paintbcket tool to fill it, it covers my entire background in white. If someone can tell me a way round this, please tell me.

Link to comment
Share on other sites

That is true but I'm a comicer. Iuse .Net for effects and speechbubbles. And I did attempt the methoed you just suggested,but whenever I add tails and use the paintbcket tool to fill it, it covers my entire background in white. If someone can tell me a way round this, please tell me.

Try turning down the tolerance on your bucket fill.

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

...but whenever I add tails and use the paintbcket tool to fill it, it covers my entire background in white. If someone can tell me a way round this, please tell me.

Add the rectangle on a second layer with the blending mode set to 'Multiply' or 'Darken'...should work like a charm.

 

Take responsibility for your own intelligence. ;) -Rick Brewster

Link to comment
Share on other sites

Another option is to click the :AntiAliasingOn: to turn it into :AntiAliasingOff: . The corners will be jagged, though. To overcome that, increase the size of your image using the Nearest Neighbor option by about 200-400%, create your shape with a width 2-4x the width you want, then resize it back down using SuperSampling.

xZYt6wl.png

ambigram signature by Kemaru

[i write plugins and stuff]

If you like a post, upvote it!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...