Jump to content

blurring bug?


Recommended Posts

Hi, I was making a signature for a forum today and once I had put my images on and got so far, I went to put another layer on, and the whole image went blurry.

I clicked the undo button and the image stayed blurred.

I tried several different options, even saving it before I put in a new layer, closing it then re opening it, but sometimes when I re open it, the image is still blurred.

I included the crash file.

This text file was created because Paint.NET crashed.
Please e-mail this file to paint.net@hotmail.com so we can diagnose and fix the problem.

Application version: Paint.NET v3.07 (Final Release build 3.07.2683.42092)
Time of crash: 02/06/2007 23:04:03
Application uptime: 00:16:48.7580000
OS Version: 6.0.6000.0 Workstation x86
.NET Framework version: 2.0.50727.312 x86
Processor: 1x "Mobile AMD Sempron(tm) Processor 3400+" @ ~1808MHz
Physical memory: 958 MB
Tablet PC: no
Locale: pdnr.c: en-US, hklm: en-US, hkcu: n/a, cc: en-GB, cuic: en-US

Exception details:
System.InvalidOperationException: ScratchSurface already borrowed: 'PaintDotNet.DocumentWorkspace.DoSaveAs() handing off scratch surface to DoSaveAsDialog()' (trying to borrow for: 'PaintDotNet.DocumentWorkspace.DoSaveAs() handing off scratch surface to DoSaveAsDialog()')
  at PaintDotNet.DocumentWorkspace.BorrowScratchSurface(String reason)
  at PaintDotNet.DocumentWorkspace.DoSaveAs()
  at PaintDotNet.DocumentWorkspace.DoSave(Boolean tryToFlatten)
  at PaintDotNet.DocumentWorkspace.DoSave()
  at PaintDotNet.AppWorkspace.CommonActionsStrip_ButtonClick(Object sender, EventArgs`1 e)
  at PaintDotNet.CommonActionsStrip.OnButtonClick(CommonAction action)
  at PaintDotNet.CommonActionsStrip.OnItemClicked(ToolStripItemClickedEventArgs e)
  at System.Windows.Forms.ToolStrip.HandleItemClick(ToolStripItem dismissingItem)
  at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
  at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
  at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
  at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
  at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
  at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
  at System.Windows.Forms.Control.WndProc(Message& m)
  at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
  at System.Windows.Forms.ToolStrip.WndProc(Message& m)
  at PaintDotNet.SystemLayer.ToolStripEx.WndProc(Message& m)
  at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
  at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
  at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
------------------------------------------------------------------------------

mypaintsig-1.jpg
Link to comment
Share on other sites

Hi, I was making a signature for a forum today and once I had put my images on and got so far, I went to put another layer on, and the whole image went blurry.

I clicked the undo button and the image stayed blurred.

I tried several different options, even saving it before I put in a new layer, closing it then re opening it, but sometimes when I re open it, the image is still blurred.

I included the crash file.

This text file was created because Paint.NET crashed.
Please e-mail this file to paint.net@hotmail.com so we can diagnose and fix the problem.

Application version: Paint.NET v3.07 (Final Release build 3.07.2683.42092)
Time of crash: 02/06/2007 23:04:03
Application uptime: 00:16:48.7580000
OS Version: 6.0.6000.0 Workstation x86
.NET Framework version: 2.0.50727.312 x86
Processor: 1x "Mobile AMD Sempron(tm) Processor 3400+" @ ~1808MHz
Physical memory: 958 MB
Tablet PC: no
Locale: pdnr.c: en-US, hklm: en-US, hkcu: n/a, cc: en-GB, cuic: en-US

Exception details:
System.InvalidOperationException: ScratchSurface already borrowed: 'PaintDotNet.DocumentWorkspace.DoSaveAs() handing off scratch surface to DoSaveAsDialog()' (trying to borrow for: 'PaintDotNet.DocumentWorkspace.DoSaveAs() handing off scratch surface to DoSaveAsDialog()')
  at PaintDotNet.DocumentWorkspace.BorrowScratchSurface(String reason)
  at PaintDotNet.DocumentWorkspace.DoSaveAs()
  at PaintDotNet.DocumentWorkspace.DoSave(Boolean tryToFlatten)
  at PaintDotNet.DocumentWorkspace.DoSave()
  at PaintDotNet.AppWorkspace.CommonActionsStrip_ButtonClick(Object sender, EventArgs`1 e)
  at PaintDotNet.CommonActionsStrip.OnButtonClick(CommonAction action)
  at PaintDotNet.CommonActionsStrip.OnItemClicked(ToolStripItemClickedEventArgs e)
  at System.Windows.Forms.ToolStrip.HandleItemClick(ToolStripItem dismissingItem)
  at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)
  at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
  at System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs e, ToolStripItemEventType met)
  at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e, ToolStripItemEventType met)
  at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)
  at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
  at System.Windows.Forms.Control.WndProc(Message& m)
  at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
  at System.Windows.Forms.ToolStrip.WndProc(Message& m)
  at PaintDotNet.SystemLayer.ToolStripEx.WndProc(Message& m)
  at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
  at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
  at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
------------------------------------------------------------------------------

mypaintsig-1.jpg
Link to comment
Share on other sites

ok sorry, its only actually crashed once and thats the code that came up when it did.

the blurring is a seperate thing all together. :cry:

although I havent tried it with different images, so I dont know if it only blurs with this particular image or if its blurring with every image.

mypaintsig-1.jpg
Link to comment
Share on other sites

ok sorry, its only actually crashed once and thats the code that came up when it did.

the blurring is a seperate thing all together. :cry:

although I havent tried it with different images, so I dont know if it only blurs with this particular image or if its blurring with every image.

mypaintsig-1.jpg
Link to comment
Share on other sites

yup

http://i13.photobucket.com/albums/a252/ ... ublur1.jpg

that was after I went to enter some text on a new layer and it went blurred.

http://i13.photobucket.com/albums/a252/ ... ublur2.jpg

added a new layer and it blurred.

http://i13.photobucket.com/albums/a252/ ... ublur3.jpg

Did the sparkel bit and clicked glow and the image blurred.

Im just testing out some other images to see if it does the same.

mypaintsig-1.jpg
Link to comment
Share on other sites

yup

http://i13.photobucket.com/albums/a252/ ... ublur1.jpg

that was after I went to enter some text on a new layer and it went blurred.

http://i13.photobucket.com/albums/a252/ ... ublur2.jpg

added a new layer and it blurred.

http://i13.photobucket.com/albums/a252/ ... ublur3.jpg

Did the sparkel bit and clicked glow and the image blurred.

Im just testing out some other images to see if it does the same.

mypaintsig-1.jpg
Link to comment
Share on other sites

I doubt the Sharpen effect will do anything here. Since none of the Blur effects are being used, it may be a rendering issue with the canvas itself.

Also, notice how the History window in every screenshot shows only "Open Image." None of the actions after the canvas is opened are being written. There's certainly a bug here, but I can't replicate it.

Would you be able to post the original picture? The one that you opened each time.

I am not a mechanism, I am part of the resistance;

I am an organism, an animal, a creature, I am a beast.

~ Becoming the Archetype

Link to comment
Share on other sites

I doubt the Sharpen effect will do anything here. Since none of the Blur effects are being used, it may be a rendering issue with the canvas itself.

Also, notice how the History window in every screenshot shows only "Open Image." None of the actions after the canvas is opened are being written. There's certainly a bug here, but I can't replicate it.

Would you be able to post the original picture? The one that you opened each time.

I am not a mechanism, I am part of the resistance;

I am an organism, an animal, a creature, I am a beast.

~ Becoming the Archetype

Link to comment
Share on other sites

yeah, the history only has 'open' because they are images that i have opened to show you what has happened, thats all.

Unless you want me to do it all again completely to show you the history, then there is nothing I can do about that.

All I know is, when I go to put text in it starts to blur that area and sometimes when I add a new layer, it blurs the whole image and sometimes all I have to do is save the image and it blurs and sharpening it only makes it worse.

On the other hand, at the moment, it seems to be only with these images that it happens to.

I made my signature today on it and it was fine with that.

:cry:

mypaintsig-1.jpg
Link to comment
Share on other sites

yeah, the history only has 'open' because they are images that i have opened to show you what has happened, thats all.

Unless you want me to do it all again completely to show you the history, then there is nothing I can do about that.

All I know is, when I go to put text in it starts to blur that area and sometimes when I add a new layer, it blurs the whole image and sometimes all I have to do is save the image and it blurs and sharpening it only makes it worse.

On the other hand, at the moment, it seems to be only with these images that it happens to.

I made my signature today on it and it was fine with that.

:cry:

mypaintsig-1.jpg
Link to comment
Share on other sites

Well just trying to help with the sharpen thing, sorry.

Going on a limb, but could it be the encoding of the image?

Also, do whatever will help. If re doing that to show us the history will help, please do so.

Otherwise we need Rick.

"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former"

[ dA Paint.NET Chat :: Yata on dA ]

Link to comment
Share on other sites

Well just trying to help with the sharpen thing, sorry.

Going on a limb, but could it be the encoding of the image?

Also, do whatever will help. If re doing that to show us the history will help, please do so.

Otherwise we need Rick.

"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former"

[ dA Paint.NET Chat :: Yata on dA ]

Link to comment
Share on other sites

Huh.

You resized it. Or them.

Well, anyway, the pixel size of lu3.pdn is 700 x 395 and the size of the others is 500 x 282.

So it's a totally normal behavior.

No. Way. I've just seen Bob. And... *poof!*—just like that—he disappears into the mist again. ~Helio

Link to comment
Share on other sites

Huh.

You resized it. Or them.

Well, anyway, the pixel size of lu3.pdn is 700 x 395 and the size of the others is 500 x 282.

So it's a totally normal behavior.

No. Way. I've just seen Bob. And... *poof!*—just like that—he disappears into the mist again. ~Helio

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...