JRSwenson

Newbies
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. What other information do you need from me in order to get PrintIt working properly? I am currently using ThatOtherApp to print the current image in paint.net with MS Paint. However, this work-around will only work as long as MS Paint is an actual application rather than an Universal Windows App (which Microsoft keeps threatening to change). Also it seems a little strange to use a second image manipulation program to print out something from the first image manipulation program.
  2. Yes, I have Bullzip installed on both machines. As to upgrading to 2019 LTSC, that is an "if", since upgrades of this type are handled by my IT department. As to my other comment about version 0.8, is there anywhere here I can find it? I am curious to see if the older version would work on the Home Machine. If so, it would indicate to me that there is something within version 0.9 that is not liked by the Home Machine.
  3. Here is the diagnostics for my work machine: <quote>Application paint.net 4.2 (Final 4.200.7133.32960) Build Date July 13, 2019 Install type Classic Hardware accelerated rendering (GPU) False Animations True DPI 96 (1.00x scale) Language en-US OS Windows 10 Enterprise 2016 LTSB x64 (10.0.14393.0) (0x7D) .NET Runtime 4.0.30319.42000 Physical Memory 8,075 MB CPU Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz Speed ~3600 MHz Cores / Threads 4 / 8 Features SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, AVX, AVX2 Video Card Intel(R) HD Graphics 630 Dedicated Video RAM 128 MB Dedicated System RAM 0 MB Shared System RAM 4,037 MB Vendor ID 0x8086 Device ID 0x5912 Subsystem ID 0x07A11028 Revision 4 LUID 0x00009C5B Flags None Graphics Preemption TriangleBoundary Compute Preemption ThreadBoundary Outputs 2 Feature Level Direct3D_12_1 DXGI Formats A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float Buffer Precision UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc Video Card Microsoft Basic Render Driver Dedicated Video RAM 0 MB Dedicated System RAM 0 MB Shared System RAM 4,037 MB Vendor ID 0x1414 Device ID 0x008C Subsystem ID 0x00000000 Revision 0 LUID 0x0000A167 Flags Software Graphics Preemption InstructionBoundary Compute Preemption InstructionBoundary Outputs 0 Feature Level Direct3D_11_1 DXGI Formats A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float Buffer Precision UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc </quote> I hope that someone knowing more about the internals of PrintIt can look at these two diagnostic files and determine why PrintIt works properly on the Work Computer and not on the Home Computer. I also attempted to have PrintIt send data to the Bullzip Print to PDF application. PrintIt worked so slowly that PDN stalled and I had to kill the process. I also read in this thread that someone used the previous version of PrintIt - Version 0.8 and it worked on his computer. I would like to try this version on the Home Machine to see if works, but I cannot find it. Can someone provide a URL to this version if it still exists?
  4. Perhaps I was not sufficiently detailed on this. On my Home Computer when I attempt to use the Print It (Tools Effect) on the current image, the appropriate windows come up. However, when I attempt to do things like change the margins it takes many minutes for the plugin to respond. Sometimes attempting to make the changes causes PDN to lock up completely. I do not have these problems on my Work Machine. I list here the diagnostics from PDN on my Home Machine: <quote> Application paint.net 4.2 (Final 4.200.7133.32960) Build Date Saturday, July 13, 2019 Install type Classic Hardware accelerated rendering (GPU) True Animations True DPI 96 (1.00x scale) Language en-US OS Windows 10 Home x64 (10.0.18362.0) (0x65) .NET Runtime 4.0.30319.42000 Physical Memory 3,533 MB CPU AMD A9-9430 RADEON R5, 5 COMPUTE CORES 2C+3G Speed ~3194 MHz Cores / Threads 2 / 2 Features SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, AVX, AVX2 Video Card AMD Radeon(TM) R5 Graphics Dedicated Video RAM 505 MB Dedicated System RAM 0 MB Shared System RAM 1,766 MB Vendor ID 0x1002 Device ID 0x98E4 Subsystem ID 0x364F17AA Revision 196 LUID 0x0000B1AE Flags AcgCompatible, SupportMonitoredFences, KeyedMutexConformance Graphics Preemption DmaBufferBoundary Compute Preemption DmaBufferBoundary Outputs 1 Feature Level Direct3D_12_0 DXGI Formats A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float Buffer Precision UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc Video Card Microsoft Basic Render Driver Dedicated Video RAM 0 MB Dedicated System RAM 0 MB Shared System RAM 1,766 MB Vendor ID 0x1414 Device ID 0x008C Subsystem ID 0x00000000 Revision 0 LUID 0x0000BA35 Flags Software, AcgCompatible, SupportMonitoredFences, KeyedMutexConformance Graphics Preemption InstructionBoundary Compute Preemption InstructionBoundary Outputs 0 Feature Level Direct3D_12_1 DXGI Formats A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float Buffer Precision UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc </quote> Since I am not currently at work, I will post diagnostics from the Work Machine when I have it.
  5. Hello. I have been having enormous trouble in getting Print It (Tools Effect) to work properly on my Home Computer. The plug in either works slowly or not at all. The Home Computer runs Windows 10 Home 1903. The printer is an HP Deskjet 1000. The system software has been updated to the last Patch Tuesday (July 2019). I have upgraded the drivers to the printer to the most recent version to no avail. However: Print It (Tools Effect) works properly on my Work Computer. The Work Computer runs Windows 10 Enterprise LTSB 1607 with a networked connection to a Ricoh Printer/Copier/Fax Machine. What other information do you need from me in order to fix this plug in so it works properly on these Computers?
  6. SUCCESS! Re-creating the paint.net User Files directory allowed ThatOtherApp to function again. Thank you for your assistance.
  7. I really do not have the tools to do a decompile of a plug-in as interesting as that would be. However I found something interesting, I do not have a paint.net User Files folder structure in my Documents folder. How do I manually create this structure? Assumedly it would have been created when paint.net was installed.
  8. No. Controlled Folder Access is not in operation on my PC. Of course MS Paint is Standard Equipment on WIndows 10 (At least until Microsoft decides to make it into a Universal App). And there does not seem to be anything wrong with the Security Settings for the Documents Folder since I can create documents with impunity in it. Two questions based on the comments I have received so far: 1) Why would this plug-in write a Temporary Image into My Documents. Being a programmer temporary files should go into the Temp Folder. 2) Why go thru the agony of saving a temporary copy of an image somewhere, opening it in Paint to print it out, and then deleting the temporary copy when there is a plug-in that will do all of that for you? Processes like this are what computers are good at solving.
  9. ThatOtherApp is not working for me. When I attempt to use it to call MS Paint to print out the current layer I get a message box with the text "App could not be loaded". This is my current configuration: paint.net 4.1.6 Windows 10 64-bit .NET Version 4.0.30319 What is needed from me in order to debug this plug-in? Since Printer+ does not print images in the way I want, and Print It does not seem to play well with my printer (HP Deskjet 1000) this is the only plug-in that will allow me to print out images.