Jump to content

Paint.Net is unbound from right click -> Edit


Go to solution Solved by Zagna,

Recommended Posts

Hello.

How Paint net worked for me for years (Windows 10) was the following:

If I double click on an image file, it opens in the Windows Photo Viewer.
When I do "right click -> Edit" , it opens in Paint.net.

This is how I love and need it.

But in the last few days since I last used the program, both Paint.net and Win10 have updated.
And now when I do "right click -> Edit", it opens images with Paint 3D. (Ew!)

I would like to restore it to it's previous function.
 

PS: 
The solution is NOT to do "open with ..." -> "Always use this app".
That would change the double click behavior, but not the "right click -> Edit"

Link to comment
Share on other sites

Or do it via registry:

  • Run regedit.exe from the ‘Run’ dialog (Win + R).
  • Go to the following Registry key.
    HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit\command
  • Modify the default (unnamed) parameter. Set it to the full path to the app which you want to use for the Edit menu.

midoras signature.gif

Link to comment
Share on other sites

@midora

 

This kinda worked, but not fully.
I did the edit you said with the following address put in place of regular paint:

Quote

"C:\Program Files\paint.net\paintdotnet.exe"

 

Now when I right click on an image and do "edit", 

it does open Paint.net! 
Progress!

But it doesn't open the image that I did the right click on in Paint.net.
It opens a new untitled project, with just a white canvas. 

 

@toe_head2001

 

Your solution did not work for me.
A re-install didn't solve the problem,

and I do not see the options from your screenshot when I run the installation.
This is all I see when I run the installer:

 

https://i.imgur.com/2LB6eOQ.jpg

 

 

 

Link to comment
Share on other sites

7 minutes ago, scg2020 said:

But it doesn't open the image that I did the right click on in Paint.net.
It opens a new untitled project, with just a white canvas. 

 

Then you removed and replaced not only the filename but also the parameter after the full path. So add "%1"

The quotes are important because the filepath may contain spaces.

midoras signature.gif

Link to comment
Share on other sites

1 hour ago, midora said:

 

Then you removed and replaced not only the filename but also the parameter after the full path. So add "%1"

The quotes are important because the filepath may contain spaces.

 

Okay, I think I did what you said. 
(Sorry if I don't get it)
and I added what you wrote.
Now the entry in the registry is:
 

Quote

"C:\Program Files\paint.net\paintdotnet.exe"%1""



It works on image files that have no spaces in their name, but it doesn't work on image files that have do have spaces in their name. Then I get a white canvas and error message.

eg.: right click -> edit works on "picture.jpg"

But when I would try it on "the picture.jpg" I would get the error 

"The Image type is not recognized, and cannot be opened.
C:\Users\Admin\Desktop\the"

Link to comment
Share on other sites

  • Solution
25 minutes ago, scg2020 said:

Okay, I think I did what you said. 
(Sorry if I don't get it)
and I added what you wrote.
Now the entry in the registry is:
It works on image files that have no spaces in their name, but it doesn't work on image files that have do have spaces in their name. Then I get a white canvas and error message.

The command needs to be

"C:\Program Files\paint.net\paintdotnet.exe" "%1"

Space between them and each in their own quotes.

Edited by Zagna
  • Thanks 1
  • Upvote 3

sig.jpg.7f312affa740bae49243c4439bc4a244.jpg

Link to comment
Share on other sites

Thank you very much!
This solved the issue.

I can't overstate how grateful I am for your help, patience and expertise.
I will definitely bookmark this, just in case another Windows update will mess things up again in the future.

 

You're all awesome!

 

ps:

I wish the installer would still just do this for us.
But I assume you have good reasons for the change, and will/would bring it back as soon as you could. <3

Edited by scg2020
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...