Jump to content

Can't open image for editing from image and fax viewer


Stitch
 Share

Recommended Posts

I've been having this problem for a while, actually. When I preview from windows image and fax viewer and then click the button to close image and fax viewer and open the image for editing, image and fax viewer closes and that's it.

If I right click the image in explorer and choose edit, Paint.net pops right up with the image. I'm betting there's some registry key that determines what that button launches that somehow I broke.

Link to comment
Share on other sites

I've uninstalled and reinstalled, and no luck. Any idea which registry key it is that decides what opens when I click that button?

It may be something with the data type, I recently tracked down a Java error I was having to a registry key being the correct name and value, but the wrong type, apparently another piece of software decided to change the data type when I wasn't looking.

When PaintDotNet's uninstalled, picture and fax viewer does the same thing, it just exits. It doesn't go to mspaint.exe.

I just took a look at it in regedit, and the key HKEY_CLASSES_ROOT\SystemFileAssociations\image\shell\edit\command is a REG_EXPAND_SZ set to "%systemroot%\system32\mspaint.exe" "%1"

Does that match the settings in a working system as far as the key and type? (clearly the value isn't right... if that's the correct key)

Okay, I'm the king of editing my posts. Problem solved! Here's my solution.

I ran into some theories that it may be a shell extension messing up the works, so I installed ShellExView from http://www.nirsoft.net/utils/shexview.html . Then I went through the shell extensions, looking for what was a Microsoft extension and what was not. Then I disabled the non-MS ones one by one, and then tried the edit button to see if it worked. I got lucky and the problem was with the first extension I disabled. Apparently WhoLockMe does not play nice with the fax and picture viewer's edit button.

Then I just went back into regedit and changed the value for the key from mspaint to paint.net. Now I'm happy to have it working and I've completely forgotten the original reason that I clicked the edit button in the first place, and even the file I was going to edit. Whatever the reason, it was more fun fixing things I'm sure.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...