Jump to content

Display glitches on the ribbon and in the layer dialogue on returning from another window


Recommended Posts

I've had this intermittent bug for some time (Win 10 x64 currently paint.net 4.216.7781.39227): With several files open, one always a multi-layer file 'cause that's what I'm doing in P.N, when I swap to another window and then return to P.N, the ribbon dialogues are incomplete (eg the red-x box to close a file will not display) or even missing. In the layer dialogue, the layers might be missing or part of the actionable bits or information bits for each is missing.  A screenshot from today to illustrate the issue.

 

In the past, I've had to close P.N and re-open to re-establish all the dialogues. Today I chanced on closing the layer file making the other file's dialogues re-establish. I've yet to see if that was a real work-around, or just a fluke.

 

In the screen shot, I think I might have already tried to close the layer file (the blue box with nothing in it in the ribbon) but at that point P.N did not seem to have responded.

 

 

 

Screenshot (27).jpg

Edited by stitlown
Fix heading typos
Link to comment
Share on other sites

  • stitlown changed the title to Display glitches on the ribbon and in the layer dialogue on returning from another window

A little more info after another occurrence of this. It looks like the GUI is not communicating properly to the underlying program.  In the latest occurrence, I was able to add a layer and save the file, but the ribbon and the layer dialogue did not update. I was even able to close the file and then re-open it and the layer dialogue did not update.

Link to comment
Share on other sites

Are you using any screen recording or GPU overclocking software? Those always seem to cause weird stuff like this. WindowBlinds (custom theming software) is also known to cause all sorts of trouble.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Thanks. No. I've never overclocked. And this is a new machine on which I've never done screen recording.  I had the same problem on my old machine. Not heard of Windows Blinds before.

 

I've had the same problem 3 or 4 times today. It's a regular ocurrence for me. Has been for some time, I've just never got around to reporting it.

 

 

Edited by stitlown
wrong information removed - it was "Human error, Dave"
Link to comment
Share on other sites

If it's of any help in diagnosing, another thing I've noticed tonight, after it was first behaving and then not, is that if I have a "return glitch" on trying to swap back to P.N then I'll have this display glitch.  The return glitch is when I click on any of the P.N pop up minatures from the P.N icon on my task bar but windows doesn't return to P.N.  I then repeat the attempted return and this time it will work, but I get the display glitch. Can't yet be sure that this is a one-for-one relationship but it gels with my past experience and experience so far tonight. Cheers,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...