Jump to content

Paint.NET cannot see my mapped network drives


Recommended Posts

From the File > Open menu, Paint.NET cannot see my mapped network drives in the My Computer list.

When I try to right click on a file in this mapped network drive (U:\ drive), I get an error (see PaintNETError.png screenshot).

 

I've also included a picture of how my normal Windows Explorer My Computer looks like, as a comparison.  To get around this I have to copy files to any other drive, edit it, save it, and move it back to my network share.

 

Running Paint.NET as Administrator does not fix this problem.

 

EDIT:

I should also note that this is not new since upgrading to Paint.NET 4.1, this has occurred since (at least) 4.0.14.

 

 

Explorer.PNG

PaintNETError.PNG

PaintNETExplorer.PNG

Edited by ToastyMallows
Link to comment
Share on other sites

I'm reaching a bit here, because the path listed in the error screenshot is pretty short, but maybe enabling long paths support will help. My hypothesis being that mapped network drives sometimes are mapped to UNC paths that are actually much longer and... and maybe something deeper in the stack is stumbling over that.

 

See here, but skip to the part where I say "However, good news:" and give instructions on enabling a group policy setting:

 

 

 

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Also, are you using the Classic version or the Windows Store version? If the latter, I'm curious if there's a bug in the sandboxing (done by the OS)

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

  • 4 months later...

@Rick Brewster

Sorry for the huge delay, completely forgot about posting this!

 

I'm using the Classic version.

 

I tried enabling Win32 long paths, then restarted Paint.NET and my computer, but the problem still persists.

 

I'm now using paint.net 4.1.5 (Final 4.105.6913.325).

 

Edited by ToastyMallows
forgot version info
Link to comment
Share on other sites

What about a file that's at the very root of the mapped drive? U:\picture.png for instance? If this works, then the folders may have characters that .NET's FileStream is incapable of dealing with. I'm not sure why that would happen, but logically it seems possible.

 

Other than that, I have no idea. Paint.NET is just using a System.IO.FileStream to open files; if PDN has problems, I'd expect other .NET-based apps to also have trouble. Maybe try using LINQPad to save/load a script on a mapped drive and see what happens. Or you could write a quick C# program or PowerShell script to explore it.

 

The code in Paint.NET is just:

 

Stream stream = new FileStream(fileName, FileMode.Open, FileAccess.Read);

(yes, there's a Dispose() call later on of course)

 

My mapped network drives work fine, although they don't reconnect at startup -- I always have to manually double click them in Explorer to get them started.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Yes it's very strange I've never had this issue before in any other program!  The problem is that the drive doesn't even show up in the list of available drives from the File > Open menu, so it doesn't matter where the picture is on the mapped drive. (See pictures)

 

This drive is also mapped for me, since this is on a work computer, so I'm not 100% sure exactly how it works.

 

Windows Explorer drive list:

WindowsExplorerDrives.PNG

 

Paint.NET drive list from File > Open menu:

PaintNETDriveList.PNG

Edited by ToastyMallows
picture captions
Link to comment
Share on other sites

I did a google search for "can't use mapped network drive in app" and ran across https://community.spiceworks.com/topic/2010485-software-does-not-see-mapped-drives

 

The underlying problem may be that Paint.NET is running as a different user than whatever has mapped the driver letter. Or with different permissions. Or something like that. (Also, sometimes "a different user" might not mean what you think ... by user I mean "whatever concept or security primitive that Windows is tripping over when it comes to this problem", not necessarily you or your user account)

 

Some things to try out would be...

 

* can you access the files directly via UNC? e.g. \\server\share\path\file.png
 

* in that link, they show examples of "net use ..." commands. Try those? Unfortunately those mappings seem to go away at logout, but it may help steer you in the right direction

 

This link may be useful too, https://stackoverflow.com/questions/35445241/application-cannot-access-mapped-drive . THey mention a "EnableLinkedConnections" setting.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...