Jump to content

High CPU Usage


jrgcombr
 Share

Recommended Posts

Hi everyone,

 

I've been experiencing a high CPU usage with paint.net when it's was supposed to be 'idle'. 

 

I'm running paint.net 4.0.12 with Windows [Version 10.0.14393], but this issue have been happening in the last versions as well. 

It's not just one thread causing the high CPU, but a few of them. I'm uploading an screenshot of Process Explorer to show more details.

I don't when the high CPU starts, but it does not happen if I minimize paint.net, tough it happen if I just Alt+Tab to something else.

If needed I can get more details (logs, dumps, etc) to get more information about this specific scenario.

 

Congrats for this REALLY GREAT application. It's awesome.

 

 

Regards,

JRG

 

 

 

 

 

paintnetcpu.png

Link to comment
Share on other sites

Is hardware acceleration disabled in the settings dialog?

 

Do you have a selection active? (press Ctrl+D or use Edit->Deselect to make sure there isn't)

 

Those two together could certainly result in consistently high CPU usage.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

 

The hardware acceleration was disabled, though I don't remember disabling it. Also the issue was happening with an active selection.

Enabling hardware acceleration improved a lot, the CPU usage is now around 10% with an active selection.

With no active selection there is almost no CPU usage as expected. 

 

I think I ran into this issue because I grab a lot of screenshots and when I paste them, they are selected by default.

 

Just out of curiosity, why a selection cause such behavior?

 

Thanks a lot for your quick and precise response. 

 

Link to comment
Share on other sites

The selection outline is always animating. That takes CPU and GPU resources. If hardware acceleration is disabled, then the CPU has to redraw the area where the selection is. 

 

Minimizing the window will cause the CPU usage to drop to zero because Paint.NET disables its animation system when it's minimized (as it should!).

 

Hardware acceleration was disabled because you're probably using an Intel GPU. Some of them proved to be unstable during 4.0's development so I added code to detect them (not all of them) and disable hardware acceleration by default.

  • Upvote 1

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

  • 6 months later...

I can look into it some more, but in the meantime my reccomendation for reducing CPU usage is: 1) make sure hardware acceleration is enabled in settings, and 2) you can try disabling animations in settings. 

 

#2 will be guaranteed to drop CPU usage to zero, but there won't be animations throughout the UI.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...