Sign in to follow this  
Followers 0
excelr8

Pasted image size doesn't match copied image size?

7 posts in this topic

Hi all, apologies if this is a really dumb question.  Prior to version 4.0, I could routinely copy a shape or image created in Excel and paste it into paint.net (paste as new image) and, at the default resolution of 96 dpi, the image size indicated (in inches) in Excel would be replicated in paint.net.  So, if I saved that pasted image as a jpg or png file and then inserted that image back into Excel, it'd be an exact match (size-wise and pretty much in every other way) for the original image that was copied from Excel.  With version 4.0, when I perform the same copy from Excel and paste into paint.net, the image size is larger than the original.  I've noticed that if I change the resolution in paint.net from the default 96 dpi to 150 dpi, the image size becomes equal to the original.  I tried this same action in Microsoft Paint and it behaves as I expect (pasted image size at 96 dpi is the same as the copied image size)  An example: if I create a 2" x 2" square shape in Excel and copy and paste it into paint.net, it comes in at 3.13" x 3.13" at 96 dpi.  The reason that changing the resolution to 150 dpi isn't ideal is, if I have text in the copied shape, it loses sharpness when the resolution is changed.  Am I looking at this completely wrong or is this an intended change to paint.net?  I can certainly use Microsoft Paint instead of paint.net to convert these types of Excel shapes into standalone image files but it was pretty convenient to use paint.net for all graphics work previously.  Thanks in advance and, again, apologies if this is a dumb graphics question (I'm a rank amateur at graphics).

Edited by excelr8
0

Share this post


Link to post
Share on other sites

I'm having this same problem. It's fairly annoying, as it's something I do almost daily for my blog.

 

Any help would be appreciated. Thanks!

 

Edited to add examples:

 

Excel to MS Paint: http://imgur.com/iwMuBRw

Excel to Paint.NET 4.0: http://imgur.com/j2oHFRP

 

Paint.NET used to act the same way MS Paint does now.

Edited by TheTim
0

Share this post


Link to post
Share on other sites

Thanks for the update. Really appreciate the fix. Does the next update have an ETA? 

0

Share this post


Link to post
Share on other sites

Rick, thanks, I just ran the 4.0.1 update today and it looks like you've fixed this issue.  Very much appreciated, will definitely be donating to the cause!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0