Jump to content

Palette based, rgb, greyscale?


kynian
 Share

Recommended Posts

Hello, I just started using Paint.net not long ago and it works really well, and its an awesome program! I've just started taking a game development class in c++ and it seems whenever I make an image using paint.net it saves it as a palette-based image (according to the folks at a help website for the game gdk I use) and for some reason it sets the entire image as invisible because of this, Im not sure exactly why this doesnt work, but here is the response from the gentleman at TGC who was trying to help me:

The problem is the format how your images are saved. They are all palette-based, and it seems that in this case, one of the colours in the palette is treated as transparent colour, and the colour key that you set in the program is not used. In the background and line images, the palette contains only black and nothing else, so black will be the transparent colour and nothing of the image will show, because all of it will be transparent.

Your player sprite has the same problem. The colour key you set in the program is 255,0,255, but the pink colour in the player image is actually 255,30,191, so it doesn't match. It's transparent only because the pink is accidentally set in the palette as transparent colour. (I haven't worked much with palette-based images, so I don't know how the transparent colour is selected in them.)

If I change the format of the background and line images in an image editor so that they will be 8 bits/channel RGB colour and not palette-based (increase colour depth command), and re-save the images, then the black colour will correctly appear. In this format, the colour key will be used, so if I re-save the player sprite in this format as well, then the pink won't be transparent any more, since it doesn't match the colour key.

is there any way to make it work as a non palette based image? Sorry if this is confusing but Im not really sure how this whole thing is supposed to work! I'm new to image editing and I haven got the hang of it yet.

any help is much appreciated.

Link to comment
Share on other sites

Hello, I just started using Paint.net not long ago and it works really well, and its an awesome program! I've just started taking a game development class in c++ and it seems whenever I make an image using paint.net it saves it as a palette-based image (according to the folks at a help website for the game gdk I use) and for some reason it sets the entire image as invisible because of this, Im not sure exactly why this doesnt work, but here is the response from the gentleman at TGC who was trying to help me:

is there any way to make it work as a non palette based image? Sorry if this is confusing but Im not really sure how this whole thing is supposed to work! I'm new to image editing and I haven got the hang of it yet.

any help is much appreciated.

You didn't mention what file format you are using to save the image.

Some file formats show a 'save configuration' dialog during save.

If the settings tell that 'Bit Depth' is set to 'auto-detect' then Paint.NET may always save your image with a palette.

Try to select something like 24-bit instead.

midoras signature.gif

Link to comment
Share on other sites

You didn't mention what file format you are using to save the image.

Some file formats show a 'save configuration' dialog during save.

If the settings tell that 'Bit Depth' is set to 'auto-detect' then Paint.NET may always save your image with a palette.

Try to select something like 24-bit instead.

Sorry, I knew I forgot something! Im saving them as .bmp images and it does bring up the save configuration box, Ill try what you suggested, thanks!

EDIT: I just tested what you said but even when I save it as 24-bit or 8-bit (the only other two options besides auto-detect) it still doesnt show up. Im extremely confused now

EDIT2: sorry I was using the wrong image, changin it to 24 bit does work!! thanks for the help :D

Edited by kynian
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...