Jump to content

Copy to clipboard not captured by ClipCache program.


Recommended Posts

I'm cross posting to forum here and to ClipCache support forum. I suspect the problem is with the ClipCache program but Paint.Net does appear to have a different clipboard format than do msPaint and Gimp. Perhaps the problem is some format the above two have in common that Paint.Net could (easily(?)) support?

Post on ClipCache forum: http://www.xrayz.co.uk/forum/viewtopic.php?p=4685#4685

When I copy from graphics from a selection in Paint.NET (free from: http://www.getpaint.net/) I get the "Could not capture" noise from ClipCache and nothing is captured.

I discovered this while trying to test another clip capturing program

It is unable to capture from GIMP (which ClipCache does) and in testing discovered that ClipCache fails on clips from Paint.NET

Both capture fine from msPaint and captures from any of the three can be pasted in the other two. While trying to figure out what is going on I ran standard MS program clipbrd.exe and saved a CLP file from each program.

Zip containing three small CLP files available at: http://buralex.googlepages.com/SamplegraphicsCLPs.zip (563KB)

If you can tell ... is this a configuration problem with ClipCache or with Paint.Net or something else.

ClipCachePro - 3.1.3 / WinXP Pro SP2/ Paint.NET 3.31

Regards ... Alec

Link to comment
Share on other sites

It is unable to capture from GIMP (which ClipCache does) and in testing discovered that ClipCache fails on clips from Paint.NET

Both capture fine from msPaint and captures from any of the three can be pasted in the other two. While trying to figure out what is going on I ran standard MS program clipbrd.exe and saved a CLP file from each program.

In subsequent testing I discovered that pasting from GIMP to PaintDotNet always fails. (whether or not a clip catching program is involved). Any attempt to paste to PaintDotNet gives this error:

---------------------------

Paint.NET

---------------------------

The image in the clipboard couldn't be recognized. Try re-copying it with the original application that was used to acquire it.

---------------------------

OK

---------------------------

Note same clipboard contents (from GIMP) can be successfully pasted to mspaint.exe, excel, and Irfan. If re-copied from one of them it can be pasted into PaintDotNet (so at least there is a workaround)

version of Gimp used is Windows 2.4.5

FWIW - a programmer (of another program ClipTrak which I'm beta testing) told me "GIMP uses a bunch of formats (largely in MIME format). To fix the problem above I used their 'image/png' format which gives good results (since the image supports transparency)"

Is this something PaintDotNet can/should take care of - on the principal that one should be as liberal as possible on import and conservative on output. (I know lots of people feel Internet Explorer is MUCH to liberal in what it attempts to accept but that's another story )

To summarize for my own use and followup I made this table of what currently works and what doesn't work:

CC-copyfrom-pasteto_table.png

Regards ... Alec

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...