sam_

Newbies
  • Content Count

    7
  • Joined

  • Last visited

Everything posted by sam_

  1. I have been doing nothing since I made my post but trying to replicate what I may have done. I have a very regular process for making specular maps and just generally editing. And I can't produce a specular map the same as before without first recoloring each new layer to transparent black. There's nothing that I could have misremembered, I've done this enough times in the past. The only other thing I can think of is there is some change in the way paint.net loads .dds files. Which seems unlikely.
  2. I can also press backspace to fill instead of erase while having transparent black as the selected color. But, after creating thousands of specular maps over the years I have never actually done this, and I always hit delete and not backspace to erase and not fill. It's even muscle memory for me to press ctrl+A followed by delete when I'm about to paste a selection. Could this be related to a plugin perhaps? More specifically is there a config file or some way that a plugin can determine what color is returned when a selection is erased?
  3. I really do know for certain, not only because I have just made this image but because I have made many images in the past where having transparent white would lead to massive artifacting in the textures I make for 3D applications. The images I create are specular maps that use R for masking, G for specular value, B for metal and A for glossiness. If erasing a selection did always leave transparent white then I would have broken specular mapping in the 3D application as areas that should have no value in fact have a value of 255 in masking, specular value and metal, which produces a black shiny mess. I have just tried to remake a specular map I have made a few days ago and have the same issue. The transparent areas in the original are black, but in the one I just remade they are transparent white. This image I have linked in my last post is a texture that I made multiple layers of and cut up like so: The only way I would have done this is to select the area and delete it. The transparent area is black, but if I replicate it now then it's white. I feel like I'm losing my mind here. I have evidence in front of me that it used to return transparent black, but now it doesn't and everyone says it never did.
  4. Mistaken how? I am looking at an image I have just been working on the past hour. There is a layer where I know for certain all I have done is erase a selection. The color picker returns transparent black. When I replicate that operation it now returns transparent white. I have been using this program for many years making similar images that use RGBA channels for data and I have never had this issue, so it's not as simple as "I'm mistaken" Here is the the layer I'm working with https://drive.google.com/file/d/1wpWcYjbCKQHorV3OhJ3FvQhOa3fUWf_G/view?usp=sharing The old layer is what I have just done an hour ago, the new layer I have just done now.
  5. But I have layers in my image that I know for certain that I have only selected and deleted which have transparent black.
  6. Today while working on an image I encountered a strange issue that I have never encountered before midway through editing. Selecting an area and pressing delete typically leaves transparent black or RGBA(0,0,0,0), but now for some reason it is leaving transparent white RGBA(255,255,255,0). I have looked through the documentation to find if I pressed a hotkey by accident, and I have checked every setting to find what I may have changed but have come up with nothing. I know for certain this is not normal behavior as I have layers in my image that have only had a selection deleted and the area is RGBA(0,0,0,0), while now replicating the exact same operation leaves RGBA(255,255,255,0). Why is this an issue? I'm working on textures for 3D applications that use RGBA channels for texture data, and I'm now getting values of 255 instead of 0 as it has been for years. I know I can press backspace while having the current selected color as transparent black as a work around, but I'd prefer the previous behaviour.