Sign in to follow this  
I Like Pi

Layer Saver (October 21, 2008)

Recommended Posts

woah, definitely makes making animated .gifs easier!

i don't quite know how else you'd do it... uncheck each layer and re-save it?

imageshack is being gimpy right now, so i cant show the finished product, but it streamlines the process a lot when you're using unFREEz.

great plugin! :D

thats actually a good idea. Everything i know about photo editing is self taught, so yeah... i save, then undo, do effect, save, repeat.

doing it with layer saver is actaully macro friendly, which helps out a lot.

thats another thing i love about paint.net, you can use keyboard shortcuts for so many things.

Share this post


Link to post
Share on other sites

That's strange. It's trying to find PdnLib.dll, which was changed to PaintDotNet.Core.dll in version 3.05. That version was released ages before this program was created. I really have no clue why it wants the old version of the DLL.

This is the relevant code:

AppDomain.CurrentDomain.AssemblyResolve += delegate(object sender, ResolveEventArgs args) {
   string name = args.Name.Substring(0, args.Name.IndexOf(','));
   try {
       string dir = (string)Registry.LocalMachine.OpenSubKey("SOFTWARE").OpenSubKey("Paint.NET").GetValue("TARGETDIR");
       return Assembly.LoadFrom(Path.Combine(dir, name + ".dll"));  <--------------------------- Error here

May or may not work:

Try moving layer saver to your paint.net directory (e.g. C:\Program Files\Paint.NET, not FileTypes or Effects).

Share this post


Link to post
Share on other sites
That's strange. It's trying to find PdnLib.dll, which was changed to PaintDotNet.Core.dll in version 3.05. That version was released ages before this program was created. I really have no clue why it wants the old version of the DLL.

I've been using Paint.NET since before 3.05, so maybe there's some garbage left behind in the registry?

Try moving layer saver to your paint.net directory (e.g. C:\Program Files\Paint.NET, not FileTypes or Effects).

I'll give it a try.

EDIT: No, it's still giving the same error. And I haven't found anything suspicious in the registry, either.

Share this post


Link to post
Share on other sites

Found the problem. :D

It's caused by any filetype plugin that was compiled prior to 3.05 and still references the old DLL. As a workaround, you can temporarily remove those plugins (or all of them if you're not sure which) and run layer saver.

I'll try to get a fix up shortly.

Share this post


Link to post
Share on other sites

You're right, it worked! Thanks for your help. :)

EDIT: But there is a small problem - well, it's more an aesthetic thing - layers with "Visible" unchecked come out completely empty (transparent, in PNG)! I guess this is unavoidable, but I wonder if there is a way to force it to save normally? Otherwise, I'll just make all the layers visible.

Share this post


Link to post
Share on other sites

I Like Pi: Excellent! I came here with two things in mind:


  • [*:2dq7wtf1] See if someone had written a plugin to export all layers as individual files,
    [*:2dq7wtf1] See if information about the .pdn format was available, since I would like to access layers programatically.

Your app solves both, since you've posted source also, much appreciated, thank you :D

Edit: I see you use PDN dll's to do the heavy lifting and having looked into both a .pdn and the PaintDotNet.Data.dll I realized that its serialized data? I'm not that strong in .NET thogh I just love it and was in need of accessing layers from Java, am I out of luck? Any ideas?

Share this post


Link to post
Share on other sites

Okay, this is sooo needed, after a large amount of layers PDN starts to glitch and choke and die... so this wonderful separate file rescues me. So thank you!

Side notes:

I do not see each file's thumbnail when i saved layers to the .PDN file type, therefore i feel i need to open each file to check the contents (someone mentioned layers not checked visible as not saving).

Another quirk is that Layer Saver GUI does not close when done, and its progress bar remains full, though the Save Cancel buttons ungray themselves (So is it really done?).

I tried drag&drop on to the program icon and it does not seem to work, but it's nice that it remembers last used directory, could it also remember its last set of configs? Is there a .ini file i can make that it can use to speed up large project chores?

And last, since layers are so tedious moving up & down in PDN, and importing files into layers always puts it at the top of the stack rather than where one wants them, have you thought much about a tool that could create PDN files from layers?

Or maybe a program that would sort the PDN layers by name, etc. in a large PDN file offline? That would be something i'd use.

Thank you very much for this program! =)

Share this post


Link to post
Share on other sites

Firstly, thanks for that amazing app. I only suggest 2 more options

1st: If you can make possible to add a button to Paint.NET that opens current pdn file by using your tool then we will not have to open your tool seperately and we can produce our files rapidly.

2nd: In your app. we have to fill out output folder in every time, but i think should be placed a checkbox (title :Use current .pdn file directory) that saves all files in current(active pdn file's) directory.

Thanks..

Share this post


Link to post
Share on other sites

Layer Saver is awsome!

You did a great job.

Is there a way I can use it from command line?

I would very much like to include it in a larger script.

Thanks

Ilan

Share this post


Link to post
Share on other sites

I had before same problem,

The only solution I found is to delete the AnimGIF.dll from Paint.NET>FileTypes folder, and Layer Saver worked fine

Thank's yellowman, it's working now. Useful plugin for creating animation.

Share this post


Link to post
Share on other sites

Great. just what I needed to batch save jpeg-xr images.

I had some problems where the save dialog was always greyed out. Running Layer Saver from the paint.net directory fixed that. (win7 security presumably)

It would be nice if instead of a few options the name field supported a custom string such as %filename%"_"%layernum% or whatever syntax is suitable and numbering supported padding so that we could do 0001, 0002 etc.

well, thats my only feedback for this great tool.

Share this post


Link to post
Share on other sites

Hi,

this is a GREAT tool, but is there already a solution to start it from commandline?

Like IlanI would love to start it from a larger script.

Thanks,

Kevin

You may use pdn2png or pdn2bmp from the commandline.

Share this post


Link to post
Share on other sites

I tried pdn2bmp, but got some problems with the bitmaps. They are all black or show a strange combination of some layers...

The LayerSaver works without errors and its possibility to name the bitmaps by the layernames is great, too. Wouldn't it be possible to implement some starting options to autofill the textboxes?

Edited by KevinT

Share this post


Link to post
Share on other sites

Thank you, this is my first time using drawing tools for my projects and because of the wonderful tools it has gone smoothly. Within in a few minutes I had a dynamic Menu with multiple layers, and with the help of this tool I've been able to export them for the game to be toggled dynamically. The one suggestion I would make if it is possible, please edit the program so the user can select whether to include the invisible layers and if they choose to include the invisible layers- please edit it so that the invisible layers appear as they are designed versus the current blank image model.

Thanks again.

Share this post


Link to post
Share on other sites

Alright, so I know I've posted this in the incompatible plugins thread about a week ago, but since I'm still having the issue even with paint.net 4.0.1, I thought I would post this in it's own thread and ask if anyone else is having trouble with it in 4.0 and/or 4.0.1.

 

Is the Layer Saver plugin working for anyone in Paint.NET 4.0?

Is it only me that it won't work for?

 

If I place the Layer Saver file into 3.5.11's folder it works.

If I place the Layer Saver file into 4.0.1's folder it doesn't work, I get this error :

LayerSaverErrorTWO_zpsd78f015d.jpg

 

Thanks.

Edited by Cc4FuzzyHuggles

Share this post


Link to post
Share on other sites

Thank's yellowman, it's working now. Useful plugin for creating animation.

I can't get it to work either, even after trying the above. It did work OK in version 3.5.

Here is what I'm getting:

http://i.imgur.com/AE4EzQF.png

Share this post


Link to post
Share on other sites

It looks like Layer Saver needs to be recompiled referencing the new DLLs in paint.net 4. Hopefully someone will take this on to help us out.

If you still have paint.net 3.5.11 installed, try copying the layer saver folder to that directory and run it from there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this