Sign in to follow this  
k.digennaro

-Installed 3.3, Now plugins crashing-

Recommended Posts

I installed 3.3, now my plug ins have been crashing, not all of them, it started with Sharpen +, now sharpen + is working, but every time i try to use Drop Shadow, i get the plug in error message.

Ive tried reinstalling the plug ins and no luck. Any one know whats going on?

Thanks

Kevin

Share this post


Link to post
Share on other sites

I also just had a crash do you wish my log as well or shall I wait until post author k.digennaro sends his in to you in case they are the same.

thanks OMA

PS if this is incorrect area please one of the mods move it for me.

Share this post


Link to post
Share on other sites

o oops, here ya go

File: C:\Program Files\Paint.NET\Effects\Vandermotten.PaintDotNetEffects.dll

Effect Name: Vandermotten.PaintDotNetEffects.DropShadowEffect

Full error message: System.MethodAccessException: PaintDotNet.ColorWheel..ctor()

at Vandermotten.PaintDotNetEffects.DropShadowConfigDialog.InitializeComponent()

at Vandermotten.PaintDotNetEffects.DropShadowConfigDialog..ctor()

at Vandermotten.PaintDotNetEffects.DropShadowEffect.CreateConfigDialog()

at PaintDotNet.Menus.EffectMenuBase.RunEffect(Type effectType)

edit: i see that a couple people had this problem with the drop shadow, but its been happening on and off with some other plugins as well.

Share this post


Link to post
Share on other sites

The author of Drop Shadow will need to publish an update. Plugins are no longer allowed to reference classes inside of PaintDotNet.exe (they weren't really supposed to before 3.30 either, but there was nothing preventing them, nor any documentation warning against it).

Share this post


Link to post
Share on other sites
The author of Drop Shadow will need to publish an update. Plugins are no longer allowed to reference classes inside of PaintDotNet.exe (they weren't really supposed to before 3.30 either, but there was nothing preventing them, nor any documentation warning against it).

hmmmm, i see, so basically the plug ins that did this will now have to be updated?

That makes sense.

Thanks for the quick response.

Kevin

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this