Jump to content

Required to run as admin in Vista?


patja
 Share

Recommended Posts

Is it required to run Paint.NET as administrator in Vista? If so is this being addressed?

When I run as administrator it seems to work fine. When I don't, it consistently generates this error:

Application version: Paint.NET v3.22 (Final Release build 3.22.2933.24445)

Time of crash: 2/29/2008 11:18:27 AM

Application uptime: 00:00:00.3300570

OS Version: 6.0.6000.0 Workstation x86

.NET Framework version: 2.0.50727.1433 x86

Processor: 4x "IntelĀ® Core2 CPU 6400 @ 2.13GHz" @ ~2999MHz (DEP, SSE, SSE2, SSE3)

Physical memory: 2045 MB

Tablet PC: no

Updates: true, err

Locale: pdnr.c: en-US, hklm: en-US, hkcu: n/a, cc: en-US, cuic: en-US

Loaded assemblies:

mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 @ C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorlib.dll

PaintDotNet, Version=3.22.2933.24445, Culture=neutral, PublicKeyToken=null @ C:\Program Files\Paint.NET\PaintDotNet.exe

System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 @ C:\Windows\assembly\GAC_MSIL\System.Windows.Forms\2.0.0.0__b77a5c561934e089\System.Windows.Forms.dll

System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 @ C:\Windows\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll

System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a @ C:\Windows\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll

PaintDotNet.Core, Version=3.22.2933.24442, Culture=neutral, PublicKeyToken=null @ C:\Program Files\Paint.NET\PaintDotNet.Core.dll

PaintDotNet.Base, Version=3.22.2933.24440, Culture=neutral, PublicKeyToken=null @ C:\Program Files\Paint.NET\PaintDotNet.Base.dll

PaintDotNet.SystemLayer, Version=3.22.2933.24441, Culture=neutral, PublicKeyToken=null @ C:\Program Files\Paint.NET\PaintDotNet.SystemLayer.dll

PaintDotNet.Resources, Version=3.22.2933.24441, Culture=neutral, PublicKeyToken=null @ C:\Program Files\Paint.NET\PaintDotNet.Resources.dll

PaintDotNet.Data, Version=3.22.2933.24442, Culture=neutral, PublicKeyToken=null @ C:\Program Files\Paint.NET\PaintDotNet.Data.dll

PaintDotNet.Effects, Version=3.22.2933.24443, Culture=neutral, PublicKeyToken=null @ C:\Program Files\Paint.NET\PaintDotNet.Effects.dll

Exception details:

System.UnauthorizedAccessException: Access to the registry key 'HKEY_CURRENT_USER\SOFTWARE\Paint.NET' is denied.

at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)

at Microsoft.Win32.RegistryKey.CreateSubKey(String subkey, RegistryKeyPermissionCheck permissionCheck, RegistrySecurity registrySecurity)

at Microsoft.Win32.RegistryKey.CreateSubKey(String subkey)

at PaintDotNet.SystemLayer.Settings.CreateSettingsKey(Boolean writable)

at PaintDotNet.SystemLayer.Settings.SetObject(String key, Object value)

at PaintDotNet.SystemLayer.Settings.SetString(String key, String value)

at PaintDotNet.ColorsForm.SwatchControl_ColorsChanged(Object sender, EventArgs e)

at PaintDotNet.SwatchControl.OnColorsChanged()

at PaintDotNet.SwatchControl.set_Colors(ColorBgra[] value)

at PaintDotNet.ColorsForm..ctor()

at PaintDotNet.AppWorkspace.InitializeFloatingForms()

at PaintDotNet.AppWorkspace..ctor()

at PaintDotNet.MainForm.InitializeComponent()

at PaintDotNet.MainForm..ctor(String[] args)

at PaintDotNet.Startup.StartPart2()

at PaintDotNet.Startup.Start()

at PaintDotNet.Startup.Main(String[] args)

------------------------------------------------------------------------------

Link to comment
Share on other sites

Admin isn't required. There is something wrong with the permissions on that registry key. Do a search for "Access to the registry key 'HKEY_CURRENT_USER\SOFTWARE\Paint.NET' is denied" (or variations). I'm pretty sure this has been solved before.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to comment
Share on other sites

I've searched on a variety of combinations of the keywords in the error message and am not finding another relevant thread.

I uninstalled Paint.NET, deleted the HKCU/Software/Paint.NET registry key and reinstalled...the error still happens.

I checked the permissions on the registry key and there is an odd entry under the list of user names "Account Unknown(S-1-5-5-0-176429)" Looking at other keys I don't see this listed on any other keys. SYSTEM and Administrators are also listed. The account I use is not listed.

I added my own account to the list and granted permissions, and now it works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...