Sign in to follow this  
Curtis

Curtis' Plugin Pack (Update for 3.5.4)

Recommended Posts

I could be wrong but I think one of the other plugins you have installed is crashing it. Could you do something for me, go to the File menu in Paint.NET and if there is a menu called "View Plugin Load Errors" or something like that, click on that and tell me whats in there. If I am right, and it is other plugins crashing it, then it should be an easy fix. Whatever it is, I won't be able to have a look at it until the weekend though.

Share this post


Link to post
Share on other sites

I did look and it there is no "View Plugin Load Errors" anywhere on any of my menus, i think my computers messed up :shock:

do you think its because Paint.Net v3.30 already has all of your plugins except effects lab cause selective palettes not working either.

Share this post


Link to post
Share on other sites

Well then, the problems not what I thought it was.

Do you get an error message from Selective Palette, would you be able to post it?

Share this post


Link to post
Share on other sites

yeah, here it is.

File: C:\Program Files\Paint.NET\Effects\CurtisBlackEffects.dll
     Effect Name: CurtisBlackEffects.SelectivePalette.SelectivePalette
     Full error message: System.MethodAccessException: PaintDotNet.ColorWheel..ctor()
  at CurtisBlackEffects.SelectivePalette.ColorPicker.InitializeComponent()
  at CurtisBlackEffects.SelectivePalette.ColorPicker..ctor()
  at CurtisBlackEffects.SelectivePalette.SelectivePaletteConfigDialog.InitializeComponent()
  at CurtisBlackEffects.SelectivePalette.SelectivePaletteConfigDialog..ctor()
  at CurtisBlackEffects.SelectivePalette.SelectivePalette.CreateConfigDialog()
  at PaintDotNet.Menus.EffectMenuBase.RunEffect(Type effectType)

Share this post


Link to post
Share on other sites

OK, yep, its because you don't have the latest version of my plugins installed, have you got the latest version downloaded and unzipped into the Paint.NET/Effects folder.

Share this post


Link to post
Share on other sites
What version of Paint.NET are you using? And when you click File is there an option called "View Plugin Load Errors"?

He must be using version 3.30 because that error is from the changes made in 3.30, but I fixed that and the new version doesn't have that problem anymore so I don't get why its not working.

Share this post


Link to post
Share on other sites

That probably wouldn't do anything except waste a lot of your time. I don't know what the problem is, the error you get has been fixed for the latest update and should not still be happening, somethings wrong here but I don't know what it is.

Share this post


Link to post
Share on other sites
Curtis, don't worry about the effects lab not working on my computer, I just wont use it.

Erm, if something is not working on your computer, then there's a very high probability that it's not working on some other users' computers, too. So Curtis should be worrying. Unless he just doesn't care (which is common amongst hobby programmers). :roll:

Share this post


Link to post
Share on other sites
Curtis, don't worry about the effects lab not working on my computer, I just wont use it.

Erm, if something is not working on your computer, then there's a very high probability that it's not working on some other users' computers, too. So Curtis should be worrying. Unless he just doesn't care (which is common amongst hobby programmers). :roll:

I do care, the thing is, I have no idea whats going on. Selective Palette is getting the errors that were from the previous version and simply should not be happening in this version. Effects Lab, well, I have no idea whats going on there. It looks like joshbl56 has my previous version installed but he said he has already installed the latest one.

joshbl56, could you try this. delete my plugin dll from the effects folder and move all the rest to another folder so now your effects folder should be empty. Open up your web browser and clear your download cache, then re-download the latest version and put it in the effects folder and try that. Who knows, maybe you web browser is caching the old version and not letting you get the newest one.

are these all only in pkg form. i much prefer to be able to delete out individual dlls that I don't want.

Yes, sorry, its just a lot easier for me to work on them this way.

Share this post


Link to post
Share on other sites
Man, I am excited to see the other plugins coming from you Curtis. Maybe I should run some of those plugin plans that I sent Pyro past you :wink:

Hey, If you have any plugin suggestions, your more than welcome to let me know, who knows, I might actually be able to do it. :wink:

Share this post


Link to post
Share on other sites

ok, good news, the plugin works perfectly when its the only one in the effects folder and im going to see if its one of the plugins thats messing it up. Curtis, you were right, for some reason, i had one of your old version, i think it said 1.20 or something, so i think the internet was downloading it again since i had never cleaned out my downloads. :oops:

sorry for all the trouble.

edit: i found out what caused effects lab to stop working, its a plugin that i downloaded god who knows when and its called mirror rotate menu, which didn't work with 3.30 anyway, so thanks Curtis.

you might want to tell people that if they downloaded mirror rotate menu, they need to get read of it or it effects lab wont work. Thanks!!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this