Jump to content

copy & paste objects in a picture - "scale pixels"?


Recommended Posts

Hi there,

I'm running into trouble with editing pictures. I need to copy some graphical elements and paste them to other regions in that picture. Whenever I do the following:

1. open picture

2. select an area and mark it ("Rectangle Select")

3. copy into clipboard (Ctrl-C)

4. copy from clipboard into drawing (Ctrl-V)

5. try to move the copied item via mouse drag & drop

then in the 5th step I can only use the mouse to "scale pixels" with the selected items. I'm only able to move the copied item by using the cursor keys. This happened the first time two weeks ago and since then I'm not able to drag & drop a copied rectangle to another place inside that drawing.

Any idea?

Best

Dietmar

Link to comment
Share on other sites

I tried it and there were no issues. You have to tell us a bit more...

1.) What is your Operating System (XP / Vista)?

2.) Do you have any pre-release Service Packs installed?

and make sure you use Paint.NET 3.22.

In my opinion, it is possible that either your Paint.NET or your .Net-Framework was corrupted due to the installation of a different software (2 weeks ago). A basic workaround would be first to try to repair Paint.NET via the MSI package in the Paint.NET/staging directory (right click -> repair) and - if this doesn't work - try to repair the .Net-Framework (Control Panel/Software).

You should wait for other posts and answer my questions before you try my workaround. Otherwise you have to face the danger to do much useless work which has rather negative effects than positive ones.

Good luck and kind regards... :)

Link to comment
Share on other sites

Hey there,

thanks for your reply.

Here are some answers:

1) operating system: Windows XP

2) service pack: SP 2, no pre-release service packs

3) paint.net: Release 3.22

Well, I tried some more tests and noticed that it's some kind of mouse sensitiveness. I can't drag & drop an item sized 25x25 px because the mouse pointer doesn't switch to an arrow. If the item is 35x35 px the mouse pointer switches from a hand into an arrow only when positioning the mouse exactly in the middle of that object.

Didn't notice that behaviour earlier :-(

Link to comment
Share on other sites

Your mouse pointer does not need to be inside of the selection to move it. Just watch for the mouse pointer to change anywhere outside of the selection and move from there.

This is a known issue and Rick will fix it when he gets around to it.

Click to play:
j.pngs.pngd.pnga.pngp.png
Download: BoltBait's Plugin Pack | CodeLab | and how about a Computer Dominos Game

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...