Sign in to follow this  
Bobmail

Why is paint.net my default photo viewer?

Recommended Posts

For some reason which I do not understand paint.net has suddenly seemed to appoint itself as my default photo viewer. Can anyone explain how I stop this happening please?

Bobmail

Share this post


Link to post
Share on other sites

You told it to during installation.

I haven't manually installed for a while, so please allow for slight error, but I do believe there is a screen during setup that lets you choose which file types you wish associated with paint.NET. You simply tick or untick as appropriate.

To undo this, uninstall Paint.NET then reinstall manually again (going for Custom install, not Quick), doing what you need to with the file type association.

EDIT:You should see something like this along the way:

th_PaintNETv320.png

[The same dialog can be found with 3.22 Beta as well, it's just that 3.20 was the most recent at hand; not that version number matters, this dialog hasn't changed for quite a while.]

Don't worry, though, your Recently Opened list and all your plugins shall remain where they were when you reinstall; your regular duties with Paint.NET will not be hindered by this.

Does this help?

Share this post


Link to post
Share on other sites

Thanks Myrddin - the real mystery I have is that I did not just instal paint.net - it's been onboard for about 3 months now - this suddnley happened one day when I opened a photo and it opened in paint.net rather than Office picture which I was expecting!

Anyway I'll try the reinstall you recommend - Thanks again

Share this post


Link to post
Share on other sites

That is quite strange. Perhaps something you inadvertently did to Picture or another program has swapped the associations, although I cannot truly tell without a brief of your daily computer life for the past few weeks. But that really is not necessary :).

Do tell if it works out for you.

Share this post


Link to post
Share on other sites

Actually, you don't need to reinstall it to fix this if you know how to use the Windows Registry Editor. But if you don't know how to use Regedit, I'd recommend that you don't even read this post, because Regedit can very easily damage your system if you do something with it that you shouldn't be doing.

Anyway...

Navigate to this key:

HKEY_USERS\[whichever one you are]\Software\Paint.NET

And delete these values:

PaintDotNet.PngFileType

PaintDotNet.JpgFileType

Really, any key that looks like this:

PaintDotNet.[FileType]FileType

BUT DO NOT DELETE PaintDotNet.PdnFileType!!

Then, repeat for HKEY_CURRENT_USER\Software\Paint.NET.

Share this post


Link to post
Share on other sites

If you open an image from Windows using the "Open with . . ." option, and you tell Windows to use paint.net, it has a checkbox that says "Always use the selected program to open this type of file". If you don't unselect that checkbox, Windows will change the file association.

If you're having the problem with only one file type, that's probably what you did. From the Windows Start menu, click Help & Support, and type "file types" in the Search box. Depending on your version of Windows, you should find an option "Change the program that opens a type of file", which will show you how to change it back.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this