Sign in to follow this  
pyrochild

pyrochild plugins (2017-12-04)

Recommended Posts

Why doesn't it download? i hit the link and click 'download' and nothing happens :(

Sorry Google Chrome was being stupid, nevermind!

Edited by tsobf2424

Share this post


Link to post
Share on other sites

New plugin: Grid Warp

Other changes:

Splatter got a new UI.

Probably a bunch of other things.

Most importantly:

pyrochild.effects.required.dll is no longer required! What a liar! You can delete it forever.

Share this post


Link to post
Share on other sites

I've downloaded the newest version of this and it works fine. However, "Smudge" is missing brushes. It only has one. What happened to "Spray Paint" and the other 2?

Ooops... Never mind. I saw the comments on how to add the PNG brushes.

Edited by scryer52

Share this post


Link to post
Share on other sites

Ok, it's getting weird.

I can't make the outline effect to work.

Downloaded the whole plugin pack

Copied the Outline Object.dll in my Effects folder

Checked that I don't have any other Outline plugin.

Made a new drawing.

Put a simple text in it.

My primary color is black and secondary is white.

I have the last version of PDN.

How do I create an outline to my text?

TIA

Edited by effemmeffe

Share this post


Link to post
Share on other sites

Hello Effemmeffe,

It sounds like you are not running 'outline object' on an object, because you said your secondary color is white.Try this:-

Add a new layer, :AddNewLayer:

Write your text (the text is now an 'object' on a transparent layer. :TextTool:

Run outline object.

Hope that helps

Share this post


Link to post
Share on other sites

In Paint.NET discussions the term 'object' refers to an image element which is located on its own layer. In other words an Object is a collection of pixels on an otherwise transparent layer.

Some plugins require the rest of the layer to be transparent in order to manipulate the edges of an object. (Hint: find these plugins in the Effects | Object submenu)

Share this post


Link to post
Share on other sites

Hi,

I have just installed Paint.Net Final Release build 3.510.4297.28964 using default settings on Win 7.

I downloaded your zip file, extracted contents to a folder on the desktop and then copied the .dll files in to the "effects" folder under the paint.net installation.

Then I started up paint.Net however I don't see any of your scripts appearing when I open "Effects" in the menu. So I tried closing paint.Net, deleting all your .dlls from the effects folder, clearing my browser cache downloading the zip again and repeating the process but no joy.

 

I am specifically interested in the "Scriptlab.dll". Does it work with the latest version of paint.Net?  

Thanks,

John

Share this post


Link to post
Share on other sites

Sorry to take so long to reply but it has taken me this long to uninstall Paint.Net, reinstall it, and then do some more digging which leads me to believe that my problem was a corrupt .Net framework. I have repaired that and now your plugins are working fine.

Thanks for the reply though and also for the excellent plugins! ;) 

Share this post


Link to post
Share on other sites

WOOOAW!!!



 


the grid-warp-tool works even much better
and faster than the grid-warp in PaintShopPro X5, better than
„defpro“ and better than the grid-warp in „HSC Edit3“ (a very
expensive plugin-bundle from humensoftware). This one is the best
one!

 

Thank you very much for creating this
very powerful tool. It's really the fastest and most flexible
grid-warp-tool I've ever seen! Next month I will donate.


(Only a small bug is in it: If you
press the okay-button it doesn't work immediately but first after
„repeat grid-warp“ is done! But nevertheless a very great thing. The other ones I haven't tested yet)



Alexander (from Germany)

Edited by DerAlexander

Share this post


Link to post
Share on other sites

I'm glad you find it useful.

(Only a small bug is in it: If you

press the okay-button it doesn't work immediately but first after

„repeat grid-warp“ is done! But nevertheless a very great thing. The other ones I haven't tested yet)

I'm not quite sure what you mean here. Can you give a list of steps that make this happen?

Share this post


Link to post
Share on other sites

Hello pyrochild,

 

for the first try I made some simple stick-figures and curves (black at white at Paint.NET, Final Release Build 3.510.4297.28964 / Win7) and than I start the

installed plugin "grid-warp". I've changed some settings (more grid-lines and points, horizontaly & verticaly) and deformed the grid a little bit. But after I had

pressed the O.K-button the work "leaves" me (sorry, I don't know the right word here) without any effect. But I tried it once more with the option: Effects > repeat grid-warp.

 

Finally that makes the work come true (or "really")! Please have a look at the topic "Grid Warp" #29 (at page 2; yoggysot and my answer, #30) too. I think yoggysot had

a problem similar to mine (my one).

 

("The other ones I've not tested yet" means the other plug-ins of your Plug-in Pack)

 

 

 

Alexander

Edited by DerAlexander

Share this post


Link to post
Share on other sites

Hello Pyrochild,

 

the same problem happens to me with the smudge tool first (means: today), but - sorry for my false alarm ! - since the last restart of my WOS both plugins are working absolutely correct in every point and step. Means: "immediately" right after have pressed the okay-button.

 

So I didn't find any small bug until now. Thank you once more fore sharing these powerful tools!

 

 

Alexander

Edited by DerAlexander

Share this post


Link to post
Share on other sites

Ahhh so it was something I did and didn't do.

 

I overwrote the fresh download with the effects from my old pc and didn't check things were current.  Thanks ma man

Share this post


Link to post
Share on other sites

Master Pyrochild,

 

Do you have a "Curves+" version which support Paint.Net 4.0 alpha? I just installed the version, and it can't be used any more. When I tried to use it, it said:

 

File: C:\Program Files\Paint.NET\Effects\Curves+.dll
      Effect name: pyrochild.effects.curvesplus.CurvesPlus
      Complete exception message: System.TypeLoadException: Could not load type 'PaintDotNet.EventArgs`1' from assembly 'PaintDotNet.Base, Version=4.0.5105.6977, Culture=neutral, PublicKeyToken=null'.
   in pyrochild.effects.curvesplus.ConfigDialog..ctor()
   in pyrochild.effects.curvesplus.CurvesPlus.CreateConfigDialog()
   in PaintDotNet.Menus.EffectMenuBase.RunEffectImpl(Type effectType) location D:\src\pdn\paintdotnet\src\PaintDotNet\Menus\EffectMenuBase.cs:line number 915

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this