Sign in to follow this  
pyrochild

pyrochild plugins (2017-12-04)

Recommended Posts

Not to sound ungrateful or impatient or anything, because I'm not :), but is there any word on zooming-in along with the cursor or moving the mouse in exact increments with the arrow keys? These are probably the only features missing from these plug-ins, otherwise, they're great.

Zoom is coming. Not sure what you mean by zooming along with the cursor, though.

I'll look into keyboard-cursor-control.

I assure you that there are quite a few missing features that I plan on adding :)

Share this post


Link to post
Share on other sites

Not sure what you mean by zooming along with the cursor, though.

It would be the same functionality as Paint.NET in that, if the cursor is in the bottom-left corner while zooming in, the zoom will focus on the area where the cursor is located so that you won't have to use the scroll bars as often if at all.

I'll look into keyboard-cursor-control.

I assure you that there are quite a few missing features that I plan on adding :)

Looking forward to it. Keep up the good work!

Edited by KeyLogic

Share this post


Link to post
Share on other sites

Is the preview for smudge ever coming back? I liked how it would show the outcome outside of the plugin before I actually clicked the "ok" button. I just recently updated everything so I could try liquify and twist but my old smudge stopped working so I had to update to this new one that doesn't do it.

Having to click the "ok" button each time now is really slowing me down. I will be reverting back(hopefully) but I am just curious for future updates. Thanks in advanced bud. I love your plugins. :mrgreen:

Edited by mero

Share this post


Link to post
Share on other sites

I did not realize:

  • That I had ever implemented such a feature
  • That anyone used said feature
  • That I had subsequently removed said feature

I can certainly look into readding it to Smudge, Liquify, and my other canvas-based plugins.

By the way, Liquify does not depend on pyrochild.effects.REQUIRED.dll, so if you really need the old version of Smudge (which does depend on it), you can still install Liquify.

Share this post


Link to post
Share on other sites

I did not realize:

  • That I had ever implemented such a feature
  • That anyone used said feature
  • That I had subsequently removed said feature

I can certainly look into readding it to Smudge, Liquify, and my other canvas-based plugins.

By the way, Liquify does not depend on pyrochild.effects.REQUIRED.dll, so if you really need the old version of Smudge (which does depend on it), you can still install Liquify.

lol oh. The version i reinstalled is 2.3.3627.29846 apparently just in case you wanted to know a version that had it. Thanks a lot for the fast reply bud.

Edited by mero

Share this post


Link to post
Share on other sites

Please try to bear with me here, but I'm not understanding the tutorial on how to download plugins. I was wanting to make one of Pyrochild's sig pic thingys. The one with the gradiant lines and water reflections. Am I supposed to download and install everything in his New Year's Eve plugin post? or Just the ones (I think there are 7 of them) that are under where he says here it is the long awaited graident thing. Like I said before I'm 57 so I'm not all that good at the PC, but I really would like to learn how to do some of the things I'm seeing you all can do on here.

thanks

vtdad

Share this post


Link to post
Share on other sites

Ahh, it's nice to be back after over a year away... my obsessive hobbies come and go, and it looks like I've come back around to Paint.NET and making maps of fictitious places. :) Thanks, Pyrochild, for still being here and continuing to update these excellent plugins. Gradient mapping is one of my favorites and virtually indispensable for the stuff I do. I even included it in a tutorial I wrote for a cartography website back in 2009.

Cheers, everyone!

Peace,

Heather

Share this post


Link to post
Share on other sites

hello guys,

thank you for these plugin. But I have a problem with few of them. Like Splatters, I don' t find it in "artistic", nothing is there !! look at this:

5b1f587d7a7d1f53736750c3ba265.png

Can anyone help me please ? I don' t understand why I don' see it. I have the latest Paint Net (Paint.NET v3.5.7 (Final Release build 3.57.4068.30273)). is it because I have installed others plug in ? is this 'bug' arrive to others pr it is only me ?

For more precisions, let see my "effect" folder, here:

59d4aa47396f1a0267213ccca7fbbtt.jpg

38c85ac4ead3b76722e72d4344f27tt.jpg

cf4666833ffae95c265c1021866d2tt.jpg

The plugin wich I would like the most to use it would be splatter, but there are others that I can' t see in Paint Net. I have tryed with an other (old) version of Paint Net (portable), but it does not appears anymore !

I really appreciate your help guys

5b1f587d7a7d1f53736750c3ba265.png

Edited by iskander71

Share this post


Link to post
Share on other sites

Your version of Splatter.dll is old, and needs to be updated.

The other plugins that you can't see are probably out-of-date also.

pyrochild.effects.common.dll is obsolete, and should be removed.

Share this post


Link to post
Share on other sites

You can install all of them, or only the ones that you want.

In any case, pyrochild.effects.REQUIRED.dll should always be installed.

Where can I find pyrochild.effects.REQUIRED.dll ?

Share this post


Link to post
Share on other sites

Go to the first post of this thread and click on Download from box.net.

pyrochild.effects.REQUIRED.dll is in the plugin pack.

.

Edited by Sarkut

Share this post


Link to post
Share on other sites

Hey, I really enjoyed using your plugins. Great Job. But Paint.Net has now updated to v3.5.8 and I am not able to use your plugins... This is what I get:

This plugin has encountered an error, and must be closed.

Because of the unpredictable nature of these types of errors, it is strongly recommended that you restart Paint.NET before proceeding. Otherwise, there could be further stability problems or data corruption.

Error Details:

File: C:\Program Files\Paint.NET\Effects\Curves+.dll

Effect Name: pyrochild.effects.curvesplus.CurvesPlus

Full error message: System.IO.FileNotFoundException: Could not load file or assembly 'pyrochild.effects.REQUIRED, Version=3.6.3627.29844, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

File name: 'pyrochild.effects.REQUIRED, Version=3.6.3627.29844, Culture=neutral, PublicKeyToken=null'

at pyrochild.effects.curvesplus.CurvesPlus.CreateConfigDialog()

at PaintDotNet.Menus.EffectMenuBase.RunEffectImpl(Type effectType) in D:\src\pdn\pdn_35x\src\PaintDotNet\Menus\EffectMenuBase.cs:line 799

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Share this post


Link to post
Share on other sites

Full error message: System.IO.FileNotFoundException: Could not load file or assembly 'pyrochild.effects.REQUIRED

(my emphasis)

Have you got this file installed along with the other files? If you can't find it you'll need to download the package again as that's where you can find it boltbait.wink.png

Share this post


Link to post
Share on other sites

Hey pyrochild. I had some of your plugins on my old laptop and they're amazing. Great work! I finally got the download to work on the updated ones (2011-4-05) and I can't wait to start using them.

I wanted to note for anyone who might also have trouble with the download; I needed to allow cookies from box.net to get the link to work. Otherwise I got a "User not allowed direct links" error message. Probably a noob mistake on my part. Anyway, great stuff man. Thanks again.

Share this post


Link to post
Share on other sites

Hey pyrochild. I had some of your plugins on my old laptop and they're amazing. Great work! I finally got the download to work on the updated ones (2011-4-05) and I can't wait to start using them.

I wanted to note for anyone who might also have trouble with the download; I needed to allow cookies from box.net to get the link to work. Otherwise I got a "User not allowed direct links" error message. Probably a noob mistake on my part. Anyway, great stuff man. Thanks again.

Yeah, allowing cookies made it work for me also.

Share this post


Link to post
Share on other sites

Strange thing keeps happining i download it and all go to prpertys and past this into effects and it say error and i say skip and at the end you have to skip all of them :L eney ideas why this is happining?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this