Jump to content

Apparent Bug with Rotate/Zoom Layer


Aakanaar
 Share

Recommended Posts

It was working the other night, now.. suddenly.. When i rotate the layer by 90 degree's, instead of a nice crisp clean layer, i get something that looks like i've glausian blurred it.

I don't have any idea what's changed. I havn't downloaded any new plugins since it was last working, nor updated the software (it's currently 3.10). I've not made any other changes to the computer.

Before it would rotate the layer.. now.. Let me get a screenshot of what i mean.

...

Ok.. scratch that.. now suddenly it's working again.. I replicated the problem all morning long, and now when I need it, i can't. There is a bug in there somewhere, not easily reproducable i guess. Consider this just a report.

jgswsigxo7.png
Link to comment
Share on other sites

It has to do with anti-aliasing. When rotating a pic with non-anti-aliased( :AntiAliasingOff: ) pixels, it blurs them, as the pixels are in a grid, so when rotated, half of a pixels might be in one grid section and the other half in another, so it shades them to make it look like it is in only one.

I would suggest either enabling anti-aliasing( :AntiAliasingOn: ) or using "flip horizontal/ vertical".

Link to comment
Share on other sites

It has to do with anti-aliasing. When rotating a pic with non-anti-aliased( :AntiAliasingOff: ) pixels, it blurs them, as the pixels are in a grid, so when rotated, half of a pixels might be in one grid section and the other half in another, so it shades them to make it look like it is in only one.

I would suggest either enabling anti-aliasing( :AntiAliasingOn: ) or using "flip horizontal/ vertical".

That shouldn't have any effect. Rotate/Zoom uses its own sampling method which is separate from the Anti-aliasing( :AntiAliasingOff: / :AntiAliasingOn: ) settings .

Are you adjusting anything beside the rotation "Angle"?

Edit:

What was you image resolution when you were able to reproduce this? I think I might have gotten this to work(not work...:lol:)

 

Take responsibility for your own intelligence. ;) -Rick Brewster

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...