Sign in to follow this  
usedHONDA

I finally got a working homepage!

Recommended Posts

http://usedhonda.110mb.com/index.htm

^^That's it^^

I had an old homepage, but it really stunk. But this one is true XHTML and CSS. I originally took it from a template, but thought that it still wasn't that good. so I changed some colors, added some images, and poof! A cool homepage! The only challenge I have is to find a way to disable capital letters for the headings. Another thing is that there's the weird "A" symbol that keeps appearing on front of my copyright symbol.

Comments and suggestions!

Share this post


Link to post
Share on other sites
I originally took it from a template
copyright © 2007 usedHONDA

^ Something must be wrong...

Also this makes me laugh.

The copyright symbol thing is a encoding problem.

Share this post


Link to post
Share on other sites

Hehe. Clean it up, usedHonda.

"Template © [Whoever you got it from]; Content © usedHonda."

Also, you need to put this at th beginning of the page:

/p>

"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

Share this post


Link to post
Share on other sites

It was okay until I edited the page again. I guess that's what happens when you edit a page from one program, open it in another, copy and paste the code into the online editor, and do more editing over there :)

EDIT: Oh great. Now there's two of those "A" thingys!

Share this post


Link to post
Share on other sites
Also, you need to put this at th beginning of the page:

/p>

"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

If so, you have to serve it as application/xhtml+xml mime type.

Else, use XHTML 1.0 Strict.

Share this post


Link to post
Share on other sites
copyright © 2007 usedHONDA | usdhnda@gmail.com

This is really getting out of hand. Though I'm still laughing about it :D

EDIT: Fixed it! Something got lost in translation while copying and pasting code.

Share this post


Link to post
Share on other sites

You say

The land where only 'HONDA' is capitalized

Yet I can see there is more than that... The WELCOME ALL!, The menu and there might be more but they're all capitals :P

Share this post


Link to post
Share on other sites

Well, right in the source, there's this:

As for the copyright symbol, are you using the ASCII copyright symbol, or are you using the global entity?

Global entity declaration: ©

The global entity is the better way to go, as ASCII or utf-8 specific symbols can change depending upon the font set used, resulting in something like so:

? 2004 Fear The Dead

I know I've had that one happen before, specifically, here:

http://www.freewebs.com/fearthedead/

(One of my old-old, very old sites, back when FrontPage 98 was my editor of choice...)

Also, the A:circumflex is displayed like so in IE6:

copyright © 2007 usedHONDA

It may be a result of the text-transform:uppercase; declaration on the A:circumflex, but I am not positive. When I save a local copy to test, it does not occur.

The Copyright symbol is shown without even the A:circumflex in Opera and IE7.

As far as the design goes, it looks rather nice. The Square

marker is rendered inconsistently cross-browser - in Opera, it's just to the left of each link text, in Firefox, it's further left, putting the marker for each within the hover area of the link before it, and in IE it doesn't show up at all.

Though I can't much talk. I changed the design of http://cmdsketchpad.com/ some, changing the footer from a simple copyright declaration to a link array, pulling the four newest tutorials from the database (yes, I know I only have one...), allowing one to access the acceptable use and browser compatibility declarations, and all that pretty stuff. I used the list-style-type:georgian; style, and IE doesn't know how to handle it. But I stopped caring. The redesign used to not work in IE6, and I was able to fix that, but I'm not removing my cool Georgian markers on IE's account.

copyright [b]©[/b] 2007 usedHONDA

Share this post


Link to post
Share on other sites

You know that banner image-thing (this one)? I took that from the origional template, changed the color, and added the nice little gradient. I was planning on something different (with gradients), but it seemed to look good like that. I'm guessing that will stay there for a few weeks.

Now for the replying part:

You say
The land where only 'HONDA' is capitalized

Yet I can see there is more than that... The WELCOME ALL!, The menu and there might be more but they're all capitals :P

Yeah, I'm trying to find a work around for that (like using the most hated font tags).

Instead of using the actual © symbol, use "©" That will help.

I figured that out about a few hours ago. It's weird how putting a symbol creates 5 more symbols.

Your 'Home' link is broken. :roll:

I know. I put "index.html" instead of index.htm

This one makes me laugh...
an a href tag
It's an anchor tag (I think the 'a' is anchor) with an href attribute :P

I added that a month ago and it stayed. I guess I'll take it off when the homepage is complete.

Now I'm down to 2 errors that I feel are correct.

EDIT: And I know what caused all of this. The ASP.NET Web Matrix.

Share this post


Link to post
Share on other sites

Maybe it was maybe it wasn't..... no, it wasn't :(

EDIT: I just fixed several things:

# Got rid of the semicolon.

# Corrected the "Home" link.

# Got rid of another semicolon that nobody else was going to see in the first place.

Share this post


Link to post
Share on other sites

I just put in my new favicon! Believe it or not, that took 8 layers! I'll give you the .pdn if you want me to prove it.

@Bob: The "problem" is in colour.css. I think I'll experiment and see what I can do (or go to an html forum).

Share this post


Link to post
Share on other sites

Grrr! 110MB originally said it would be open to registrations again by 16/04/07 (Monday - for me) and now they are saying May 1! I can't wait that long

Share this post


Link to post
Share on other sites

Yeah, the W3Cs "Hey look how awesome I am" buttons don't look very awesome.

Many websites I've seen that have links to their validation results use basic text links. I know I do! :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this