Sign in to follow this  
OrbitUtmost

"Windows 7 SP1 or Newer is required" Installation error - Help

Recommended Posts

First off, thank you for your time,

Secondly, my problem.

 

I recently did a factory reset on my PC and reinstalled windows 7. I then tried to install PAINT.NET and received the "Sp1" Error.

 

Yes, I'm using verified version of windows and the latest install from http://www.getpaint.net/download.html

 

 

After reading the forums, I updated to Sp1, and tried again. Same error.

Using the forums, here's what I've tried so far.

- Update to SP1

- Install ALL windows updates

- Reinstall the Microsoft .Net framework to 4.5.2 (http://www.microsoft.com/en-us/download/confirmation.aspx?id=42643)

- Unzip the download folder and run the Paint.Net installer then,

- Cold restart the system with these updates

 

After all of these, I still receive the error of "Windows 7 SP1 or newer is required" despite having it installed.

 

Any help is greatly appreciated,

Thanks!

 

Screen Shots are here: http://imgur.com/a/Z5sRb

Share this post


Link to post
Share on other sites

This is a known problem with SP1 not being recognized. Last time it was reported, a repair to .NET fixed it.


Open the "Programs and Features" control panel.

 

Locate the entry "Microsoft .NET Framework 4.5" in the list (might also be listed as 4.5.2).

Click on the entry, then click on the "Uninstall / Change" button, and choose Repair.

 

 

Once that is done, disable your anti-virus and do a cold boot.

 

Attempt re-installation from unzipped  download (not running the exe from within the ZIP file).

 

Please let us know how you get on.  Good luck. 

 

Share this post


Link to post
Share on other sites

Hey, thanks for the help. Sorry it took me so long to get back to you.

 

Here's what happened:

- Attempted to repair the .Net --> It error, complaining about an invalid object.

- Uninstalled the . Net and then restarted the PC

- Reinstalled the .NET and did a successful repair

- Turned off firewall and shutdown

- Turned on PC and attempted install --> Still got the "Sp1 is needed" error

- Re-downloaded the installer from getpaint.net (and extracted using default windows) --> Same error again.

 

Long story short, a lot of restarts --> same result.

 

If there's any other fixes, let me know. Thanks!

 

 

--- Aside ---

If it just wont fix, I still have the 3.5.11 paint.net installer on a flash drive somewhere, along with all the plugins, so I'm not completely out of luck. (hopefully this line doesn't get me ban hammered, I'm not recommending this to anyone or giving a download, just noting that I have another option if 4.0.5 won't run.)

Share this post


Link to post
Share on other sites

Ok.  Let's take a step back and ensure SP1 is correctly installed

 

Start Menu > Computer (right hand sidebar) + Right click > Properties (alternatively Control Panel > System and Security > System)
 
Under the heading "Windows Edition" does it say SP1 is installed?
 
yhsjjie-668.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this