Jump to content

Installation Error 1603 (4.0.2 and 4.0.3)


Recommended Posts

I hope that I can finally resolve this issue.

 

It all started when PDN prompted me to update to 4.0.2 a few weeks ago when I opened it. After closing and attempting to update, I got fatal error 1603 and it closed. PDN was then no where to be found on my PC. After looking through the logs, I found one error - actually, the only log that had anything in it:

 

"32 bit MSI may not be installed on 64 bit OS."

 

I've looked through everything, read all the fixes, tried almost all of them (trustedinstaller download says the file is invalid, so I can't use that) ran as admin, installed .NET 4.5.2, repaired it, etc, etc, etc. I've been through so many restarts and whatnot. PDN has chosen to fail when I need it the most, and I'm not going to waste $100+ on a 32 bit OS just so I can install a program. I've also googled everywhere to no avail. So please, can someone help me? Like I said, I really need PDN right now.

Link to comment
Share on other sites

http://forums.getpaint.net/index.php?/topic/17903-x64-msi-wont-install-on-64bit/

this sounds related. try to double-check the error message for more text which may relate it to that link, which posted more text in the error message. 

 

You can't conclude that you need a new 32-bit OS to install paint.net. It could be a dysfunction in your current 64-bit OS, as the above link would suggest. In fact, it is definitely untrue that a 32-bit OS is required to install paint.net. So don't do that.

  • Upvote 1
Link to comment
Share on other sites

That didn't help me. Again, the only logs I see are PdnMsiInstall and pdnSetupshim:

This is the PdnMsiinstall:

=== Logging started: 7/30/2014  20:31:46 ===
32-bit MSI may not be installed on 64-bit OS.
=== Logging stopped: 7/30/2014  20:31:47 ===
 
And this is the pdnSetupshim:
--- paint.net SetupShim starting, lpCmdLine='/suppressReboot', nCmdShow=10
CoInitialize(NULL) returned 0
Checking OS requirement
    bIsWin7SP1 = true
    bResult = true
EnsureOSRequirement() returned 0
Called EnsureTrustedInstallerIsEnabledAsync()
Checking .NET requirement
    bIsNetfx45Installed = true
    bIsSupportedNetfxInstalled = true
    bIsNetfxInstallerPresent = true
PreInstallPrompt() returned true
InstallNetfx() returned 0
Launching paint.net installer. bRebootRequired=false
 

I didn't find anything about Paint.Net in my registry. Any further help would be greatly appreciated.

 

EDIT: is there a manual install? Like PDN compiled into a ZIP folder that I can just extract?

Edited by ABilly05
Link to comment
Share on other sites

I can't make sense of "trustedinstaller download says the file is invalid, so I can't use that". It sounds garbled.

 

Have you redownloaded the paint.net installer? Perhaps you have -- perhaps 'invalid' is referring to an older version of paint.net's installer, which it is attempting to uninstall first, if the link i pasted is related. That link doesn't say there should be anything obviously about paint.net in your registry, it discusses a cryptic number in your registry. At any rate, you can search for msizap which lets you clear out MSI's awareness of old things to uninstall, or discover whatever microsoft thinks is an adequate replacement (some troubleshooting wizard), or whatever people are doing instead of msizap nowadays, or find a link to an old copy of msizap.

 

There are a lot more links on this forum about the subject. I'm confident youre having the same problem

 

http://forums.getpaint.net/index.php?/topic/20393-issues-installing-356-on-windows-7-x64/

http://forums.getpaint.net/index.php?/topic/18931-fatal-installation-error-1603-fix

Link to comment
Share on other sites

But have you tried this?

There's nothing wrong with the installer.  I've used it on six different 64-bit systems with zero problem; more to the point, so have hundreds of thousands of others.  The problem is definitely on your end, so if you want help please follow these steps.

 

The Doctor: There was a goblin, or a trickster, or a warrior... A nameless, terrible thing, soaked in the blood of a billion galaxies. The most feared being in all the cosmos. And nothing could stop it, or hold it, or reason with it. One day it would just drop out of the sky and tear down your world.
Amy: But how did it end up in there?
The Doctor: You know fairy tales. A good wizard tricked it.
River Song: I hate good wizards in fairy tales; they always turn out to be him.

Link to comment
Share on other sites

I've tried everything in both threads already, and already got it working through LiberKey. I can't find any fix.

 

It probably has something to do with the fact that my computer got screwed up about a year ago and I had to reinstall Windows via a USB because my computer never shipped with any discs. But what's important here is I got the app working.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...