Sign in to follow this  
TechnoRobbo

The Plugin Browser (Updated 2015-24-01)

Recommended Posts

Seems the remaining issues are now the disappeared help button (top right) and the width of the slider.

 

If you are creating your own vertical scrollbar then you should check that you are using SystemInformation.VerticalScrollBarWidth to set the width. This value is scaled.

Share this post


Link to post
Share on other sites

 

 

Seems the remaining issues are now the disappeared help button (top right) and the width of the slider.

The Listbox should be easy because that's my own Owner-Drawn. I have just been concentrating on the standard form controls.

 

The "Help" LinkLabel is the hard one because it's defying conventional techniques in HDPI mode (a mind of it's own) - I may have to use a regular Event-Driven Label which appear to be easier to manage.

 

Either way - I'm really close to making it HDPI friendly.

Share this post


Link to post
Share on other sites

Thank you for creating this wonderful plugin, it will make everything much easier :)

 

I seem to be having a problem with downloading the list of plugins, could it be because I am behind a proxy? Paint.NET itself is able to find updates and updated itself to 4.0.5 today.

 

I am not getting any error message, only an empty list (except for the builtin effects and the Plugin Browser)

 

Thank you in advance!

 

Share this post


Link to post
Share on other sites

Yes actually Red tested it on his XP with 3.5. It appears that you are using custom color scheme and all your label text are white. The center Graphic Listbox inherited that. Try the standard windows color scheme and see if that fixes your issue. If that's the problem I can force some label colors.

Share this post


Link to post
Share on other sites

Thanks TR. The color scheme was the issue. I changed and everything is fine.

Edited by xod

Share this post


Link to post
Share on other sites

Yes actually Red tested it on his XP with 3.5. It appears that you are using custom color scheme and all your label text are white. The center Graphic Listbox inherited that. Try the standard windows color scheme and see if that fixes your issue. If that's the problem I can force some label colors.

 

This plugin is running in PDN 4.0.5 ?  B) 

Share this post


Link to post
Share on other sites

I have often looked at the Plugin Browser but up until now never bothered to download it as I felt it was just as easy to find what you want the usual way and I could not see the benefit of having to click on a plugin to find a plugin. But since changing laptop , which has a lower resolution screen , I found it tricky to access Distort and Render plugins at the bottom of the (long) list as PDN will not let you scroll down. The little arrow I find terribly awkward to use and often I find myself closing the list instead of finding and choosing the plugin I want.

So today I downloaded and installed this plugin and what a relief! Finally I can easily access all the plugins by scrolling down. I must say that it is unlikely that I will be using it where the plugin list does not go off the bottom of the screen as it is still faster to go directly to those ones but for the long lists it is so much easier.

 

Many thanks for this great plugin guys, it has definitely made life a little bit easier. :):beer:

  • Upvote 1

Share this post


Link to post
Share on other sites

 

Version 1.0.2+ Ready for Download

 

v 1.0.2.+ Fixes New Year Bug preventing new Plugin Index  data from being downloaded

 

 

@ Fine !!! Very impressive, very good work. That's great ,indispensable, perfect. Thanks to all who have worked with.  :beer:  :pizza:

Share this post


Link to post
Share on other sites

There is a visibility issue when using Classic and high contrast themes in Windows 7. See attachments. This is not the case with rest of Paint.net when having these themes active.

 

post-140057-0-82332600-1421837562_thumb.     post-140057-0-73473800-1421837574_thumb.

 

Edit: I see now this has been menthioned before in an earlier post in some way. I didn't want to read all the posts to check if this has been posted before. Allthough my post is about the default themes shipped wth Win7.

Edited by datiswous

Share this post


Link to post
Share on other sites

There is a visibility issue when using Classic and high contrast themes in Windows 7. See attachments. This is not the case with rest of Paint.net when having these themes active.

 

@datiwous! Welcome to the forum. I also have Windows 7. The plugin browser wonderful.

Share this post


Link to post
Share on other sites

Version 1.0.3.+ Ready for Download

 

 

There is a visibility issue when using Classic and high contrast themes in Windows 7. See attachments. This is not the case with rest of Paint.net when having these themes active.

 

Version 1.0.3.+ adjusted to work with Windows themes

Share this post


Link to post
Share on other sites

Any way you can disable plugin update, or at least provide a button to turn it off? This is what keeps me from using it. My editing system is not (nor will ever be) connected to internet, every time I launch this plugin, it tries to connect.  

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this