Sign in to follow this  
zipmmcs

Blurry application fonts

Recommended Posts

Hello,

 

I faced wiht a symptom with the Paint.NET 4 on Windows 7 x86/x64 Home Premium and Enterprise. The VGA card (if matters) is an ATi 7770, but tested on i3's internal GPU and on HD 6750 as well. All the application fonts (including menus and title bar) shows the fonts blurry - please see attached picture.

I tried different ClearType settings including turning it off completely without any progress.

With the previous version (3.5.10/11) I did not observe this issue. If there is a workaround or solution already, please share with me.

 

Thanks & Regards,

zipmmcs

Share this post


Link to post
Share on other sites

I don't see an attached picture.

Please host it at photobucket (or some other hosting site) and post the link here.

Share this post


Link to post
Share on other sites

Hi Pixey,

 

first of all thank you for answering my issue. But you misunderstand the situation. This is and interface issue.

OK. I reuploaded the picture with some markings - I was hoping that the screenshot itself will be talkative enough. Link: http://i1285.photobucket.com/albums/a597/zipmmcs/PNET_401_zpsedcc678a.png

- Adjustments menu: the letter "n" is barely visible.

- Effects menu: the subpixel rendering kills the clear visibility.

- Layers menu\Import From File...: also issue of subpixel rendering - the "I" is not black, but somewhat brown.

- Layers menu\Flip Horizontal: letter "n" is also badly visible.

 

With the same setup the Paint.NET 3.5.11 was just perfect. I cannot recall if different font was used for the interface of the software. For me it is obvoius that the interface font has issues and cannot be rendered perfectly - or an extra clear type rendering applied to the interface of the software.

The situation is even worse when a poor DPI monitor is used like a 5:4 aspect ratop 19"@1280x1024 or a 16:9 24"@1920x1080, it is just bad. I'm sure that this is not a uniqe or user dependent issue since on different setups under different user accounts I can see the problem.

 

Is it possible to change the interface font somehow, like from command parameters?

 

Thanks and Regards,

zipmmcs

Share this post


Link to post
Share on other sites

Ahhhh - yes I thought you meant the 'functions' were not highlited.

 

So, it could be an artifacts problem .... see here perhaps this will help.  Hope so anyway :)

Share this post


Link to post
Share on other sites
Guest

I have the same problem.

 

-win7 x64

-AMD Radeon 14.6 drivers

-hardware acc on/off

-no problems with 3.5

-default system font changed from Segoe to Arial

 

s87w.png

Share this post


Link to post
Share on other sites

Also, if you change the settings for font smoothing, antialiasing, or the ClearType settings, you'll need to restart paint.net. For performance reasons it only gets that info at startup.

Share this post


Link to post
Share on other sites

The cleartype tuned for darker - every applications provides better readability. Just reinstalled 3.5.11 to _exactly_ the same setup - including cleartype tuning: http://i1285.photobucket.com/albums/a597/zipmmcs/PNET_3511_zps4fae7d8a.png

No blurry font issue. So there is a difference between the two releases from interface point of view which gone bad.

 

Regards,

zipmmcs

Edited by zipmmcs

Share this post


Link to post
Share on other sites

quickpost, The font rendering looks really broken, color-wise, in that screen shot ... O_o

 

Paint.NET is using a high-quality DirectWrite rendering mode called "natural symmetric." Old versions used good ol' GDI for rendering. Some people just don't like the way DirectWrite does it. *shrug* Edit: it also looks like it is buggy on some systems, giving text a weird "rainbow" appearance

 

I have something y'all can try if you really don't like the way the fonts look.

 

You can download the ZIP attached to this post, and then double-click the .REG file inside of it. It will force Paint.NET to use another DirectWrite rendering mode that should look the same as "good ol' GDI".

 

Or you can make the modification yourself by opening up Registry Editor and going to HKEY_CURRENT_USER \ SOFTWARE \ paint.net, then add a String key called "UI/DefaultTextRenderingMode" (without quotes) and set its value to "ClearTypeGdiClassic" (without quotes).

 

Here's the contents of the .REG file which is inside the .ZIP:

Windows Registry Editor Version 5.00
 
[HKEY_CURRENT_USER\Software\Paint.NET]
"UI/DefaultTextRenderingMode"="ClearTypeGdiClassic"

PDN4_GDIClassicText.zip

Share this post


Link to post
Share on other sites

I would like to take this opportunity to say thanks for making paint.net is one of the few new relatively new programs in the universe which doesnt forcibly enable text antialiasing.... anywhere. I don't know whether this was on purpose or not, but I imagine the existence of this registry hack is a sign of taking it seriously.

Share this post


Link to post
Share on other sites

 

...

 

Dear Rick,

 

thank you very much for the quick and comprehensive answer on the topic. It behaves as expected on all PCs now. My problem is solved now.

 

Thank you and best regards,

zipmmcs

Share this post


Link to post
Share on other sites

I would like to take this opportunity to say thanks for making paint.net is one of the few new relatively new programs in the universe which doesnt forcibly enable text antialiasing.... anywhere. I don't know whether this was on purpose or not, but I imagine the existence of this registry hack is a sign of taking it seriously.

 

It seems that most people don't notice / don't care. But for those who do notice/care, it's either something they're super passionate about ("I hate this!") or it just doesn't work for their eyes. So it's good to have an "escape hatch."

 

I don't know if you used some older WPF applications but they had this nasty problem whereby if text was moving (e.g., a scrollable area of text, or any type of animation thingy), the text would be super blurry for a moment once it "settled." That really messed with my eyes trying to focus, and there were some cases where I just couldn't use a certain piece of software because of it. Or I had to train myself to look away and then look back. It was a very unpleasant feeling.

Share this post


Link to post
Share on other sites

I'd just like to post that I had the same issue on my laptop; Windows 8.1.  The .reg file in this thread fixed my issue.

 

I'm using two external monitors via display port, Paint.NET on primary monitor.  Native screen resolution is 2560 x 1440.  All other applications render fonts correctly, but Paint.NET was really messed up.  It's almost like it was subpixel rendering the fonts with incorrect knowledge of the pixel colour components (ie: RGB vs BGR).

 

Here's a copy of my Diagnostics information:

 

Application paint.net 4.0.1 (Final 4.1.5306.43142)
Build Date Saturday, 12 July 2014
 
Hardware accelerated rendering (GPU) True
Animations True
DPI 96.00 (1.00x scale)
Language en-US
 
OS Windows 8.1 (6.3.9600.0)
.NET Runtime 4.0.30319.34014
Physical Memory 16,323 MB
 
CPU Intel® Core i7-4900MQ CPU @ 2.80GHz
    Architecture x64 (64-bit)
    Process Mode 64-bit
    Speed ~2794 MHz
    Cores / Threads 8
    Features DEP, SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, XSAVE
 
Video Card NVIDIA Quadro K2100M
    Dedicated Video RAM 1,958 MB
    Dedicated System RAM 0 MB
    Shared System RAM 8,161 MB
    Vendor ID 0x10DE
    Device ID 0x11FC
    Subsystem ID 0x05CC1028
    Revision 161
    LUID 0x00008839
    Flags None
    Outputs 2
 
Video Card Microsoft Basic Render Driver
    Dedicated Video RAM 0 MB
    Dedicated System RAM 0 MB
    Shared System RAM 256 MB
    Vendor ID 0x1414
    Device ID 0x008C
    Subsystem ID 0x00000000
    Revision 0
    LUID 0x00009309
    Flags Software
    Outputs 0

Share this post


Link to post
Share on other sites

Have there been changes in 4.0.1 compared to 4.0 regarding the rendering of fonts?

 

D3dno7J.png

Left 4.0, right 4.0.1

 

Disabling hardware-acceleration doesn't help.

Win7 SP1, .NET Runtime 4.0.30319.18444, nVidia GT 640, 337.88

Edited by Elbart

Share this post


Link to post
Share on other sites

There wasn't supposed to be but I'm seeing several people reporting this. I'm trying to figure out what change could've possibly caused this.

 

Are you using a rotated monitor by any chance?

Share this post


Link to post
Share on other sites

Okay I think I figured this out. I accidentally swapped the ClearTypeLevel and EnhancedContrast values in 1 location, due to inconsistent ordering between 2 different representations of the text rendering parameters.

 

I'm planning a 4.0.2 update for today or tomorrow, so please just bear with the font rendering for a little while longer.

Share this post


Link to post
Share on other sites

Have there been changes in 4.0.1 compared to 4.0 regarding the rendering of fonts?

 

D3dno7J.png

Left 4.0, right 4.0.1

 

Disabling hardware-acceleration doesn't help.

Win7 SP1, .NET Runtime 4.0.30319.18444, nVidia GT 640, 337.88

I've been running 4.0 for plugin development and hadn't updated to 4.0.1. So, I didn't see the same issue that you all have seen in this thread. Had I upgraded, I would have been "up in arms" as well. I just upgraded and must say that Version 4.0.1 hurts my eyes.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this