Sign in to follow this  
david.atwell

Common paint.net 4.0.0 problems - Flickering? Won't start? CHECK HERE FIRST!

Recommended Posts

First, if you're still running version 4.0.0, upgrade to the latest version of Paint.NET (currently 4.0.1 as of this writing). It's no longer in Beta, holds the same great new features introduced in 4.0.0, and should give you great results. Head over to this page (always current) to get it.

If that didn't work, the below is worth a try (though they are fixes specific to 4.0.0, they're fixes worth trying anyway).  Click the "show" link to view them.  If none of that works, feel free to start a troubleshooting thread with your problem and we will try to help you as best we can.

Hidden Content:
Having one of these issues? Try the fixes below before asking for help. Odds are it'll probably fix the problem. I promise.*

Visual Artifacts, Flickering, etc.

paint.net 4.0 has some great new hardware acceleration, but it doesn't work for every video card yet. If you're having flickering, strange white squares when you move the mouse, and generally things that don't look quite right, try this fix:

1. Click the :Settings:Settings icon in the top-right.

2. Toggle "Hardware accelerated rendering (GPU)" off.

Feeling adventurous? Head over to the paint.net 4.0 preview center and give the 4.0.1 Beta a try instead; many users have reported a fix with it.

"(null)" or "BadImageFormatException" Error on Start

Do you have an error that looks like this?

paint.net error.jpg

1. Navigate to C:\Program Files\Paint.NET (or whatever the directory where you installed the program).

2. Run the program PdnRepair.exe.

3. Restart paint.net.

If you're still having issues after trying these steps and have used the site search to make sure it hasn't been solved in another thread, feel free to start a troubleshooting thread with your problem and we will try to help you as best we can.

Good luck!

*Not really, but I hope it will help some people.

Share this post


Link to post
Share on other sites

I believe I have a fix for the flickering in 4.0.1, which means disabling hardware acceleration won't be necessary.

 

I also should have much improved performance for the case where hardware acceleration has to be disabled.

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this