Sign in to follow this  
Simon Brown

(superseded) Simon B's plugin pack for 4.0 including CustomBrushesMini 2.2 beta

Recommended Posts

Hello.

I wanted the updated CustomBrushes plugin, so I deleted the one I had then tried to install this pack. I think all the plugins were added correctly, but now I can't find the newer CustomBrushes Mini. Did I goof somthing?
 
On the topic of layers, I don't know what kind of layers Null54 wants, but I would like to see brush sets be more usable.
You probably don't need this explained, but just so we're on the same page, here's what I mean...
I often get brushes from brusheezy, and most of them come in sets. Which is normally an abr file that has 2 or more brushes in it, each brush on it's own layer. These brush sets don't de-layer in CustomBrushes Mini, making it so the set of brushes are a single flattened brush. Because of this, I first have to use a program like abrMate to divide the brushes up. Once they are individual brushes, I can then use them in CustomBrushes Mini.
As a side note : Paint.NET has an ABR file extension plugin, using this plugin I have loaded the brush sets into Paint.NET, which opens the sets in layers.

 

 

PS : THANK YOU for your hard work and the plugin updates. <3

Edited by Cc4FuzzyHuggles

Share this post


Link to post
Share on other sites

@Cc4FuzzyHuggles, you could also download abrViewer from Source Forge.  It basically converts ABR file into individual graphic files in .PNG format.  I have used that method in the past.

 

@SimonBrown, is there any chance the interface could load a copy of a layer onto the canvas?  For example, lets say I have an outline of a sketch on Layer A, and I want to paint in Layer B.  I would copy the sketch from Layer A, then on Layer B, I would run the brush plug-in, and paste the sketch as a "layer" onto the canvas for guide.  I haven't tried that, by the way, I was curious if it was possible.

Edited by TrevorOutlaw

Share this post


Link to post
Share on other sites

@Cc4FuzzyHuggles, you could also download abrViewer from Source Forge.  It basically converts ABR file into individual graphic files in .PNG format.  I have used that method in the past.

 

I actually tried that program first, but for some reason it didn't work well on my PC, so I had to find an alternative. In the end I found abrMate, and I think in some ways I like it more. :)

Share this post


Link to post
Share on other sites

Would having that behaviour for few specific filetypes be sufficient? Is abr the main one you have in mind?

 

That would work, although it may be easier to check the SupportsLayers property than trying to detect specific filetypes.

The ABR filetype is the one that I was referring to.

Share this post


Link to post
Share on other sites

I wanted the updated CustomBrushes plugin, so I deleted the one I had then tried to install this pack. I think all the plugins were added correctly, but now I can't find the newer CustomBrushes Mini. Did I goof somthing?

Did you get it working? It should be under Effects -> Tools.

Share this post


Link to post
Share on other sites

Sorry, I still don't see it. The only way I see a custom brushes is if I put the older one back in my effects folder. Does it need to be in there first and the new one simply "updates" it?

Edited by Cc4FuzzyHuggles

Share this post


Link to post
Share on other sites

Custom Brushes mini not working on build 5284. It threw up this error about IMPDF File type even though I tried to open custom brush mini :/

 

Exception details:
System.TypeInitializationException: The type initializer for 'ImPDFPlugin.ImPDFFileType' threw an exception. ---> System.NullReferenceException: Object reference not set to an instance of an object.
   at ImPDFPlugin.ImPDFFileType..cctor()
   --- End of inner exception stack trace ---
   at ImPDFPlugin.ImPDFFileType.Debug(String message)
   at ImPDFPlugin.ImPDFSaveConfigWidget.Finalize()

Share this post


Link to post
Share on other sites

Sorry for the double post, but I can now report Custom brushes mini as working. I removed the ImPDF File type plugin and CBM is now working - Odd :/

Share this post


Link to post
Share on other sites

A stable version has been published in the plugins section.

Loading multiple layers as separate brushes hasn't been implemented, but may be considered for a later version.

Share this post


Link to post
Share on other sites

This has been superseded by the latest version of my plugin pack.)

I don't see it. Provide a link so a mod can pin it.

Share this post


Link to post
Share on other sites

I recommend releasing your 4.0 plugin pack in a new thread. It makes users aware that this may not work on 3.5.11.

If you are not supporting the old pack We Mods can lock it - or you can remove the link.

Share this post


Link to post
Share on other sites

When I posted my question he hadn't updated the thread title with an update date. I think he's fine.

Share this post


Link to post
Share on other sites

Are we talking about this one?  http://forums.getpaint.net/index.php?/topic/15218-simon-bs-plugin-pack-custom-brushes-editable-text-and-more-2014-06-22/

 

IMHO a change of date isn't enough to indicate to users that an update has taken place.  I would have missed it entirely in my monthly revision of the Plugin Index because I don't scan old thread titles.  

 

How about at least a post in the thread to indicate that all your plugins work with 3.5.11 and 4.0x?

 

Slightly aside:

 

I don't want to play hide-and-seek with plugin authors.  If any of you are revising or changing the contents of your plugin packs make it clear with a post or let me know via PM so I can update the Plugin Index.  A new thread is a great way to show me and others that new stuff exists, and it's date-stamped. 

Share this post


Link to post
Share on other sites

Sorry about that. I also posted in the CustomBrushesMini thread that an update had been posted. Apart from updating the date in the plugin pack thread, is there anything else I can do to make it clear?

Since 4.0 hadn't been released when I posted the update, I made sure the plugins supported 3.5.11 as well. However, support for 3.5.11 may be dropped in the next update.

I've added a notice that the plugins should work in 4.0 and 3.5.11.

Share this post


Link to post
Share on other sites

Thanks Simon.  Changing a post or a thread title doesn't raise a flag for me.  I rely on a new post or a new thread to see changes as these are flagged as "unread".  Either will do.  A PM would also work :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this