Martin Osieka

Print It (Tools Effect)

Recommended Posts

Ok Glenn, let's try some diagnostics :)

 

Can you open Settings > Diagnostics and click the Copy to Clipboard button

 

SettingsDiagnostics.png

 

Paste the clipboard contents into a post here.

 

While you have The Settings dialog open, click on the Plugin Errors tab and see if anything is listed.

Share this post


Link to post
Share on other sites

Hey there,

Here it is. I'm I don't have a plugins error option in the diagnostics box.

 

Thanks

 

 

 

 

Application    paint.net 4.0.21 (Final 4.21.6589.7045)
Build Date    Monday, January 15, 2018
Install type    Classic
    
Hardware accelerated rendering (GPU)    True
Animations    True
DPI    96.00 (1.00x scale)
Language    en-US
    
OS    Windows 10 Home x64 (10.0.17134.0) (0x65)
.NET Runtime    4.0.30319.42000
Physical Memory    3,518 MB
    
CPU    AMD A8-6410 APU with AMD Radeon R5 Graphics    
    Speed    ~1996 MHz
    Cores / Threads    4 / 4
    Features    DEP, SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, XSAVE
    
Video Card    AMD Radeon(TM) R5 Graphics
    Dedicated Video RAM    497 MB
    Dedicated System RAM    0 MB
    Shared System RAM    1,759 MB
    Vendor ID    0x1002
    Device ID    0x9851
    Subsystem ID    0xF9171179
    Revision    5
    LUID    0x0000999E
    Flags    None
    Outputs    1
    
Video Card    Microsoft Basic Render Driver
    Dedicated Video RAM    0 MB
    Dedicated System RAM    0 MB
    Shared System RAM    1,759 MB
    Vendor ID    0x1414
    Device ID    0x008C
    Subsystem ID    0x00000000
    Revision    0
    LUID    0x0000A052
    Flags    Software
    Outputs    0

Share this post


Link to post
Share on other sites

On Windows7 the plugin crashes if we select fonts that do not contain Regular style (for example, Aharoni or Vivaldi).
Windows10 treats fonts differently and the plugin works although it reacts very slowly.

Share this post


Link to post
Share on other sites

You got all the requisite files in the correct place?

 

Quote

Installation

- Copy the two files OptionBasedLibrary vX.X.dll/.dlc to the Paint.NET\ folder (NOT to Paint.NET\Effects\ !!!)
- Copy the two files PrintIt.Effect.dll/.dlc to the Paint.NET\Effects\ folder

 

Share this post


Link to post
Share on other sites

Before you ask, here are the diagnostics.

 

Application    paint.net 4.1.5 (Final 4.105.6913.325)
Build Date    Wednesday, December 05, 2018
Install type    Classic
    
Hardware accelerated rendering (GPU)    True
Animations    True
DPI    96.00 (1.00x scale)
Language    en-US
    
OS    Windows 10 Pro x64 (10.0.17763.0) (0x30)
.NET Runtime    4.0.30319.42000
Physical Memory    16,324 MB
    
CPU    Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz
    Speed    ~3492 MHz
    Cores / Threads    4 / 4
    Features    SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, AVX, AVX2
    
Video Card    NVIDIA GeForce GTX 1050 Ti
    Dedicated Video RAM    4,018 MB
    Dedicated System RAM    0 MB
    Shared System RAM    8,162 MB
    Vendor ID    0x10DE
    Device ID    0x1C82
    Subsystem ID    0x85C61043
    Revision    161
    LUID    0x00008774
    Flags    AcgCompatible, SupportMonitoredFences, KeyedMutexConformance
    Graphics Preemption    PixelBoundary
    Compute Preemption    DispatchBoundary
    Outputs    2
    Feature Level    Direct3D_12_1
    DXGI Formats    A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float
    Buffer Precision    UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc
    
Video Card    Microsoft Basic Render Driver
    Dedicated Video RAM    0 MB
    Dedicated System RAM    0 MB
    Shared System RAM    8,162 MB
    Vendor ID    0x1414
    Device ID    0x008C
    Subsystem ID    0x00000000
    Revision    0
    LUID    0x0000A104
    Flags    Software, AcgCompatible, SupportMonitoredFences, KeyedMutexConformance
    Graphics Preemption    InstructionBoundary
    Compute Preemption    InstructionBoundary
    Outputs    0
    Feature Level    Direct3D_12_1
    DXGI Formats    A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float
    Buffer Precision    UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc

Share this post


Link to post
Share on other sites

As a test I emptied the effects folder except the printit.dll and tried it. The plugin is very slow to open and then locks up PDN.

Any ideas?

Share this post


Link to post
Share on other sites

Try moving OptionBasedLIbrary v0.7.9.dll to another location (like your desktop) then restart PDN. I've only got v0.7 in the PDN directory.

Share this post


Link to post
Share on other sites

OK! I tried that but no luck. I even tried moving everything, all effects except printit, to the desktop. Uninstalled PDN then cleared the cache and reinstalled PDN. Still no luck!

I don't know!

Share this post


Link to post
Share on other sites

Maybe is something wrong with your printer driver?

 

After I updated to Windows v1803 (OS Build 17134.345) the plugin is running OK.

Edited by xod

Share this post


Link to post
Share on other sites

I'm running two different printers. A Brother and a Canon. I just tried disconnecting the Brother (my main printer) and it does the same thing on the Canon.

And everything is up to date.

Share this post


Link to post
Share on other sites

From Windows>Settings>Devices>Devices and printers you can try to change the default printer and than run the plugin again and see what happens.

 

RwL5iUJ.png

Share this post


Link to post
Share on other sites

Yeah, I tried it both ways. I'm convinced it's a Windows thing. Unless somebody else has any ideas.

Thanks @xod and EER!

Share this post


Link to post
Share on other sites

hello,  I am having issues printing since downloading two mayjor plugin packs, and did not have any issues prior to the download. The pictures are now printing very very dark. I calibrated my screen and even adjusting the exposure/contrast and lightness to a overly bright setting is still resulting in a dark print. I dont want to lose my plugins but I need to print. Please help!!! 

Share this post


Link to post
Share on other sites

I downloaded the PrintIt plug-in and copied the 4 files as instructed then restarted both Paint.net and my computer, but I don't see "Tools" in the Effects menu (or PrintIt elsewhere in Effects).

 

I'm running Windows 10, so I copied the 2 OptionBasedLibrary files to [my profile]\ThisPC\Documents\paint.net App Files, and the 2 PrintIt.Effect files to ...\Effects.

 

Can anyone help me activate PrintIt?

 

Thanks,

- Jeff H

Edited by jjeff
Clarify the plug-in name

Share this post


Link to post
Share on other sites
16 minutes ago, jjeff said:

I copied the 2 OptionBasedLibrary files to [my profile]\ThisPC\Documents\paint.net App Files, and the 2 PrintIt.Effect files to ...\Effects.

 

Place all 4 files into the Effects folder.

Share this post


Link to post
Share on other sites

Great add-in. Quick notes.
1. Documentation should show the layer/printIt option. I was looking in the printer dialog. I know it's in the text but, well, pictures? Thanks

2. Should force default to single sided since double-sided rarely makes sense in posters.

3. Caught the last note about putting all files into the Effects dir. It had hung on my first try with putting files in the main dir.

Share this post


Link to post
Share on other sites

Hello. I have been having enormous trouble in getting Print It (Tools Effect) to work properly on my Home Computer. The plug in either works slowly or not at all. The Home Computer runs Windows 10 Home 1903. The printer is an HP Deskjet 1000. The system software has been updated to the last Patch Tuesday (July 2019).  I have upgraded the drivers to the printer to the most recent version to no avail.

 

However: Print It (Tools Effect) works properly on my Work Computer. The Work Computer runs Windows 10 Enterprise LTSB 1607 with a networked connection to a Ricoh Printer/Copier/Fax Machine.

 

What other information do you need from me in order to fix this plug in so it works properly on these Computers?

 

Share this post


Link to post
Share on other sites
9 minutes ago, JRSwenson said:

The plug in either works slowly or not at all.

 

Please elaborate.

Share this post


Link to post
Share on other sites

Perhaps I was not sufficiently detailed on this. On my Home Computer when I attempt to use the Print It (Tools Effect) on the current image, the appropriate windows come up. However, when I attempt to do things like change the margins it takes many minutes for the plugin to respond. Sometimes attempting to make the changes causes PDN to lock up completely. I do not have these problems on my Work Machine.

 

I list here the diagnostics from PDN on my Home Machine:

<quote>

Application    paint.net 4.2 (Final 4.200.7133.32960)
Build Date    Saturday, July 13, 2019
Install type    Classic
    
Hardware accelerated rendering (GPU)    True
Animations    True
DPI    96 (1.00x scale)
Language    en-US
    
OS    Windows 10 Home x64 (10.0.18362.0) (0x65)
.NET Runtime    4.0.30319.42000
Physical Memory    3,533 MB
    
CPU    AMD A9-9430 RADEON R5, 5 COMPUTE CORES 2C+3G   
    Speed    ~3194 MHz
    Cores / Threads    2 / 2
    Features    SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, AVX, AVX2
    
Video Card    AMD Radeon(TM) R5 Graphics
    Dedicated Video RAM    505 MB
    Dedicated System RAM    0 MB
    Shared System RAM    1,766 MB
    Vendor ID    0x1002
    Device ID    0x98E4
    Subsystem ID    0x364F17AA
    Revision    196
    LUID    0x0000B1AE
    Flags    AcgCompatible, SupportMonitoredFences, KeyedMutexConformance
    Graphics Preemption    DmaBufferBoundary
    Compute Preemption    DmaBufferBoundary
    Outputs    1
    Feature Level    Direct3D_12_0
    DXGI Formats    A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float
    Buffer Precision    UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc
    
Video Card    Microsoft Basic Render Driver
    Dedicated Video RAM    0 MB
    Dedicated System RAM    0 MB
    Shared System RAM    1,766 MB
    Vendor ID    0x1414
    Device ID    0x008C
    Subsystem ID    0x00000000
    Revision    0
    LUID    0x0000BA35
    Flags    Software, AcgCompatible, SupportMonitoredFences, KeyedMutexConformance
    Graphics Preemption    InstructionBoundary
    Compute Preemption    InstructionBoundary
    Outputs    0
    Feature Level    Direct3D_12_1
    DXGI Formats    A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float
    Buffer Precision    UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc

</quote>

 

Since I am not currently at work, I will post diagnostics from the Work Machine when I have it.

Share this post


Link to post
Share on other sites

Here is the diagnostics for my work machine:

 

<quote>Application    paint.net 4.2 (Final 4.200.7133.32960)
Build Date    July 13, 2019
Install type    Classic
    
Hardware accelerated rendering (GPU)    False
Animations    True
DPI    96 (1.00x scale)
Language    en-US
    
OS    Windows 10 Enterprise 2016 LTSB x64 (10.0.14393.0) (0x7D)
.NET Runtime    4.0.30319.42000
Physical Memory    8,075 MB
    
CPU    Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz
    Speed    ~3600 MHz
    Cores / Threads    4 / 8
    Features    SSE, SSE2, SSE3, SSSE3, SSE4_1, SSE4_2, AVX, AVX2
    
Video Card    Intel(R) HD Graphics 630
    Dedicated Video RAM    128 MB
    Dedicated System RAM    0 MB
    Shared System RAM    4,037 MB
    Vendor ID    0x8086
    Device ID    0x5912
    Subsystem ID    0x07A11028
    Revision    4
    LUID    0x00009C5B
    Flags    None
    Graphics Preemption    TriangleBoundary
    Compute Preemption    ThreadBoundary
    Outputs    2
    Feature Level    Direct3D_12_1
    DXGI Formats    A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float
    Buffer Precision    UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc
    
Video Card    Microsoft Basic Render Driver
    Dedicated Video RAM    0 MB
    Dedicated System RAM    0 MB
    Shared System RAM    4,037 MB
    Vendor ID    0x1414
    Device ID    0x008C
    Subsystem ID    0x00000000
    Revision    0
    LUID    0x0000A167
    Flags    Software
    Graphics Preemption    InstructionBoundary
    Compute Preemption    InstructionBoundary
    Outputs    0
    Feature Level    Direct3D_11_1
    DXGI Formats    A8_UNorm, B8G8R8A8_UNorm, R16G16B16A16_UNorm, R16G16B16A16_Float, R32G32B32A32_Float
    Buffer Precision    UNorm8bpc, UNorm8bpcSrgb, UNorm16bpc, Float16bpc, Float32bpc

</quote>

 

I hope that someone knowing more about the internals of PrintIt can look at these two diagnostic files and determine why PrintIt works properly on the Work Computer and not on the Home Computer.

 

I also attempted to have PrintIt send data to the Bullzip Print to PDF application. PrintIt worked so slowly that PDN stalled and I had to kill the process.

 

I also read in this thread that someone used the previous version of PrintIt - Version 0.8 and it worked on his computer. I would like to try this version on the Home Machine to see if works, but I cannot find it. Can someone provide a URL to this version if it still exists?

 

Share this post


Link to post
Share on other sites
20 minutes ago, JRSwenson said:

Windows 10 Enterprise 2016 LTSB

 

At work you're using Win 10 2016 LTSB/LTSC

At home you're using Win 10 1903

 

Perhaps Microsoft changed something in Windows 10 within those 3 years. I have no idea. I guess you'll find out when you upgrade to 2019 LTSC at work. :P

 

20 minutes ago, JRSwenson said:

I also attempted to have PrintIt send data to the Bullzip Print to PDF application.

 

You're using that same PDF printer at both home and work?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.