Jump to content

'PostScript' FileType Plugin (.PS, .EPS, .AI)


Recommended Posts

8 hours ago, Djisves said:

Yet another of Martin's plugins with a broken download link.

I have a saved copy if a moderator needs it.

 

If you can let me have it @Djisves I can put it in the first post.  Thanks :)

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to post
Share on other sites
4 minutes ago, Djisves said:

Here you are. ImPS,EPS,AI.Open.FileType v1.0.zip

 

If it's it's OK to do it without permission from a moderator, I can upload a few more plugins that I found, in their own topics. This way we can save time and trouble. 

 

Thanks for the file @Djisves  No it's not possible for a member to edit threads.  Thee norm is for a member to send the info to a Mod who will then update it.  So if you have a list of other things, please send a PM to your favorite Mod 😁 who will then oblige.

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to post
Share on other sites

I meant for me upload on a new post, so that the moderator will go ahead and post it on the first post immediately. It saves time if I don't have to ask every time if it's OK to post it and then the moderator to have to reply and then wait for me to upload.

In any case, I think I have mentioned all that I have found, for the time being, in their own topics. You can reply as you read them.

Xkds4Lh.png

Link to post
Share on other sites
3 hours ago, Djisves said:

I meant for me upload on a new post, so that the moderator will go ahead and post it on the first post immediately. It saves time if I don't have to ask every time if it's OK to post it and then the moderator to have to reply and then wait for me to upload.

In any case, I think I have mentioned all that I have found, for the time being, in their own topics. You can reply as you read them.

 

Yes, that's fine too @Djisves as one of us would notice and then could add it to the first page :)

30b8T8B.gif

How I made Jennifer & Halle in Paint.net

My Gallery | My Deviant Art

"Rescuing one animal may not change the world, but for that animal their world is changed forever!" anon.

 
Link to post
Share on other sites
  • 3 months later...

I am running Paint.net 4.213.7521 64bit and have installed this plugin and GhostScript 9.26. I can open some .ai and .eps file, but when I tried to open the one, I get the following error:

 

Application version: paint.net 4.2.13

System.ArgumentException: Size of layer does not match size of containing document
   at OptionBasedFileTypes.OpenFileType.OnLoad(Stream input)
   at PaintDotNet.FileType.Load(Stream input) in D:\src\pdn\src\Data\FileType.cs:line 513
   at PaintDotNet.Functional.Func.Eval[T1,TRet](Func`2 f, T1 arg1) in D:\src\pdn\src\Base\Functional\Func.cs:line 158

 

I tried searching, but didn't find any posts with a solution. I can't attach a copy of the file since it's about 2MB.

  • Like 1
Link to post
Share on other sites
  • 4 weeks later...

That is not clear whether author is interested in maintaining the plugin project. Anyhow, big thanks for creating the original version!


Those who experience System.ArgumentException, please consider installing an older version of Paint.NET. I have tried Paint.NET v3.5.11 and it worked.

CAUTION: older version's Paint.NET installer will delete your newer version (even if a different folder is selected at the setup stage), and possibly the customizations. So, backup, backup, backup!

Edited by Neutron16
the info is incorrect
Link to post
Share on other sites
35 minutes ago, Neutron16 said:

Those who experience System.ArgumentException, please consider installing an older version of Paint.NET. I have tried Paint.NET v3.5.11 and it worked.

 

Could you upload a (family-friendly) file that causes this error in 4.2.14?

I am not sure why it would work in 3.5.11 and not 4.2.14,  both versions should throw the same error when the layer size does not match the document size.

  • Like 1
  • Thanks 1

PdnSig.png

Plugin Pack | PSFilterPdn | Content Aware Fill | G'MICPaint Shop Pro Filetype | RAW Filetype | WebP Filetype

The small increase in performance you get coding in C++ over C# is hardly enough to offset the headache of coding in the C++ language. ~BoltBait

 

Link to post
Share on other sites
On 11/1/2020 at 4:57 PM, null54 said:

 

Could you upload a (family-friendly) file that causes this error in 4.2.14?

I am not sure why it would work in 3.5.11 and not 4.2.14,  both versions should throw the same error when the layer size does not match the document size.

Sorry, I made a mistake. It was the wrong file. Wishful thinking...
I've edited the original post. Thank you for pointing out my mistake. 

Edited by Neutron16
grammar
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...