Sign in to follow this  
yezo

Blurry UI Fonts

Recommended Posts

Hi,

 

Thanks for the great program, I have been using it for years, and love it.

 

I tried the last alpha of the version 4.0, and it appears that all the UI text appears blurry (probably due to the fact its now being drawn with Direct2D, not GDI).

 

Here is the comparison between the old and the new:

 

post-134632-0-82780600-1387434511_thumb.

 

As you can see, the new UI text really stands out of the standard Windows text look, and is harder to read.

 

I tried disabling "hardware accelerated rendering" in settings, but it didn't affect the UI text.

 

The same problem of text "bluriness" was present in WPF until .NET 4.0, where it was addressed after numerous user requests, and before shipment of VS2010, which uses WPF for the code editor.

 

Please consider this problem, because for many of the users (such as me) it may appear as a big user interface flaw. My suggestion is at least to make the "hardware accelerated rendering" setting affect the way the UI text is rendered.

 

Thank you,

Yevgeni Zolotko.

Share this post


Link to post
Share on other sites

Direct2D doesn't have to be the reason, you can replicate this with GDI+ too. There are a lot of properties you can change in .Net when drawing text and will be able to get a lot of different amounts of blurry text ^^

For example this code:

    Private Sub Form1_Paint(sender As Object, e As PaintEventArgs) Handles Me.Paint
        e.Graphics.CompositingQuality = Drawing2D.CompositingQuality.AssumeLinear
        e.Graphics.SmoothingMode = Drawing2D.SmoothingMode.HighQuality
        e.Graphics.PixelOffsetMode = Drawing2D.PixelOffsetMode.HighQuality

        e.Graphics.FillRectangle(Brushes.White, 0, 0, 500, 100)
        e.Graphics.TextRenderingHint = Drawing.Text.TextRenderingHint.ClearTypeGridFit
        e.Graphics.DrawString("File     Edit     View     Image     Layers     Adjustments     Effects", New Font("Segoe UI", 9), Brushes.Black, 20, 20)
        e.Graphics.TextRenderingHint = Drawing.Text.TextRenderingHint.AntiAlias
        e.Graphics.DrawString("File     Edit     View     Image     Layers     Adjustments     Effects", New Font("Segoe UI", 9), Brushes.Black, 20, 40)
    End Sub

produces this:

post-134676-0-33362700-1387837226_thumb.

 

The first line is what I would consider good and the lower line seems blurry.

Share this post


Link to post
Share on other sites

Hi everyone,

 

The point of my post is: currently, in the new Paint.NET, UI font rendering is seriously different from the rest of the system.

I hope this is obvious. I just wanted point out this is not desired behavior for most of Windows users.

 

About the ClearType tuning tool: my ClearType is tuned OK by default. For example, in Windows Explorer the text is rendered perfectly.

 

The problem is in rendering the text with different API, or with different settings.

 

You can try this link to see the feedback to the same problem in Firefox: https://www.google.com.hk/search?q=mozilla+firefox+font+harware+acceleration&oq=mozilla+firefox+font+harware+acceleration&aqs=chrome..69i57.9931j0j7&sourceid=chrome&espv=210&es_sm=93&ie=UTF-8

Happily, the "hardware acceleration" can be turned off in Firefox, and thus the problem with fonts can be solved. I just want to have the same in Paint.NET.

 

Please take this into account.

 

Thank you,

Yevgeni Zolotko.

Share this post


Link to post
Share on other sites

The point of my post is: currently, in the new Paint.NET, UI font rendering is seriously different from the rest of the system.

 

Indeed. A better default value for font rendering should be chosen (I don’t think Paint.NET should regress in functionality just for this (it should stay in DirectWrite), but there’s room for improvement here, I think.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this