Jump to content

Transparency quirk - Part shows transparent but still prints white


Recommended Posts

I have succeeded in making a graphic background transparent....

However,

There are 4 small sections that appear transparent but when i hit the wand they are a different transparent color (still white and grey little boxes but don't turn pale blue on top when i hit the wand...

And,

It is these 4 small areas that still print white.

I don't know if i messed it up with layers before ... but i am guessing???

These areas won't erase again because they show as erased.

I tried copying and pasting in paint.net a variety of formats... Gif, Jpeg, Pnd and then tried erasing again and although Jpeg did erase.... i was back to square one and these 4 small areas keep printing white.

Anyone got any clues how i can transparent these 4 small areas?

Jd

<snip>

Link to comment
Share on other sites

I took your image and magic wanded it: everything seems fine:

 

Th2Fe.png

 

Edit: Oh, I see your problem. You want to get the areas in between the horse legs. To do that, change the magic wand's fill mode to global:

 

cIyyp.png

Edited by OddLlama

Here is my website - http://www.oddllama.cu.cc

Here is my gallery - http://oddalpaca.deviantart.com/gallery

Am I odd? - yes

Am I a llama? - yes

Link to comment
Share on other sites

Uh Oh... Odd Llama....

 

Global worked until i opened it again.

 

I went to check my horse graphic before i sent it.  It was saved as a Jpg. I 'opened with' ... Paint.net.... clicked on the wand and the same spaces between the horses legs are not transparent.

Link to comment
Share on other sites

the .jpg image filetype does not support transparency. If you want the spaces to be transparent, you have to save as either a .gif or .png image.

 

what I do all summer Emote Cursor Pack 'noob gallery

No, Paint.NET is not spyware...but, installing it is an IQ test. ~BoltBait

Blend modes are like the filling in your sandwich. It's the filling that can change your experience of the sandwich. ~Ego Eram Reputo

Link to comment
Share on other sites

Hello pdnnoob,

I appreciate what you are saying. However, when i open the jpg with Paint.net (it is saved in paint as a jpg) everything stayed transparent except the 4 small spaces inside the horses legs.

I am guessing i must have missed erasing them before and maybe it is a layers thing?

Odd Llama was right about switching the wand to 'global' this did erase those 4 small areas... but when i saved it as a jpg again and reopened it in paint.net again those 4 small places are still not transparent.

The erase initially and saving in jpg did retain the transparency around 99% of the graphic. I am using this for a book cover and i have got to get that white out... i must submit the graphic as a jpg or a tiff

Link to comment
Share on other sites

JPG's DO NOT support transparency.  Check you've got the correct file extension and not something like MyFile.jpg.png

 

If you erase and save as a png the transparent areas will be preserved.  If you have saved it as a jpg - it cannot have transparent areas.

 

TIP: you can toggle to Global mode by holding down the Shift key ;)

Link to comment
Share on other sites

I understand that Jpg's do not support transparencies. When i open the jpg in paint and click on the wand the entire background is removed but those 4 small spaces.

On my final edit of a book those 4 small spaces are the only white part showing up in the background of my book cover.

yes, in paint i can click on global and they go transparent. I saved it in jpg b4, again, opened it with paint and clicked on the wand and all but 4 small areas were transparent. how come when i repeat this process the 4 small areas are still white? And, these 4 small white places are the only white area showing on my book cover - and, i submitted the graphic to the publisher in jpg.

Maybe i will try saving it as a gif or png then resaving it as a jpg - since i must submit it as a jpg.

I really appreciate your input!

Link to comment
Share on other sites

1. Select the areas directly.  You can chain multiple selections together with the Add mode (hold down the Ctrl key when making more selections).

 

2. Press Delete to erase them. 

 

3. Then save the image as a PNG.

 

4. Import your new PNG to your book cover.  When you flatten and save as a jpg the areas will behave as you wish (allowing the background to show through).

Link to comment
Share on other sites

Ok Ego Eram Reputo,

I think you are telling me to

1. erase all of the background areas - i did this

2. I deleted all of the background areas

3. I saved it as a PNG.

4. I am not the one importing it into my book cover, the publisher needs to receive my graphic in jpg form.

I can see what the problem is from my side. The 4 small leg parts may be transparent now but i have no way of checking.....

Here's the problem. When i open up any graphic back into paint.net - click on the wand... and here is the problem on my side.... i have to change wand to global every time b4 clicking wand on graphic page. Flood mode keeps reverting to contiguous.

So, I don't have any idea what my book publisher will see (if the 4 small places will still be transparent)and i am not eligible to send this to them another time after this next submission.

I am not sure if i have another option to your #4? when does my graphic get flattened? I must submit it as a jpg like i did 24 other pictures which i was successful at cutting out the backgrounds.

Link to comment
Share on other sites

Ask your book publisher to make the background transparent for you then. jpeg files don't support transparency, so just send the non-transparent image to your publisher and tell him what needs to be transparent. If your publisher doesn't know how to do such a thing, they should have gone out of business long ago.

 

what I do all summer Emote Cursor Pack 'noob gallery

No, Paint.NET is not spyware...but, installing it is an IQ test. ~BoltBait

Blend modes are like the filling in your sandwich. It's the filling that can change your experience of the sandwich. ~Ego Eram Reputo

Link to comment
Share on other sites

Glad you got it figured out now! I'm always happy to help, so feel free to post more questions if you have any :)

 

what I do all summer Emote Cursor Pack 'noob gallery

No, Paint.NET is not spyware...but, installing it is an IQ test. ~BoltBait

Blend modes are like the filling in your sandwich. It's the filling that can change your experience of the sandwich. ~Ego Eram Reputo

Link to comment
Share on other sites

It didn't work. i opened it in paint - not paint.net - i filled the background with a color and the 4 small areas are still white.

Was your fill bucket in global mode? EDIT: oh, you used paint. Paint doesn't have a global mode so that is what should have happened. They really are transparent (if you save in PNG).

Edited by OddLlama

Here is my website - http://www.oddllama.cu.cc

Here is my gallery - http://oddalpaca.deviantart.com/gallery

Am I odd? - yes

Am I a llama? - yes

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...