Sign in to follow this  
Xevoius

Removing PNG Transparency Halo Effect

Recommended Posts

Greetings,

I have been using the Red Ochre "Selection2Clear" plugin to remove this effect but it only seems to sometimes work.

How do most of you get rid of this effect? I can only see this in my game and I am trying to figure out a way to guarantee that none of my PNG artwork has this.

~Cheers

Edited by Xevoius

Share this post


Link to post
Share on other sites

select the area where the halo appears using the magic wand selection tool, add a new layer, and fill the selection with black.

Then, select the whole layer (with the black) and copy it (ctrl+c). Delete the layer when you are done.

Use the alpha mask plugin with "mix alpha" and "from clipboard" checked.

This should set the transparency of those areas all the way to 0. If the edges end up being pixelated, use the "AA's Assistant" plugin on the black layer before you copy it.

Share this post


Link to post
Share on other sites

Thank you very much for the help.

I am a programmer and not an artist and ideally I would like to find a simpler solution for this as I will want to make sure that no art accidentally gets into my game with this problem.

I will give this one a try.

Share this post


Link to post
Share on other sites

I already think I may have found a solution with the "Selection2Clear" plugin.

I tried what you had suggested but I did a Shift-Magic Wand on all of the transpartent parts of the image at one time (had to adjust the Tolerance to get the multi-selection correct), then did a Shift-Paint Bucket to fill all of the background to black and then saved the image.

Then, while the image still had the transparent (now black) parts of the image still selected, I finally used the "Selection2Clear" plugin and the resulting image once saved no longer shows up with a halo effect on the edge where the transparency begins.

Thanks again.

Edited by Xevoius

Share this post


Link to post
Share on other sites

I can't seem to find a clean solution.  I am still having the transparecy issue where I get a halo effect.  Sometimes I am able to remove it and sometimes I am not.

 

I have not found soution that works every time using a step by step process.

 

Can anyone give me a hand?

 

I think this is what I do that seems to work most of the time.

 

Select the transparent area, fill in with Black and while still selected delete the selection using "selection2clear" plugin and save...??

 

Thanks.

Edited by Xevoius

Share this post


Link to post
Share on other sites

Hello Xevious,

Now I'm not sure what exactly you mean by the the 'Halo' effect but I'm guessing it has to do with the colour (BGR)values of the 'transparent' areas of the png, or possibly areas not being fully transparent.

 

My 'selection2clear' originally set the colour values to white(BGR all = 255) and the transparency to 0. These are the initial values of a transparent new layer. However I was advised to change this so that only the Transparency was changed to 0, so that people could get the information back if required.

 

If you want to set the 'colour ' of the transparency I would recommend using 'Object2colour' (also in my pack) - You can then choose what to do with the fully opaque, semi-transparent edge pixels and the fully transparent background OR simply select 'clean clear' from the drop down menu at the bottom. This will set all fully transparent pixels to white and leave opaque and translucent (AA'd edge pixels) unchanged.

 

 

[Edit - previously misread the code and it infact does what it should - setting the transparency to white.]

 

- You can always use the 'reveal all at 255' checkbox to check what colour the transparency is - don't forget to uncheck it before running it though.

 

In summary, continue using 'selection2clear' for erasing (if you need to maintain the selection) and use 'Object2colour'  setting [opaque to unchanged,translucent to unchanged and transparent to white],before saving as a png.

 

I hope that helps and if it doesn't please reply and hopefully we can work out what the problem is. ;)

Share this post


Link to post
Share on other sites

If the "color" of the transparent areas is what causes the problem, set your color to a completely transparent black or a transparent white (using the color window), then select the area and press backspace.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this