Jump to content

Removing white around images


Recommended Posts

Either you or the website is converting the image from a filetype that can handle transparency (like .png) to .jpeg.

 

what I do all summer Emote Cursor Pack 'noob gallery

No, Paint.NET is not spyware...but, installing it is an IQ test. ~BoltBait

Blend modes are like the filling in your sandwich. It's the filling that can change your experience of the sandwich. ~Ego Eram Reputo

Link to comment
Share on other sites

pdnnoob is correct. If you are not converting the file types then it is being coverted at the remote website. To put an end to the puzzle, right click of the image at the remote website and select 'Properties' in Internet Exlporer or select 'View Image Info' in Firefox. It will reveal the MIME type of the web image. You will see that they are being coverted to JPEGs.


 

Link to comment
Share on other sites

I checked that just now, and the file is still a png. Here is the image. This forum has a white background so the area around the image looks transparent, but my blog has a darker background and the white border shows up around it. If you click on the view image option in your browser, the image opens in a new window and it has a white background.

j7VALu61qwCN5_e.jpg

Edited by Cavalcade
Link to comment
Share on other sites

The posted image is a PNG with a JPG appended onto the filename. JPG's definitely don't support transparency, but PNG's do.

When I copied the image into Paint.NET the background was transparent - supporting the theory that this is in fact a badly named PNG. I'd recommend properly renaming it as this may be the source of the problem (some viewers thinking this is a JPG and others thinking is is a PNG).

Further questions should the above not resolve the problem:

Is the entire background is white? Or is there a thin white edge around the magnifying glass?

If the last is correct - try using AA's Assistant to remove the edge.

Link to comment
Share on other sites

No luck. I tried again with an image that started out as a png. Then I did the magic wand thing and surrounded it with the checkerboard. Saved it as a png file, and when I tried to post it on my blog, it still had the white background. The background was only invisible when I layered it over another image in Paint.net. Is there something I'm missing here.

Link to comment
Share on other sites

1. Did you fix the filename by removing the bit that says "JPG" ?

2. Does your blog software actually support transparency?

Link to comment
Share on other sites

1. Did you fix the filename by removing the bit that says "JPG" ?

2. Does your blog software actually support transparency?

I couldn't remove "JPG,"because I can't see it in the file name, only png. I'm with blogger, so I'm not sure if it supports transparency or not.

Are you, by chance, using IE6?

No, my browser is Firefox.

Link to comment
Share on other sites

Reopen the image in Paint.NET. Use File | Save As.... to specify a NEW filename. Do NOT type in the extension - select the PNG extension from the drop down list in the Save As.. dialog. Ensure you're using the default settings in the PNG options that follow.

Now try that image in your blog/browser.

Link to comment
Share on other sites

Reopen the image in Paint.NET. Use File | Save As.... to specify a NEW filename. Do NOT type in the extension - select the PNG extension from the drop down list in the Save As.. dialog. Ensure you're using the default settings in the PNG options that follow.

Now try that image in your blog/browser.

Okay, I just found out that the png file is being changed to a jpeg at Minus where I upload my pictures. But even when I post directly to blogger, from my hard-drive, I get the same result. The white border still shows. However, when I posted the same image to another website it was transparent. So it seems to be blogger that is not compatible with transparency.

Edited by Cavalcade
Link to comment
Share on other sites

yeah. Usually, the typical image hosting sites we use are tinypic, imageshack, and photobucket; all of which support .png filetypes. If you can, upload to tinypic (it's the easiest) and see if you can use that on your blog. If so, I think you answered your own question :D

 

what I do all summer Emote Cursor Pack 'noob gallery

No, Paint.NET is not spyware...but, installing it is an IQ test. ~BoltBait

Blend modes are like the filling in your sandwich. It's the filling that can change your experience of the sandwich. ~Ego Eram Reputo

Link to comment
Share on other sites

Okay, I just found out that the png file is being changed to a jpeg at Minus where I upload my pictures. ...

yeah. Usually, the typical image hosting sites we use are tinypic, imageshack, and photobucket; all of which support .png filetypes. ...

The problem not with Minus.

I use Minus for all my image hosting needs and I assure you that it supports PNGs and transparency just fine.

Xkds4Lh.png

Link to comment
Share on other sites

I often have this same issue on a few websites and is always due to image compression & conversion features. The easiest thing to do is to add a new layer to the magnifying glass image then place that new layer below the original image and use the "hex value" color option with the "fill tool" to set the new layer to the same color as the blog. You can then flatten all layers and save it as a ".jpg". I had to clean up the magnifying glass a little bit for this example. Click the 2nd image to enlarge it if needed. Hopefully this helps! :D

Magnifying Glass / PNG format

magnifyingglass.png

Add new layer / move new layer to the bottom / use "hex value" to set color / use "fill tool" to color the layer

addnewlayerpreview.jpg

Edited by RFX

RFX5A1.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...