Jump to content

Overlaying image is showing checkerboard background when saved.


Recommended Posts

Hello,

I have an issue with a transparent image. So, I have an image of someone & I want to paste an image of a transparent heart around their face, which I also have. I open the heart in Paint.net & notice the checkerboard background, which means that the background is transparent. I then copy & paste it onto the image of the person but the heart still has the checkerboard background instead of being transparent & it is covering the face. Also, when I saved the heart image on my Mac desktop, the thumbnail had a white background but when I opened it in Preview & iPhoto, it was transparent. Can you please help me?

Thank you,

Jacob Saunders

PS: I have Parallels Desktop so I'm running Mac & Windows side-by-side.

Link to comment
Share on other sites

Hi Jacob - welcome to the forum!

It sounds like you're simply getting the layer order wrong. You will need two layers - one for the face and one for the heart. You want the heart with the transparent background in the layer below the one with the face. Activate the Heart layer (by clicking on it in the Layers window) and move it down using the :MoveLayerDown: icon in the Layers Window.

RE: Saving it to MAC: Not transparent? - that sounds like a Mac issue. There is no problem with the image (as you have found it, correctly has transparent areas when opened in the appropriate software). Try asking this one on a Mac forum.

I don't know what image files the Mac supports or what you're saving it as - bear in mind that JPG does not support transparency. PNG does.

<Moved to Paint.NET Discussion & Questions>

Link to comment
Share on other sites

1. Activate the heart layer by clicking on it in the Layers Window.

2. Select the Magic Wand tool :MagicWandTool:

3. Hold the Shift key down and click on the white background. Note: if the entire background is not selected - fine tune the Tolerance setting in the Tool Bar and select again.

4. press Delete.

Link to comment
Share on other sites

Dark blue is the selection region. Press the Esc key to deselect.

Link to comment
Share on other sites

Upload both images to a hosting site and post the links here. I think we need to see whats going on with your images in order to help you.

Link to comment
Share on other sites

Ok. the Heart image has a transparent background, but the centre of the heart is filled with white. I assume you want to relocate Wanda's head so it appears framed by the heart:

yhsjjie-71.png

Here's how I did this...,

1. open both images.

2. Activate the Wanda image and select the magic wand tool :MagicWandTool:

3. In the Tool Bar, lower the Tolerance slider to 25%

4. Click beside Wanda's head to select the area around her head (like her 'aura').

5. Press delete. That's removed (most of) the background around Wanda's head and face.

6. Press Ctrl + A (to Select All), then press Ctrl + C to copy.

7. Activate the heart image.

8. Add a new layer :AddNewLayer:

9. Press Ctrl + V to paste Wanda into the new layer. When prompted, choose the option to keep the canvas the same size.

10. Select the Gradient tool :GradientTool:

11. In the Tool Bar, choose the Radial :RadialGradient: and Transparency :AlphaChannelOnly: options.

12. Click in the centre of Wanda's face and drag outwards until you're satisfied with the fading.

Save as a PDN then flatten and save in the format you require.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...