Sign in to follow this  
JLUC

Eventlog : .NET Runtime optimization Error 1101

Recommended Posts

Hi all,

I'm new on the forum, but I used paint.net for a while ; it's a realy nice tool.

I'm now looking to deploy paint.net by script (not GPO, I'm using another tool : WPKG).

I had build a test environnement with fresh WinXP, WinXP-64 and Win7-64, and I'm testing paint.net on it.

Each computer is update (trought WSUS), and .Net framwork 2.0-SP2, 3.0-SP2, 3.5-SP1 and 4.0 are installed.

I've made the msi deployment package with the following command :

Paint.NET.3.5.10.Install.exe /createmsi CHECKFORUPDATES=0 CHECKFORBETAS=0 JPGPNGBMPEDITOR=1 TGAEDITOR=1 ALLUSERS=1 DESKTOPSHORTCUT=1

The package (x86 for WinXP, x64 for WinX-P64 and Win7-64) are deployed with this msiexec command :

msiexec.exe /i paintmsifile.msi /quiet /norestart

Paint.NET is running well on each computer, but I've an error in the evenet log concerning a paint.net file :

.NET Runtime Optimization error 1101

--- Win XP ---

.NET Runtime Optimization Service (clr_optimization_v4.0.30319_32) - Failed to compile C:\Program Files\Paint.NET\PaintDotNet.SystemLayer.Native.x64.dll because this image is not a valid Win32 application.

--- Win XP 64 ---

.NET Runtime Optimization Service (clr_optimization_v4.0.30319_64) - Failed to compile C:\Program Files\Paint.NET\PaintDotNet.SystemLayer.Native.x86.dll because of the following error:  is not a valid Win32 application. (Exception from HRESULT: 0x800700C1).

--- Win 7 64 ---

.NET Runtime Optimization Service (clr_optimization_v4.0.30319_64) - Failed to compile C:\Program Files\Paint.NET\PaintDotNet.SystemLayer.Native.x86.dll because of the following error:  n’est pas une application Win32 valide. (Exception from HRESULT: 0x800700C1).

Because there is an x64 error on x86 computer and x86 error on x64 ones, I check files : there is x86 and x64 "PaintDotNet.Native.x--.dll" files on each computer. Could it be the problem ?

As I say before, Paint.Net is running well, but I don't want to deploy a tool if the installer is not perfect.

I didn't found any clear answer of this problem in the FAQ, the Forum or with google. Sorry if I miss somthing.

For sure I use the last version : 3.5.10

Manyt thanks to who can help me :)

Share this post


Link to post
Share on other sites

Thanks for this fast answer Rick.

And many, many thanks for your work on Paint.net.

Julien.

Edited by JLUC

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this