Jump to content

Unnecessary dependency on .NET 1.1


Recommended Posts

.NET was specifically designed to allow multiple versions of itself to be installed, so don't worry about having both of them installed. We built Paint.NET to work with .NET 1.1, and thus we require it to be present. .NET 2.0 is not just some superset of .NET 1.1 -- it changes how some things behave!

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to post
Share on other sites
  • 1 month later...

Yeah, if you install .NET 1.1, then install Paint.NET, then install .NET 2.0, and then uninstall .NET 1.1 ... it'll still work. Probably. No guarantees, of course (we certainly haven't tested it out). Our installer requires that .NET 1.1 is installed, but we don't enforce that when our app runs.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to post
Share on other sites

We will not be changing that requirement with our v2.5 release. You can have both .NET 1.1 and .NET 2.0 installed at the same time, and we have not done any testing under .NET 2.0. It might run fun or it might crash and die or corrupt things in other mysterious and random ways. We can't know until we get enough time with it.

Like our FAQ, http://www.eecs.wsu.edu/paint.net/faq.htm , says (emphasis added):

I already have .NET 2.0 installed, why does Paint.NET say that .NET 1.1 is required?

The first thing to understand is that the various versions of the .NET Framework are designed to be installable together in a side-by-side fashion. If you have .NET 1.0 and .NET 1.1 installed, and run a program that was built to run on .NET 1.0, then it will use the .NET 1.0 DLL's and functionality even though .NET 1.1 is present. Newer versions of .NET do not necessarily supercede older versions. Quite often functionality is added or changed in newer versions and it's very important to us that Paint.NET functions in exactly the way we designed it to.

The confusing part for the user is that installing .NET 2.0 does not install .NET 1.1 or 1.0. With other redistributable packages, such as DirectX 9.0, you are actually installing all the previous versions as well. .NET uses a different type of versioning that is alien for most users (and many developers) at this time.

Because of all this, we can't yet predict how Paint.NET will behave if it is run with .NET 2.0. It may run fine for the most part, or maybe it will behave oddly, crash, or worse. Because we prefer that Paint.NET run reliably for users, we require that .NET 1.1 is installed even if .NET 2.0 is already there. If you already have .NET 2.0 installed, you simply need to install .NET 1.1 as well. It will not erase or corrupt your .NET 2.0 installation.

Our v2.6 release will be built completely on top of .NET 2.0. The timing is just not that great in this one case.

The Paint.NET Blog: https://blog.getpaint.net/

Donations are always appreciated! https://www.getpaint.net/donate.html

forumSig_bmwE60.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...